Want to read Slashdot from your mobile device? Point it at m.slashdot.org and keep reading!


Forgot your password?
Linux Hardware

Ask Slashdot: Linux-Friendly Motherboard Manufacturers? 352

dotancohen writes "I am tasked with building a few Linux machines for a small office. However, many the currently available motherboards seem to be Linux-hostile. For instance, in addition to the whole UEFI issue, my last install was a three-day affair due to the motherboard reporting a Linux-supported ethernet device (the common RTL8168) while it was actually using a GbE Ethernet device that does not work with the legacy drivers and didn't even work with a test Windows 7 install until the driver disk was installed. There are no current hardware compatibility lists for Debian or Ubuntu and I've received from Asus and Gigabyte the expected reply: No official Linux support, install Windows for best experience. I even turned to the two large local computer vendors, asking if they could provide Linux-compatible machines ready to go, but neither of them would be of any help. What globally-available motherboards or motherboard manufacturers can you recommend today?"
This discussion has been archived. No new comments can be posted.

Ask Slashdot: Linux-Friendly Motherboard Manufacturers?

Comments Filter:
  • Intel? (Score:5, Informative)

    by IceNinjaNine ( 2026774 ) on Friday December 28, 2012 @01:19PM (#42411793)
    Aren't just plain Intel boards, with Intel NICs and Intel HD graphics supposed to be 'out of the box' open source friendly?
  • system 76 (Score:2, Informative)

    by Anonymous Coward on Friday December 28, 2012 @01:20PM (#42411809)

    I have heard good things about system 76

  • Easy (Score:5, Informative)

    by kimvette ( 919543 ) on Friday December 28, 2012 @01:23PM (#42411841) Homepage Journal

    I have yet to try a motherboard which is not Linux-friendly in recent years. Every single server board I have ever tried has worked flawlessly. Every true hardware RAID controller (be it integrated or PCI-X, PCI-E, or PCI) has been supported natively, and software/hybrid/fakeraid controllers have always been supported in JBOD mode. Integrated Intel or Matrox video works fine.

    Workstation/desktop boards? Aside from bluetooth, wifi, or weird video chipsets, they are supported fine. Ethernet ports used to require some tweaking (especially for Marvell controllers) but even those enjoy good support. If you want a good, fast board check out the GA-Z77X-UD5H-WB

    As far as UEFI is concerned - if you run 32-bit RHEL/CentOS/Scientific Linux, you won't be able to boot the 32-bit disc with UEFI enabled, but why would you forgo the flat memory space of a 64-bit board now that RAM is dirt cheap? Boot 64-bit disc and it works just fine. I have UEFI enabed on my GA-Z77X-UD5H-WB and it is fully supported out of the box by OpenSUSE and both Centos and RHEL 6.3. It's more work to get full support in Linux, actually, because the Linux install Just Works(TM). To boot Windows 7, I had to make a Windows 7 USB key. It booted 64-bit Linux just fine.

  • Re:Intel? (Score:5, Informative)

    by jedidiah ( 1196 ) on Friday December 28, 2012 @01:23PM (#42411853) Homepage

    Or just search Google. The reviews on sites like Newegg or Amazon might also indicate Linux friendliness or just the general level of quality. Then there are sites like Phoronix.

    In other words: Just search Google. It's not 1996.

    Someone mentioned System76. There's also Zareason.

    Once again: Just search Google. It's not 1996.

  • Re:Raspberry Pi (Score:5, Informative)

    by NFN_NLN ( 633283 ) on Friday December 28, 2012 @01:24PM (#42411867)

    "I am tasked with building a few Linux machines for a small office." I'm not sure how much your labor is worth but you can buy a built server on the cheap ($599).

    http://www.dell.com/ca/business/p/poweredge-t110-2/pd [dell.com]

    Operating System

            Microsoft® Windows® Small Business Server 2011
            Microsoft® Windows Server® 2008 Foundation R2 SP1
            Microsoft® Windows Server® 2008 SP2, x86/x64 (x64 includes Hyper-V)
            Microsoft® Windows Server® 2008 R2 SP1, x64 (includes Hyper-V v2)
            Novell® SUSE® Linux® Enterprise Server
            Red Hat® Enterprise Linux®

  • This MB worked (Score:5, Informative)

    by future assassin ( 639396 ) on Friday December 28, 2012 @01:29PM (#42411915) Homepage

    I just built an HTPC and this is what I used for my mb/cpu

    MSI FM2-A75MA-E35 mATX FM2 A75 DDR3 1PCI-E16 2PCI-E1 1PCI SATA3 HDMI DVI USB3.0 Motherboard
    AMD A8-5600K APU Quad Core Processor Socket FM2 3.2GHZ 4MB 100W Retail Box

    works fine here right out of the box with no BIOS settings. I have Linux Mint 14 Mate running on it. The only issue I had was getting audio over HDMI but for some reason downloading and installing the AMD propitiatory drivers wouldn't install Catalyst. I had to go and install the CCC through the package manager. Reboot and audio over HDMI worked.

    If you want to stick to the open source drivers and want to have sound over HDMI (if it doesn't work) try this

    Edit to /etc/default/grub and add




    To make it look like this
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

    Haven't tried it with my HTPC but did it with my sons laptop. Also with the laptop I had to disable two settings in the BIOS and create an EFI partition but the install of Linux Mint 14 KDE went smoothly an games seem to be running good with the open source drivers.

  • Re:Intel? (Score:4, Informative)

    by Sparticus789 ( 2625955 ) on Friday December 28, 2012 @01:29PM (#42411919) Journal

    My office exclusively uses Intel motherboards (for SecureBIOS) and I have yet to have any compatibility issues with Ubuntu, Fedora, Debian, RHEL5, and CentOS.

  • by agoliveira ( 188870 ) <adilson@@@adilson...net> on Friday December 28, 2012 @01:30PM (#42411921)

    http://www.ubuntu.com/certification/ [ubuntu.com] shows desktops and servers classified by vendor, distro, etc

  • Re:Raspberry Pi (Score:5, Informative)

    by LordLimecat ( 1103839 ) on Friday December 28, 2012 @01:42PM (#42412041)

    Theyre also several times their component cost, and horribly cost-ineffective if you are throwing OSX out the window.

    Intel chipsets tend to be supported very well. Generally if you want to know compatibility, dont look @ "is this motherboard supported", just look at whether:
      * The northbridge is supported
      * The southbridge is supported
      * The NICs are supported

    Generally Intel stuff is VERY well supported, and GENERALLY year-old chips are supported fairly well. Try to stay away from brand new stuff unless youve done the research to make sure the kernel supports it. Googling something like "Linux support RTL8187" or "linux support P77" should give you some ideas. I wouldnt sweat it too much tho, just pilot one machine and if it goes well roll the config out.

    Im not super clear on why UEFI would cause a big issue for a Linux install, but I also havent paid that much attention to it. I have an ASUS UEFI mobo, and I believe it had an option to pretend to be a normal BIOS or something, though Im using Win8 and havent really messed with it.

  • by AliasMarlowe ( 1042386 ) on Friday December 28, 2012 @02:04PM (#42412203) Journal

    According to Phoronix [phoronix.com], the Intel DZ77GA-70K and the ECS Golden Board Z77H2-A2X are fine for Linux. It is implied that almost any motherboard with the Intel Z77 chip set should be OK for linux. They did a longer follow-up review on the ECS Z77H2-A2X Ultimate Golden Edition Extreme [phoronix.com] with linux.

  • Re:Raspberry Pi (Score:4, Informative)

    by Nerdfest ( 867930 ) on Friday December 28, 2012 @03:12PM (#42412657)

    Strange, I use 64 bit Linux pretty much exclusively and use quite a lot of 32 bit software, including Flash.

  • Re:Raspberry Pi (Score:4, Informative)

    by hairyfeet ( 841228 ) <bassbeast1968 AT gmail DOT com> on Friday December 28, 2012 @06:02PM (#42414291) Journal

    But don't SUSE and RHEL require sever contracts to get updates? that would probably make going the server route not a good deal.

    I still think the best bet would be to go AMD AM3, you can get a complete 6 core kit for $260 after MIR [tigerdirect.com] and if you can get by with a dual or quad you can shave another $70 or so off that. The board is using the 760 chipset, that is a Radeon 3000 which I'm pretty sure is well supported under the FOSS drivers and I've used these board before and it uses a combo of EFI and BIOS so you don't have to worry about a locked UEFI.

    I tried looking for 760 drivers specifically but it looks like its baked in to Ubuntu and most of the popular distros and since the chipset is 4 years old it should be well supported. I'd say its the best bet, supports plenty of RAM, plenty of SATA drives, and it'll run anything from a dual to an octocore so there is plenty of upgrade potential here but with the X6 chips so cheap I'd probably go with the X6, after all when not in use it'll drop the power and speed of half the cores so its like having a fast triple core and when they do need the extra cycles you'll have 6 cores to call on.

  • Re:Raspberry Pi (Score:4, Informative)

    by falconwolf ( 725481 ) <falconsoaring_2000 AT yahoo DOT com> on Saturday December 29, 2012 @12:34AM (#42417339)

    Except Macs have odd keyboards that are missing keys such as PgUp, PgDn, Home, End, Del/Backspace and have a special "flower power" key which does nothing on Linux.

    Reading this I glanced down at my keyboard, I'm typing this on a MacBook Pro, and what do I see? I see Page Up, Page Down, Home, End, and Delete, which is Backspace on Linux and Windows PCs, keys. Now if I hold "fn" while pressing Delete I get the normal Delete. I dual-boot my MacBook, Snow Leopard and Ubuntu 12.04 and I've used the "flower power" when booted into Ubuntu. Without remapping the keyboard. I have not had a problem doing in Ubuntu what I do in Snow Leopard.


You know, Callahan's is a peaceable bar, but if you ask that dog what his favorite formatter is, and he says "roff! roff!", well, I'll just have to...