<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '176195004160593607',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices? - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="To protect our home networks from IoT cracking, Ceaus wants to see a smart firewall:

It's a small box (the size of a Raspberry Pi) with two ethernet ports you put in front of your ISP router. This firewall is capable of detecting your IoT devices and blocking their access to the internet, only and ...">
		<meta itemprop="name" content="Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices? - Slashdot">
		<meta itemprop="description" content="To protect our home networks from IoT cracking, Ceaus wants to see a smart firewall:

It's a small box (the size of a Raspberry Pi) with two ethernet ports you put in front of your ISP router. This firewall is capable of detecting your IoT devices and blocking their access to the internet, only and ...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/networking_64.png">
	
	
		<link rel="canonical" href="https://ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/319027" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?release_20161213" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?release_20161213" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?release_20161213" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?release_20161213">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: botnet internet privacy security networking
  
  var backend_tpc = [[ "networking", "privacy", "internet", "askslashdot", "security", "botnet" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?release_20161213"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?release_20161213" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//ask.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotAskSlashdot" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //ask.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Slashdot is powered by <strong><a href="//ask.slashdot.org/submission">your submissions</a></strong>, so send in your scoop
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="adwrap">
				
				<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
				<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 internet speed test!</a></strong> No Flash necessary and runs on all devices.
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-87424989" data-fhid="87424989" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">87424989</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-87424989">
			<a href="//ask.slashdot.org/index2.pl?fhfilter=networking" onclick="return addfhfilter('networking');">
			
				<img src="//a.fsdn.com/sd/topics/networking_64.png" width="64" height="64" alt="Networking" title="Networking">
			
		</a>
		
	
		
		
		
		

		
		<a href="//ask.slashdot.org/index2.pl?fhfilter=botnet" onclick="return addfhfilter('botnet');">
			
				<img src="//a.fsdn.com/sd/topics/botnet_64.png" width="64" height="64" alt="Botnet" title="Botnet">
			
		</a>
		
	
		
		

		
		<a href="//ask.slashdot.org/index2.pl?fhfilter=privacy" onclick="return addfhfilter('privacy');">
			
				<img src="//a.fsdn.com/sd/topics/privacy_64.png" width="64" height="64" alt="Privacy" title="Privacy">
			
		</a>
		
	
		
		

		
		<a href="//ask.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		
	
		
		

		
		<a href="//ask.slashdot.org/index2.pl?fhfilter=internet" onclick="return addfhfilter('internet');">
			
				<img src="//a.fsdn.com/sd/topics/internet_64.png" width="64" height="64" alt="The Internet" title="The Internet">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-87424989" class="story-title"> <a   href="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices">Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices?</a></span>

		
		
		<!--<span class="comments commentcnt-87424989" >230</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices#comments" title="">230</a></span>
		
	</h2>
	<div class="details" id="details-87424989">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-87424989" datetime="on Sunday November 20, 2016 @07:30PM">on Sunday November 20, 2016 @07:30PM</time>
		
		
			 from the <span class="dept-text">home-network-of-things</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-87424989">
	
		
	

	
		
		<div id="text-87424989" class="p">
			
		 	
				To protect our home networks from IoT cracking, <a href="/~Ceaus">Ceaus</a> wants to see a smart firewall:

<i>It's a small box (the size of a Raspberry Pi) with two ethernet ports you put in front of your ISP router. This firewall is capable of detecting your IoT devices and blocking their access to the internet, only and exclusively allowing traffic for the associated mobile app (if there is one). All other outgoing IoT traffic is blocked...  Once you've plugged in your new IoT toaster, you press the "Scan" button on the firewall and it does the rest for you.</i> <br>
This would also block "snooping" from outside your home network, and of course, keep your devices off botnets.  The original submission asks  "Does such a firewall exist? Is this a possible Kickstarter project?"  So leave your best answers in the comments.  Could a smart firewall protect IoT devices?
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-87424989" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices"
								  data-janrain-title="Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices?"
								  data-janrain-message="Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices? @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-87424989" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/botnet" target="_blank">botnet</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/internet" target="_blank">internet</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/privacy" target="_blank">privacy</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//news.slashdot.org/story/16/11/20/2225225/one-third-of-californias-trees-are-dead?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//games.slashdot.org/story/16/11/21/007252/2016-winners-announced-for-interactive-fiction-competition?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//news.slashdot.org/story/16/11/20/2225225/one-third-of-californias-trees-are-dead?sdsrc=prev">One Third of California's Trees Are Dead </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//tech.slashdot.org/story/16/09/04/2343254/microsoft-helps-develop-smart-iot-enabled-refrigerators?sdsrc=rel">Microsoft Helps Develop Smart, IoT-Enabled Refrigerators </a></h3><h3><a href="//ask.slashdot.org/story/16/09/26/0438233/ask-slashdot-is-my-iot-device-part-of-a-botnet?sdsrc=rel">Ask Slashdot: Is My IoT Device Part of a Botnet?</a></h3><h3><a href="//tech.slashdot.org/story/16/11/01/225221/new-more-powerful-iot-botnet-infects-3500-devices-in-5-days?sdsrc=rel">New, More-Powerful IoT Botnet Infects 3,500 Devices In 5 Days</a></h3><h3><a href="//yro.slashdot.org/story/16/11/16/202240/schneier-we-need-a-new-agency-for-iot-security?sdsrc=rel">Schneier: We Need a New Agency For IoT Security</a></h3><h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//ask.slashdot.org/submission/6493481/ask-slashdot-smart-firewalls-for-iot?sdsrc=rel" href="#">Submission: Ask Slashdot: Smart firewalls for IoT</a></h3><h3><a href="//news.slashdot.org/story/16/12/18/2255254/ubuntu-survey-discovers-consumers-are-terrible-about-updating-their-iot-devices?sdsrc=rel">Ubuntu Survey Discovers 'Consumers Are Terrible' About Updating Their IoT Devices</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//games.slashdot.org/story/16/11/21/007252/2016-winners-announced-for-interactive-fiction-competition?sdsrc=next">2016 Winners Announced For Interactive Fiction Competition</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="railad">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div class="commentwrap ">
<div class="commentBox notice pcna">
			

		
			
				This discussion has been archived.
			
			No new comments can be posted.
		
	
</div>
</div><a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices" title="Back to Article - Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices?">Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices?</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>





	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices?" href="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices">Ask Slashdot:  Could A 'Smart Firewall' Protect IoT Devices?</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<button class="btn" disabled="disabled">Archived Discussion</button>
							
							<!-- <a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=9903511" class="btn">Search <span class="totalcommentcnt">230</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>





	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//ask.slashdot.org/comments.pl?sid=9903511">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=9903511" class="ui-icon search_comments">Search <span class="totalcommentcnt">230</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//ask.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/16/11/20/2323227/ask-slashdot-could-a-smart-firewall-protect-iot-devices/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?release_20161213" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_53328989" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53328989" class="commentstatus"></div>
<div id="comment_53328989" class="cw">
	<div id="comment_top_53328989" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53328989" name="comment_link_53328989" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53328989" onclick="return D2.setFocusComment(53328989)" >Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53328989" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53328989); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mlts">mlts</a>  <span class="uid"><a href="//slashdot.org/~mlts">( 1038732 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53328989">		
		on Sunday November 20, 2016 @07:39PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53328989">#53328989</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53328989"><p>Ideally, there should be a profile/manifest IoT makers have as standard with their devices.  This shows what incoming/outgoing ports and hosts the IoT device communicates with.  Everything else should be blocked as default from the router.  This should be in some central registry or a standardized URL system, so a home firewall could, once it recognizes a certain IoT device, grab a profile and run with it.</p><p>Of course, a lot of IoT makers would just put in that the device takes incoming/outgoing traffic from anything and everything, but hopefully there might be come makers who give a shit enough about security to put in limits of what their devices can and do not try communicating with.</p><p>This way, a firewall, once it registers a device can automatically apply a profile and call it done.  Of course, there are security issues, but this is a giant step forward, compared to letting the device have unfettered access in and out.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53328989">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Ideally a manifest/profile from IoT makers... by mlts @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53328989" data-title="Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Ideally a manifest/profile from IoT makers... by mlts" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53328989" data-title="Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Ideally a manifest/profile from IoT makers... by mlts" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53328989" data-title="Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53328989" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53328989"></div>

<ul id="group_53328989">
	<li id="hiddens_53328989" class="hide"></li>
</ul>

<ul id="commtree_53328989"><li id="tree_53329403" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329403" class="commentstatus"></div>
<div id="comment_53329403" class="cw">
	<div id="comment_top_53329403" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329403" name="comment_link_53329403" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329403" onclick="return D2.setFocusComment(53329403)" >Re:Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53329403" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329403); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MobyDisk">MobyDisk</a>  <span class="uid"><a href="//slashdot.org/~MobyDisk">( 75490 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329403">		
		on Sunday November 20, 2016 @09:06PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329403">#53329403</a>)
		<small><a href="http://www.mobydisk.com/" title="http://www.mobydisk.com/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329403"><p>I love that idea!  It's like FDA labeling laws, but for electronics.  It would be totally cheap for the manufacturer to do, and it would make it totally transparent as to which devices are total crap.  And if they lie, they could be liable for it at LEAST under false advertising laws.  Now that you say this -- why the heck haven't we done this before?  It seems so simple and obvious.</p><p>This device communicates on the following protocols:<br>IP address | Protocol | Destination<br>.<br>.<br>.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329403">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53328989" onclick="return D2.selectParent(53328989)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Ideally a manifest/profile from IoT makers... by MobyDisk @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329403" data-title="Re:Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Ideally a manifest/profile from IoT makers... by MobyDisk" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329403" data-title="Re:Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Ideally a manifest/profile from IoT makers... by MobyDisk" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329403" data-title="Re:Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329403" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329403"></div>

<ul id="group_53329403">
	<li id="hiddens_53329403" class="hide"></li>
</ul>

<ul id="commtree_53329403"><li id="tree_53329947" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329947" class="commentstatus"></div>
<div id="comment_53329947" class="cw">
	<div id="comment_top_53329947" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329947" name="comment_link_53329947" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329947" onclick="return D2.setFocusComment(53329947)" >Re:Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53329947" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329947); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~grahamsz">grahamsz</a>  <span class="uid"><a href="//slashdot.org/~grahamsz">( 150076 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329947">		
		on Sunday November 20, 2016 @11:58PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329947">#53329947</a>)
		<small><a href="http://graha.ms/" title="http://graha.ms/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~grahamsz/journal/" title="Friday August 17, 2007 @06:22PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329947"><p>But how would that work for devices that aren't tied to a specific service?  I have some neat little wifi devices that show up in spotify and let me stream to various speakers around the house. If i cut them off from the internet then they simply don't work. I'd have to manually identify every IP that spotify uses and there seem to be a lot of them. In the end I watched them, identified two chinese IPs that they do reach out to and simply blocked those two. In theory that should stop them pulling in new firmware which seems like the most likely way they'd be infected. (However I haven't been able to determine if it uses an DNS lookup to find them and if so then that means someone hacking the chinese manufacturer could easily route the dns to another server).</p><p>The other thing that's really missing here is that this isn't really limited to iot devices. I'm sure in a year or two they'll be as secure as a typical windows machine and then the exploits will swing back that direction. Consumers that care about keeping their devices safe will do so, and those that don't give a fuck will see a slight improvement as time goes by.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329947">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53329403" onclick="return D2.selectParent(53329403)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Ideally a manifest/profile from IoT makers... by grahamsz @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329947" data-title="Re:Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Ideally a manifest/profile from IoT makers... by grahamsz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329947" data-title="Re:Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Ideally a manifest/profile from IoT makers... by grahamsz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329947" data-title="Re:Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329947" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329947"></div>

<ul id="group_53329947">
	<li id="hiddens_53329947" class="hide"></li>
</ul>

<ul id="commtree_53329947"><li id="tree_53331087" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331087" class="commentstatus"></div>
<div id="comment_53331087" class="cw">
	<div id="comment_top_53331087" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331087" name="comment_link_53331087" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331087" onclick="return D2.setFocusComment(53331087)" >Re:</a>


		 	<span id="comment_score_53331087" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331087); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331087"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331087"><p>As long as Spotify configured its DNS servers correctly it shouldn't be a problem for the firewall to identify all the IP addresses that the devices need to communicate with.</p><p>Ideally some kind of identity information for each domain would be included in the manifest, so that the firewall can automatically check that it hasn't changed before allowing access. 5, 10 and 15 years down the line a lot of these domains that provide firmware updates or control services will be long gone so there must be a way to rev<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331087">

</div>
</div>

<div id="replyto_53331087"></div>

<ul id="group_53331087">
	<li id="hiddens_53331087" class="hide"></li>
</ul>

</li><li id="tree_53334691" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53334691" class="commentstatus"></div>
<div id="comment_53334691" class="cw">
	<div id="comment_top_53334691" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53334691" name="comment_link_53334691" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53334691" onclick="return D2.setFocusComment(53334691)" >Re:</a>


		 	<span id="comment_score_53334691" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53334691); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MobyDisk">MobyDisk</a>  <span class="uid"><a href="//slashdot.org/~MobyDisk">( 75490 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53334691"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53334691"><p>I do not understand the questions.  I will try to answer.</p><p><div class="quote"><p>But how would that work for devices that aren't tied to a specific service?</p></div><p>Any labeling system has standard lingo.  When labeling food for example, vitamin content is listed as a % of the estimated daily value required for an average adult.  Protein however is listed in grams.  Terms such as "Yellow #5" are standardized.  The same would happen when labeling your speakers.  When a device is listening, we would need to have a term for "I listen on all IPV4 addresses" and "I listen on the local IP multicast address."  If you've<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53334691">

</div>
</div>

<div id="replyto_53334691"></div>

<ul id="group_53334691">
	<li id="hiddens_53334691" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53329673" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329673" class="commentstatus"></div>
<div id="comment_53329673" class="cw">
	<div id="comment_top_53329673" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329673" name="comment_link_53329673" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329673" onclick="return D2.setFocusComment(53329673)" >Re:</a>


		 	<span id="comment_score_53329673" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329673); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ArmoredDragon">ArmoredDragon</a>  <span class="uid"><a href="//slashdot.org/~ArmoredDragon">( 3450605 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329673"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329673"><p>This wouldn't work. As soon as malware infiltrates the device, it could make the manifest say whatever it wants.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329673">

</div>
</div>

<div id="replyto_53329673"></div>

<ul id="group_53329673">
	<li id="hiddens_53329673" class="hide"></li>
</ul>

<ul id="commtree_53329673"><li id="tree_53329681" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329681" class="commentstatus"></div>
<div id="comment_53329681" class="cw">
	<div id="comment_top_53329681" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329681" name="comment_link_53329681" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329681" onclick="return D2.setFocusComment(53329681)" >Re:Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53329681" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329681); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329681">		
		on Sunday November 20, 2016 @10:27PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329681">#53329681</a>)
		<small><a href="//slashdot.org/~Bing+Tsher+E/journal/" title="Friday May 14, 2010 @09:13AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329681"><p>The IoT device is installed in a home, and writes the 'manifest' to the firewall device at installation.  If it ever changes, the firewall would immediately know.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329681">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53329673" onclick="return D2.selectParent(53329673)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Ideally a manifest/profile from IoT makers... by Bing Tsher E @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329681" data-title="Re:Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Ideally a manifest/profile from IoT makers... by Bing Tsher E" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329681" data-title="Re:Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Ideally a manifest/profile from IoT makers... by Bing Tsher E" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329681" data-title="Re:Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329681" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329681"></div>

<ul id="group_53329681">
	<li id="hiddens_53329681" class="hide"></li>
</ul>

<ul id="commtree_53329681"><li id="tree_53329699" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329699" class="commentstatus"></div>
<div id="comment_53329699" class="cw">
	<div id="comment_top_53329699" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329699" name="comment_link_53329699" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329699" onclick="return D2.setFocusComment(53329699)" >Re:</a>


		 	<span id="comment_score_53329699" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329699); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ITRambo">ITRambo</a>  <span class="uid"><a href="//slashdot.org/~ITRambo">( 1467509 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329699"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329699">Excellent point. I wish this would take off. I hate the current IoT ease of hacking.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329699">

</div>
</div>

<div id="replyto_53329699"></div>

<ul id="group_53329699">
	<li id="hiddens_53329699" class="hide"></li>
</ul>

</li><li id="tree_53329963" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329963" class="commentstatus"></div>
<div id="comment_53329963" class="cw">
	<div id="comment_top_53329963" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329963" name="comment_link_53329963" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329963" onclick="return D2.setFocusComment(53329963)" >Re:Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53329963" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329963); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~grahamsz">grahamsz</a>  <span class="uid"><a href="//slashdot.org/~grahamsz">( 150076 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329963">		
		on Monday November 21, 2016 @12:03AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329963">#53329963</a>)
		<small><a href="http://graha.ms/" title="http://graha.ms/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~grahamsz/journal/" title="Friday August 17, 2007 @06:22PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329963"><p>At which point the consumer would see "Hey, your lightswitch wants permission to send a whole bunch of traffic to a random server" and they'd approve the change like they always do.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329963">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53329681" onclick="return D2.selectParent(53329681)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Ideally a manifest/profile from IoT makers... by grahamsz @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329963" data-title="Re:Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Ideally a manifest/profile from IoT makers... by grahamsz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329963" data-title="Re:Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Ideally a manifest/profile from IoT makers... by grahamsz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329963" data-title="Re:Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329963" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329963"></div>

<ul id="group_53329963">
	<li id="hiddens_53329963" class="hide"></li>
</ul>

<ul id="commtree_53329963"><li id="tree_53331099" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331099" class="commentstatus"></div>
<div id="comment_53331099" class="cw">
	<div id="comment_top_53331099" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331099" name="comment_link_53331099" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331099" onclick="return D2.setFocusComment(53331099)" >Re:</a>


		 	<span id="comment_score_53331099" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331099); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331099"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331099"><p>Just don't allow it to ever be changed. There is no good reason why it ever would need to change - if the manufacturer can't manage their domains properly, it's not up to us to support that.</p><p>Think of it like car safety. In many jurisdictions the car will not allow you to drive it if certain safety features are not working, mandated by law. Some of the features are to protect other people, pedestrians in particular.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331099">

</div>
</div>

<div id="replyto_53331099"></div>

<ul id="group_53331099">
	<li id="hiddens_53331099" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53330653" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53330653" class="commentstatus"></div>
<div id="comment_53330653" class="cw">
	<div id="comment_top_53330653" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330653" name="comment_link_53330653" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330653" onclick="return D2.setFocusComment(53330653)" >Re:Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53330653" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330653); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CountBrass">CountBrass</a>  <span class="uid"><a href="//slashdot.org/~CountBrass">( 590228 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330653">		
		on Monday November 21, 2016 @05:45AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330653">#53330653</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330653"><p>So your solution to securing incredibly insecure IoT devices is to allow those incredibly insecure IoT devices privileged access to the security device that polices access to your network.</p><p>This is why you don't let novices come up with security solutions.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330653">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53329681" onclick="return D2.selectParent(53329681)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Ideally a manifest/profile from IoT makers... by CountBrass @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53330653" data-title="Re:Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Ideally a manifest/profile from IoT makers... by CountBrass" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53330653" data-title="Re:Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Ideally a manifest/profile from IoT makers... by CountBrass" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53330653" data-title="Re:Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53330653" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53330653"></div>

<ul id="group_53330653">
	<li id="hiddens_53330653" class="hide"></li>
</ul>

</li><li id="tree_53330983" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330983" class="commentstatus"></div>
<div id="comment_53330983" class="cw">
	<div id="comment_top_53330983" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330983" name="comment_link_53330983" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330983" onclick="return D2.setFocusComment(53330983)" >Re:</a>


		 	<span id="comment_score_53330983" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330983); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mlts">mlts</a>  <span class="uid"><a href="//slashdot.org/~mlts">( 1038732 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330983"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330983"><p>Then the device gets compromised, tells the firewall to do allow everything as the manifest, and the fun begins.  It might be that the device presents a signed (and a CA system is a solved problem similar to signed executables) manifest, allowing the device access, but if the signature chain isn't valid, it would be ignored.</p><p>Of course, this causes the issue of who controls the CA chain to rear its ugly head, because who becomes the root CA now has the keys to the kingdom that all the IoT makers must defer to<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330983">

</div>
</div>

<div id="replyto_53330983"></div>

<ul id="group_53330983">
	<li id="hiddens_53330983" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53330169" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330169" class="commentstatus"></div>
<div id="comment_53330169" class="cw">
	<div id="comment_top_53330169" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330169" name="comment_link_53330169" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330169" onclick="return D2.setFocusComment(53330169)" >Re:</a>


		 	<span id="comment_score_53330169" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330169); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Gavagai80">Gavagai80</a>  <span class="uid"><a href="//slashdot.org/~Gavagai80">( 1275204 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330169"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330169"><p>Is there really a need to allow the manifest to be updated? It's not as if IoT device makers are in the habit of giving customers free software updates that enable new features, you're supposed to throw it out and buy the next device for that.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330169">

</div>
</div>

<div id="replyto_53330169"></div>

<ul id="group_53330169">
	<li id="hiddens_53330169" class="hide"></li>
</ul>

</li><li id="tree_53330217" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330217" class="commentstatus"></div>
<div id="comment_53330217" class="cw">
	<div id="comment_top_53330217" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330217" name="comment_link_53330217" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330217" onclick="return D2.setFocusComment(53330217)" >Re:</a>


		 	<span id="comment_score_53330217" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330217); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~vux984">vux984</a>  <span class="uid"><a href="//slashdot.org/~vux984">( 928602 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330217"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330217"><p>Actually, It could be like antivirus or an adblocker where you subscribe to a service of your choice to provide you your device profiles from a database of devices... seeded by manufacturers, by volunteers, etc, etc... and not just IoT -- i think a system like this could work for mobile phone permissions and even desktop application firewalls.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330217">

</div>
</div>

<div id="replyto_53330217"></div>

<ul id="group_53330217">
	<li id="hiddens_53330217" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53330517" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330517" class="commentstatus"></div>
<div id="comment_53330517" class="cw">
	<div id="comment_top_53330517" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330517" name="comment_link_53330517" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330517" onclick="return D2.setFocusComment(53330517)" >Re:</a>


		 	<span id="comment_score_53330517" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330517); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NotAPK">NotAPK</a>  <span class="uid"><a href="//slashdot.org/~NotAPK">( 4529127 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330517"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330517"><p>This will mitigate scenarios where the device has an open Telnet port for "factory testing" that is not turned off once it goes out in the field.</p><p>However, a lot of exploits are in the semi-custom protocols these IoT makers are hacking up themselves. Those vulnerabilities are not mitigated by firewall protection in any way.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330517">

</div>
</div>

<div id="replyto_53330517"></div>

<ul id="group_53330517">
	<li id="hiddens_53330517" class="hide"></li>
</ul>

<ul id="commtree_53330517"><li id="tree_53332027" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53332027" class="commentstatus"></div>
<div id="comment_53332027" class="cw">
	<div id="comment_top_53332027" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53332027" name="comment_link_53332027" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53332027" onclick="return D2.setFocusComment(53332027)" >Re:</a>


		 	<span id="comment_score_53332027" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53332027); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bob+the+Super+Hamste">Bob the Super Hamste</a>  <span class="uid"><a href="//slashdot.org/~Bob+the+Super+Hamste">( 1152367 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53332027"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53332027"><p><div class="quote"><p>Those vulnerabilities are not mitigated by firewall protection in any way.</p></div><p>How? It isn't like manufactures of these dumb little devices are implementing things at ore below layer 4 of the OSI model so why wouldn't a standard firewall be able to block their crap. At worst it would be some custom protocol running on some random port using TCP. If they did go and create their own custom layer 3 or 4 protocol it would likely be blocked anyway as what networking device would understand bullshit protocol 862 from ChinaTrashCo. If you are referring to running some BS over HTTP that these<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53332027">

</div>
</div>

<div id="replyto_53332027"></div>

<ul id="group_53332027">
	<li id="hiddens_53332027" class="hide"></li>
</ul>

<ul id="commtree_53332027"><li id="tree_53332045" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53332045" class="commentstatus"></div>
<div id="comment_53332045" class="cw">
	<div id="comment_top_53332045" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53332045" name="comment_link_53332045" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53332045" onclick="return D2.setFocusComment(53332045)" >Re:</a>


		 	<span id="comment_score_53332045" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53332045); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NotAPK">NotAPK</a>  <span class="uid"><a href="//slashdot.org/~NotAPK">( 4529127 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53332045"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53332045"><p>Sorry, I meant you can block the functionality completely, but once you want to make use of those features you'll need to allow firewall access and by that point a lot of the vulnerabilities rest with the protocol.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53332045">

</div>
</div>

<div id="replyto_53332045"></div>

<ul id="group_53332045">
	<li id="hiddens_53332045" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53331473" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53331473" class="commentstatus"></div>
<div id="comment_53331473" class="cw">
</div>

<div id="replyto_53331473"></div>

<ul id="group_53331473">
	<li id="hiddens_53331473" class="hide"></li>
</ul>

<ul id="commtree_53331473"><li id="tree_53331553" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331553" class="commentstatus"></div>
<div id="comment_53331553" class="cw">
	<div id="comment_top_53331553" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331553" name="comment_link_53331553" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331553" onclick="return D2.setFocusComment(53331553)" >Re:</a>


		 	<span id="comment_score_53331553" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331553); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NotAPK">NotAPK</a>  <span class="uid"><a href="//slashdot.org/~NotAPK">( 4529127 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331553"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331553"><p>But won't do anything for protocol issues.</p><p>A lot of the IoT devices use port 80 and run some kind of HTTP client or server protocol. *Nothing* you do at the router is going to protect you from anything related to these kinds of crap-fest devices.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331553">

</div>
</div>

<div id="replyto_53331553"></div>

<ul id="group_53331553">
	<li id="hiddens_53331553" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53330843" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53330843" class="commentstatus"></div>
<div id="comment_53330843" class="cw">
	<div id="comment_top_53330843" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330843" name="comment_link_53330843" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330843" onclick="return D2.setFocusComment(53330843)" >Re:Ideally a manifest/profile from IoT makers...</a>


		 	<span id="comment_score_53330843" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330843); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cheetah_spottycat">cheetah_spottycat</a>  <span class="uid"><a href="//slashdot.org/~cheetah_spottycat">( 106624 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330843">		
		on Monday November 21, 2016 @07:11AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330843">#53330843</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330843">This is called UPNP, and is exactly the problem why so many devices are reachable through the internet while their owners don't suspect a thing.</div>
	</div>

	<div class="commentSub" id="comment_sub_53330843">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53328989" onclick="return D2.selectParent(53328989)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Ideally a manifest/profile from IoT makers... by cheetah_spottycat @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53330843" data-title="Re:Ideally a manifest/profile from IoT makers...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Ideally a manifest/profile from IoT makers... by cheetah_spottycat" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53330843" data-title="Re:Ideally a manifest/profile from IoT makers...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Ideally a manifest/profile from IoT makers... by cheetah_spottycat" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53330843" data-title="Re:Ideally a manifest/profile from IoT makers...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53330843" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53330843"></div>

<ul id="group_53330843">
	<li id="hiddens_53330843" class="hide"></li>
</ul>

</li><li id="tree_53332779" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53332779" class="commentstatus"></div>
<div id="comment_53332779" class="cw">
	<div id="comment_top_53332779" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53332779" name="comment_link_53332779" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53332779" onclick="return D2.setFocusComment(53332779)" >Re:</a>


		 	<span id="comment_score_53332779" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53332779); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hAckz0r">hAckz0r</a>  <span class="uid"><a href="//slashdot.org/~hAckz0r">( 989977 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53332779"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53332779">Many baby monitors and security cams automagically punch a hole through your home router using Plug-n-play, which is a very bad idea for home security. On the surface thsi doesn't sound much different than what you propose, only I think your profile idea likely was meant to place additional restrictions on how that hole is to be managed. Once the router opens a hole for a device almost anything can flow through that hole unless the router does deep packet inspection, and any SSL used to make that connection</div>
	</div>

	<div class="commentSub" id="comment_sub_53332779">

</div>
</div>

<div id="replyto_53332779"></div>

<ul id="group_53332779">
	<li id="hiddens_53332779" class="hide"></li>
</ul>

</li><li id="tree_53329207" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329207" class="commentstatus"></div>
<div id="comment_53329207" class="cw">
</div>

<div id="replyto_53329207"></div>

<ul id="group_53329207">
	<li id="hiddens_53329207" class="hide"></li>
</ul>

<ul id="commtree_53329207"><li id="tree_53329475" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329475" class="commentstatus"></div>
<div id="comment_53329475" class="cw">
	<div id="comment_top_53329475" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329475" name="comment_link_53329475" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329475" onclick="return D2.setFocusComment(53329475)" >Re:</a>


		 	<span id="comment_score_53329475" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329475); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mlts">mlts</a>  <span class="uid"><a href="//slashdot.org/~mlts">( 1038732 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329475"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329475"><p>If the maker puts in an IP address or DNS host, they are responsible for it, so it would be about the same risk as a company ninja-flashing an Android phone to double as a USB zapper.  A manifest would make it at least known that the maker did vouch for the IP address.</p><p>There are many issues with this manifest system, be it who validates signatures, how do the firewalls grab devices, how are manifests updated and how is a firewall admin presented with updates.  However, this is far better than nothing, as as<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329475">

</div>
</div>

<div id="replyto_53329475"></div>

<ul id="group_53329475">
	<li id="hiddens_53329475" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53328991" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53328991" class="commentstatus"></div>
<div id="comment_53328991" class="cw">
	<div id="comment_top_53328991" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53328991" name="comment_link_53328991" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53328991" onclick="return D2.setFocusComment(53328991)" >some rules</a>


		 	<span id="comment_score_53328991" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53328991); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53328991">		 &lt;<a href="mailto:martin.espinoza%40gmail.com">martin.espinoza@gmail.com</a>&gt;
		on Sunday November 20, 2016 @07:40PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53328991">#53328991</a>)
		<small><a href="http://hyperlogos.org/" title="http://hyperlogos.org/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~drinkypoo/journal/" title="Friday September 30, 2016 @08:26AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53328991"><p>All you really need is... some rules.</p><p>If you have an openwrt, dd-wrt or similar router, you can definitely block whatever traffic you want without new hardware.</p><p>You can whitelist devices by IP or MAC and not permit anything else to generate egress traffic, which won't prevent against devices smart enough to spoof your IP and MAC sending data but which will defeat the casual attacks.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53328991">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="some rules by drinkypoo @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53328991" data-title="some rules">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="some rules by drinkypoo" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53328991" data-title="some rules">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="some rules by drinkypoo" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53328991" data-title="some rules">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53328991" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53328991"></div>

<ul id="group_53328991">
	<li id="hiddens_53328991" class="hide"></li>
</ul>

<ul id="commtree_53328991"><li id="tree_53329021" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329021" class="commentstatus"></div>
<div id="comment_53329021" class="cw">
	<div id="comment_top_53329021" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329021" name="comment_link_53329021" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329021" onclick="return D2.setFocusComment(53329021)" >Re:some rules</a>


		 	<span id="comment_score_53329021" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329021); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~grahamsz">grahamsz</a>  <span class="uid"><a href="//slashdot.org/~grahamsz">( 150076 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329021">		
		on Sunday November 20, 2016 @07:49PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329021">#53329021</a>)
		<small><a href="http://graha.ms/" title="http://graha.ms/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~grahamsz/journal/" title="Friday August 17, 2007 @06:22PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329021"><p>I've corralled mine into a dhcp space, but it might be safer just to set up a whole separate wifi network for them, would make it easier to monitor.</p><p>Still it's trickier for things like the chromecast or airplay-type devices, because they both interact with phones and laptops on the local network and need to connect directly to streaming sources on the internet.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329021">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53328991" onclick="return D2.selectParent(53328991)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:some rules by grahamsz @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329021" data-title="Re:some rules">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:some rules by grahamsz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329021" data-title="Re:some rules">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:some rules by grahamsz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329021" data-title="Re:some rules">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329021" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329021"></div>

<ul id="group_53329021">
	<li id="hiddens_53329021" class="hide"></li>
</ul>

<ul id="commtree_53329021"><li id="tree_53329221" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329221" class="commentstatus"></div>
<div id="comment_53329221" class="cw">
	<div id="comment_top_53329221" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329221" name="comment_link_53329221" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329221" onclick="return D2.setFocusComment(53329221)" >Re:some rules</a>


		 	<span id="comment_score_53329221" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329221); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fyngyrz">fyngyrz</a>  <span class="uid"><a href="//slashdot.org/~fyngyrz">( 762201 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329221">		
		on Sunday November 20, 2016 @08:31PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329221">#53329221</a>)
		<small><a href="http://fyngyrz.com/" title="http://fyngyrz.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~fyngyrz/journal/" title="Monday February 08, 2010 @01:38PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329221"><blockquote><div><p>set up a whole separate wifi network for them, would make it easier to monitor.</p></div></blockquote><p>That's the actual answer. Get them their own SLOW connection, their own firewall/router, and let them talk to anyone they want. Keep them the hell away from your in-house goodness. And FFS, secure your actual wifi network. Also, put the channels at opposite ends of the band (or in different bands, better yet.)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329221">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53329021" onclick="return D2.selectParent(53329021)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:some rules by fyngyrz @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329221" data-title="Re:some rules">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:some rules by fyngyrz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329221" data-title="Re:some rules">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:some rules by fyngyrz" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329221" data-title="Re:some rules">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329221" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329221"></div>

<ul id="group_53329221">
	<li id="hiddens_53329221" class="hide"></li>
</ul>

</li><li id="tree_53329729" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329729" class="commentstatus"></div>
<div id="comment_53329729" class="cw">
	<div id="comment_top_53329729" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329729" name="comment_link_53329729" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329729" onclick="return D2.setFocusComment(53329729)" >Re:</a>


		 	<span id="comment_score_53329729" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329729); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aaarrrgggh">aaarrrgggh</a>  <span class="uid"><a href="//slashdot.org/~aaarrrgggh">( 9205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329729"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329729">Novel idea here... 3!!! SSIDs: general purpose devices, untrusted devices, and DMZ devices.  Easy enough with DD-WRT or UBNT gear.

The practical challenge is getting the broadcast traffic mirrored to the general purpose VLAN, but there are tools for that as well.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329729">

</div>
</div>

<div id="replyto_53329729"></div>

<ul id="group_53329729">
	<li id="hiddens_53329729" class="hide"></li>
</ul>

</li><li id="tree_53330123" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330123" class="commentstatus"></div>
<div id="comment_53330123" class="cw">
	<div id="comment_top_53330123" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330123" name="comment_link_53330123" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330123" onclick="return D2.setFocusComment(53330123)" >Re:</a>


		 	<span id="comment_score_53330123" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330123); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CrashNBrn">CrashNBrn</a>  <span class="uid"><a href="//slashdot.org/~CrashNBrn">( 1143981 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330123"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330123">Something like this
<a href="https://www.amazon.com/gp/product/B00NR2VMNC/" title="amazon.com">Dual Band Wi-Fi Range Extender, Repeater, Wall Plug w/ Ethernet Port</a> [amazon.com].
<br> <br>
Then run the IOT on the child network.</div>
	</div>

	<div class="commentSub" id="comment_sub_53330123">

</div>
</div>

<div id="replyto_53330123"></div>

<ul id="group_53330123">
	<li id="hiddens_53330123" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329039" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329039" class="commentstatus"></div>
<div id="comment_53329039" class="cw">
	<div id="comment_top_53329039" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329039" name="comment_link_53329039" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329039" onclick="return D2.setFocusComment(53329039)" >Re:</a>


		 	<span id="comment_score_53329039" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329039); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~vawarayer">vawarayer</a>  <span class="uid"><a href="//slashdot.org/~vawarayer">( 1035638 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329039"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329039"><p><div class="quote"><p>If you have an openwrt, dd-wrt or similar router, you can definitely block whatever traffic you want without new hardware.</p></div><p>Not even need some specific open-sourced firmware. Just any home router / NAT / firewall can do that. Don't need smart devices, just smart people to configure it properly...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329039">

</div>
</div>

<div id="replyto_53329039"></div>

<ul id="group_53329039">
	<li id="hiddens_53329039" class="hide"></li>
</ul>

<ul id="commtree_53329039"><li id="tree_53329255" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329255" class="commentstatus"></div>
<div id="comment_53329255" class="cw">
	<div id="comment_top_53329255" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329255" name="comment_link_53329255" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329255" onclick="return D2.setFocusComment(53329255)" >Re:</a>


		 	<span id="comment_score_53329255" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329255); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~WhiteKnight07">WhiteKnight07</a>  <span class="uid"><a href="//slashdot.org/~WhiteKnight07">( 521975 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329255"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329255"><p><div class="quote"><p>Not even need some specific open-sourced firmware. Just any home router / NAT / firewall can do that. Don't need smart devices, just smart people to configure it properly...</p></div><p>Hi. Welcome to the internet. You must be new here.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329255">

</div>
</div>

<div id="replyto_53329255"></div>

<ul id="group_53329255">
	<li id="hiddens_53329255" class="hide"></li>
</ul>

</li><li id="tree_53329535" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329535" class="commentstatus"></div>
<div id="comment_53329535" class="cw">
	<div id="comment_top_53329535" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329535" name="comment_link_53329535" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329535" onclick="return D2.setFocusComment(53329535)" >Re:</a>


		 	<span id="comment_score_53329535" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329535); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TapeCutter">TapeCutter</a>  <span class="uid"><a href="//slashdot.org/~TapeCutter">( 624760 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329535"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329535"><p><div class="quote"><p>Don't need smart devices, just smart people to configure it properly</p></div><p>Smart devices are easier to make than smart people.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329535">

</div>
</div>

<div id="replyto_53329535"></div>

<ul id="group_53329535">
	<li id="hiddens_53329535" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329141" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329141" class="commentstatus"></div>
<div id="comment_53329141" class="cw">
	<div id="comment_top_53329141" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329141" name="comment_link_53329141" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329141" onclick="return D2.setFocusComment(53329141)" >Re:some rules</a>


		 	<span id="comment_score_53329141" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329141); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Giant+Electronic+Bra">Giant Electronic Bra</a>  <span class="uid"><a href="//slashdot.org/~Giant+Electronic+Bra">( 1229876 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329141">		
		on Sunday November 20, 2016 @08:15PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329141">#53329141</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329141"><p>ALL you need are some CONVENTIONS. Every firewall that isn't utterly worthless already blocks ALL outgoing traffic. IoT devices should, by convention, expose their API on a specific and otherwise not typical port. This port can simply always be blocked, ALWAYS ALWAYS blocked on the firewall. Now, when you need to have some specific access from somewhere, then the firewall could act as an authenticating proxy, removing the need for IoT vendors to actually grok security (which is literally a hopeless hope, they never will). Assuming your wireless network is adequately secured, so that nothing gets on it that you don't want there, you should be pretty set. Further conventions could relegate all IoT devices to a separate specific VLAN, etc. The key point is, all the devices need to do is adhere to some VERY simple conventions that even half-assed software vendors can adhere to.</p><p>Won't stop all problems, but it would make a damned good start.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329141">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53328991" onclick="return D2.selectParent(53328991)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:some rules by Giant Electronic Bra @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329141" data-title="Re:some rules">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:some rules by Giant Electronic Bra" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329141" data-title="Re:some rules">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:some rules by Giant Electronic Bra" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329141" data-title="Re:some rules">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329141" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329141"></div>

<ul id="group_53329141">
	<li id="hiddens_53329141" class="hide"></li>
</ul>

<ul id="commtree_53329141"><li id="tree_53329445" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329445" class="commentstatus"></div>
<div id="comment_53329445" class="cw">
	<div id="comment_top_53329445" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329445" name="comment_link_53329445" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329445" onclick="return D2.setFocusComment(53329445)" >Re:</a>


		 	<span id="comment_score_53329445" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329445); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~silas_moeckel">silas_moeckel</a>  <span class="uid"><a href="//slashdot.org/~silas_moeckel">( 234313 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329445"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329445"><p>I have no problems getting all my IoT devices to work just fine when they have in general no internet access.  In my case it's a seperate vlan with firewall rules.</p><p>The problem is the cloud push to do very little onsite and send a lot of data into the clod while accepting C&amp;C from it.  Look around and plenty of devices that work locally.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329445">

</div>
</div>

<div id="replyto_53329445"></div>

<ul id="group_53329445">
	<li id="hiddens_53329445" class="hide"></li>
</ul>

<ul id="commtree_53329445"><li id="tree_53331327" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331327" class="commentstatus"></div>
<div id="comment_53331327" class="cw">
	<div id="comment_top_53331327" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331327" name="comment_link_53331327" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331327" onclick="return D2.setFocusComment(53331327)" >Re:</a>


		 	<span id="comment_score_53331327" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331327); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Giant+Electronic+Bra">Giant Electronic Bra</a>  <span class="uid"><a href="//slashdot.org/~Giant+Electronic+Bra">( 1229876 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331327"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331327"><p>Yeah, that's true of course. The problem is most devices envisage remote operation, and for many it CAN make sense. Quite a lot of them also expect to be able to push data up into the cloud for whatever reasons. Many also perform remote updates. It would of course be perfectly reasonable to allow devices to designate a single external point of contact which they can initiate, and obviously your firewall/LAN setup can easily deal with that. That will still leave some potential vectors for attack, but they wo<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331327">

</div>
</div>

<div id="replyto_53331327"></div>

<ul id="group_53331327">
	<li id="hiddens_53331327" class="hide"></li>
</ul>

<ul id="commtree_53331327"><li id="tree_53332143" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53332143" class="commentstatus"></div>
<div id="comment_53332143" class="cw">
	<div id="comment_top_53332143" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53332143" name="comment_link_53332143" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53332143" onclick="return D2.setFocusComment(53332143)" >Re:</a>


		 	<span id="comment_score_53332143" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53332143); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~silas_moeckel">silas_moeckel</a>  <span class="uid"><a href="//slashdot.org/~silas_moeckel">( 234313 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53332143"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53332143"><p>Sure lots of things want to connect to the internet, take my garage door interface.  They sell their own services to let you via the cloud open/close the door and get alerts if it's left open etc etc.  It has a local API, it connects to my IoT vlan and can not get out the door.  Yet that means it never gets any possible firmware updates (would have to check if there is a way to upgrade via the api/local interface) but for a wired device on an isolated vlan at worst it's a way to get into that vlan via RF or<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53332143">

</div>
</div>

<div id="replyto_53332143"></div>

<ul id="group_53332143">
	<li id="hiddens_53332143" class="hide"></li>
</ul>

</li><li id="tree_53331517" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53331517" class="commentstatus"></div>
<div id="comment_53331517" class="cw">
</div>

<div id="replyto_53331517"></div>

<ul id="group_53331517">
	<li id="hiddens_53331517" class="hide"></li>
</ul>

<ul id="commtree_53331517"><li id="tree_53332177" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53332177" class="commentstatus"></div>
<div id="comment_53332177" class="cw">
	<div id="comment_top_53332177" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53332177" name="comment_link_53332177" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53332177" onclick="return D2.setFocusComment(53332177)" >Re:</a>


		 	<span id="comment_score_53332177" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53332177); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~silas_moeckel">silas_moeckel</a>  <span class="uid"><a href="//slashdot.org/~silas_moeckel">( 234313 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53332177"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53332177"><p>Hells most of them should not be on wifi, zwave etc etc is plenty fast and a better network.  A dimmer needs a IP stack like a whole in the head.  If you need that much speed it better be running artnet or similar not https connections to the cloud.  The vast majority of this stuff has data use measured in bytes per day maybe KB if it's gathering power usage data.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53332177">

</div>
</div>

<div id="replyto_53332177"></div>

<ul id="group_53332177">
	<li id="hiddens_53332177" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_53331721" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331721" class="commentstatus"></div>
<div id="comment_53331721" class="cw">
	<div id="comment_top_53331721" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331721" name="comment_link_53331721" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331721" onclick="return D2.setFocusComment(53331721)" >Re:</a>


		 	<span id="comment_score_53331721" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331721); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331721"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331721"><p>You're very quickly falling into a trap of making assumptions about the devices and the applications.</p><p><div class="quote"><p>Every firewall that isn't utterly worthless already blocks ALL outgoing traffic.</p></div><p>So every firewall on every home network then.</p><p><div class="quote"><p>IoT devices should, by convention, expose their API on a specific and otherwise not typical port.</p></div><p>The same could be said about a computer. IoT devices like computers are equally multi-purpose. You expose the API on a port. Great now you have an open port. That port requires two-way communication for configuration, now you have an entry point. In that entry point you just need a bit of poor input checking with some remote code execution vulnerability and now yo<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331721">

</div>
</div>

<div id="replyto_53331721"></div>

<ul id="group_53331721">
	<li id="hiddens_53331721" class="hide"></li>
</ul>

<ul id="commtree_53331721"><li id="tree_53331795" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331795" class="commentstatus"></div>
<div id="comment_53331795" class="cw">
	<div id="comment_top_53331795" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331795" name="comment_link_53331795" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331795" onclick="return D2.setFocusComment(53331795)" >Re:</a>


		 	<span id="comment_score_53331795" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331795); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Giant+Electronic+Bra">Giant Electronic Bra</a>  <span class="uid"><a href="//slashdot.org/~Giant+Electronic+Bra">( 1229876 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331795"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331795"><p>That's an overgeneralization. It also doesn't take into account that there are a LOT of possibilities that are short of 'you can just access the whole internet'. Any Firewall can restrict outgoing traffic to specific destinations. It can restrict incoming connections equally. It can force a login through a proxy, which can thwart any backdoor. More sophisticated devices can recognize malicious behavior and put a stop to it. There's plenty that can be done.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331795">

</div>
</div>

<div id="replyto_53331795"></div>

<ul id="group_53331795">
	<li id="hiddens_53331795" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53329249" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329249" class="commentstatus"></div>
<div id="comment_53329249" class="cw">
	<div id="comment_top_53329249" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329249" name="comment_link_53329249" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329249" onclick="return D2.setFocusComment(53329249)" >Re:</a>


		 	<span id="comment_score_53329249" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329249); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rjune">rjune</a>  <span class="uid"><a href="//slashdot.org/~rjune">( 123157 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329249"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329249"><p>Rules - that is the key.  I have a DVD player that is networked so we can access Netflix.  The question is, what access does this device need?  When we want to watch something, we request access through the device, so it needs to tell Netflix what to stream, and it needs access to receive our movie.  I think the hardest part of setting up a firewall is going to be figuring that out.  The DVD player is old, but it can access at least a half-dozen services.  The same information would be needed for every serv<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329249">

</div>
</div>

<div id="replyto_53329249"></div>

<ul id="group_53329249">
	<li id="hiddens_53329249" class="hide"></li>
</ul>

<ul id="commtree_53329249"><li id="tree_53329739" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329739" class="commentstatus"></div>
<div id="comment_53329739" class="cw">
	<div id="comment_top_53329739" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329739" name="comment_link_53329739" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329739" onclick="return D2.setFocusComment(53329739)" >Re:</a>


		 	<span id="comment_score_53329739" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329739); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aaarrrgggh">aaarrrgggh</a>  <span class="uid"><a href="//slashdot.org/~aaarrrgggh">( 9205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329739"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329739">With DPI, you can make a firewall rule to allow media services applications.  You can do it on a $50 EdgeRouter-X painlessly.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329739">

</div>
</div>

<div id="replyto_53329739"></div>

<ul id="group_53329739">
	<li id="hiddens_53329739" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329275" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329275" class="commentstatus"></div>
<div id="comment_53329275" class="cw">
	<div id="comment_top_53329275" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329275" name="comment_link_53329275" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329275" onclick="return D2.setFocusComment(53329275)" >Re:some rules - but you have to know how!</a>


		 	<span id="comment_score_53329275" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329275); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~chromaexcursion">chromaexcursion</a>  <span class="uid"><a href="//slashdot.org/~chromaexcursion">( 2047080 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329275"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329275">Absolutely correct!<br>
There are several ways to use existing router features to do this.  A few steps, a few minutes work.<br>
Sadly, most are too ignorant to implement them.<br> <br>
Basically, how to get the unwashed massed to learn to implement them.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329275">

</div>
</div>

<div id="replyto_53329275"></div>

<ul id="group_53329275">
	<li id="hiddens_53329275" class="hide"></li>
</ul>

</li><li id="tree_53329473" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329473" class="commentstatus"></div>
<div id="comment_53329473" class="cw">
	<div id="comment_top_53329473" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329473" name="comment_link_53329473" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329473" onclick="return D2.setFocusComment(53329473)" >Re:</a>


		 	<span id="comment_score_53329473" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329473); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRealMindChild">TheRealMindChild</a>  <span class="uid"><a href="//slashdot.org/~TheRealMindChild">( 743925 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329473"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329473">This is bullshit and I will tell you why. Most of this crap communicates over port 80. Block port 80 and you block it all. Keep it open and it is just as exploitable as it ever was. You would need something that could inspect the contents of the traffic. However, if it can inspect the contents of the traffic, you have already failed. All communications should be done over an encrypted connection.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329473">

</div>
</div>

<div id="replyto_53329473"></div>

<ul id="group_53329473">
	<li id="hiddens_53329473" class="hide"></li>
</ul>

<ul id="commtree_53329473"><li id="tree_53330721" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330721" class="commentstatus"></div>
<div id="comment_53330721" class="cw">
	<div id="comment_top_53330721" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330721" name="comment_link_53330721" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330721" onclick="return D2.setFocusComment(53330721)" >Re:</a>


		 	<span id="comment_score_53330721" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330721); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~msauve">msauve</a>  <span class="uid"><a href="//slashdot.org/~msauve">( 701917 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330721"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330721">"Block port 80 and you block it all. Keep it open and it is just as exploitable as it ever was."<br> <br>You have a really, really crappy firewall if it can only block ports without considering the specific IP(s) the traffic is from/to.</div>
	</div>

	<div class="commentSub" id="comment_sub_53330721">

</div>
</div>

<div id="replyto_53330721"></div>

<ul id="group_53330721">
	<li id="hiddens_53330721" class="hide"></li>
</ul>

</li><li id="tree_53332155" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53332155" class="commentstatus"></div>
<div id="comment_53332155" class="cw">
	<div id="comment_top_53332155" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53332155" name="comment_link_53332155" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53332155" onclick="return D2.setFocusComment(53332155)" >Re:</a>


		 	<span id="comment_score_53332155" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53332155); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bob+the+Super+Hamste">Bob the Super Hamste</a>  <span class="uid"><a href="//slashdot.org/~Bob+the+Super+Hamste">( 1152367 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53332155"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53332155">Why coulnd't I have a set of rules that says:<br>
Allow established connections<br>
Shitty_IoT_Device1 is allowed to send data on port 80 only to Shitty_IoT_Manufacturer1<br>
Shitty_IoT_Manufacturer1 is allowed contact Shitty_IoT_Device1 on port WhatEverListeningPort<br>
Shitty_IoT_Device2 is allowed to send data on port 80 only to Shitty_IoT_Manufacturer1<br>
Shitty_IoT_Manufacturer1 is allowed contact Shitty_IoT_Device2 on port WhatEverListeningPort<br>
Shitty_IoT_Device3 is allowed to send data on port 80 only to Shitty_IoT_Man</div>
	</div>

	<div class="commentSub" id="comment_sub_53332155">

</div>
</div>

<div id="replyto_53332155"></div>

<ul id="group_53332155">
	<li id="hiddens_53332155" class="hide"></li>
</ul>

</li><li id="tree_53329671" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329671" class="commentstatus"></div>
<div id="comment_53329671" class="cw">
</div>

<div id="replyto_53329671"></div>

<ul id="group_53329671">
	<li id="hiddens_53329671" class="hide"></li>
</ul>

<ul id="commtree_53329671"><li id="tree_53329707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329707" class="commentstatus"></div>
<div id="comment_53329707" class="cw">
	<div id="comment_top_53329707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329707" name="comment_link_53329707" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329707" onclick="return D2.setFocusComment(53329707)" >Re:</a>


		 	<span id="comment_score_53329707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329707); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRealMindChild">TheRealMindChild</a>  <span class="uid"><a href="//slashdot.org/~TheRealMindChild">( 743925 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329707">"Lol". So your consumer grade router will work on a whitelist only basis, and intelligently whitelist wherever you would be connecting from when connecting to your IoT crap, while filtering malicious devices from the same location? Please.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329707">

</div>
</div>

<div id="replyto_53329707"></div>

<ul id="group_53329707">
	<li id="hiddens_53329707" class="hide"></li>
</ul>

</li><li id="tree_53330579" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330579" class="commentstatus"></div>
<div id="comment_53330579" class="cw">
	<div id="comment_top_53330579" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330579" name="comment_link_53330579" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330579" onclick="return D2.setFocusComment(53330579)" >Re:</a>


		 	<span id="comment_score_53330579" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330579); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JaredOfEuropa">JaredOfEuropa</a>  <span class="uid"><a href="//slashdot.org/~JaredOfEuropa">( 526365 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330579"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330579">And most importantly: set rules for which device can go where on 80.  Your desktop can have it all, whereas your IP camera is allowed access only to the IP address of the remote access service.  Sure, a compromised device could spoof its IP or MAC address and still get out, but... it will have to be infected in the first place.  And a well configured firewall will make that much harder.</div>
	</div>

	<div class="commentSub" id="comment_sub_53330579">

</div>
</div>

<div id="replyto_53330579"></div>

<ul id="group_53330579">
	<li id="hiddens_53330579" class="hide"></li>
</ul>

</li><li id="tree_53330741" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330741" class="commentstatus"></div>
<div id="comment_53330741" class="cw">
	<div id="comment_top_53330741" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330741" name="comment_link_53330741" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330741" onclick="return D2.setFocusComment(53330741)" >Re:</a>


		 	<span id="comment_score_53330741" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330741); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330741"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330741">Okay, so IoT vendor X is using AWS and Azure for their server-side hosting.  Where do you get the list of all valid AWS and Azure IPs to whitelist?  How do you keep it up to date?  Does your cheap router have enough space in its tables to match against those (large, non-contriguous) ranges without imposing a performance penalty?</div>
	</div>

	<div class="commentSub" id="comment_sub_53330741">

</div>
</div>

<div id="replyto_53330741"></div>

<ul id="group_53330741">
	<li id="hiddens_53330741" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53329971" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329971" class="commentstatus"></div>
<div id="comment_53329971" class="cw">
	<div id="comment_top_53329971" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329971" name="comment_link_53329971" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329971" onclick="return D2.setFocusComment(53329971)" >True, and anomaly detection gets most of the way</a>


		 	<span id="comment_score_53329971" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329971); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~raymorris">raymorris</a>  <span class="uid"><a href="//slashdot.org/~raymorris">( 2726007 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329971"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329971"><p>As Drinkypoo said, no need for new hardware, this is all about configuration.  If you have a great many devices, configuration could be difficult, but there is a short cut.  It's called "anomaly detection".  The firewall learns what's normal, and when unusual traffic starts it takes one of three different actions, depending on the level of risk it estimated.  Snort os open source software that can do this.</p><p>Along with anomaly detection covering 90%, you might also add some manual rules.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329971">

</div>
</div>

<div id="replyto_53329971"></div>

<ul id="group_53329971">
	<li id="hiddens_53329971" class="hide"></li>
</ul>

</li><li id="tree_53330591" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330591" class="commentstatus"></div>
<div id="comment_53330591" class="cw">
	<div id="comment_top_53330591" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330591" name="comment_link_53330591" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330591" onclick="return D2.setFocusComment(53330591)" >Re:</a>


		 	<span id="comment_score_53330591" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330591); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JaredOfEuropa">JaredOfEuropa</a>  <span class="uid"><a href="//slashdot.org/~JaredOfEuropa">( 526365 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330591"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330591">It's not about the rules, but about setting them up.  You can, but can your grandma?  That's the lithmus test of the proposed device.  You need a device that can figure out the rules by itself, or that makes it dead easy for people to configure it.  <br> <br>As someone suggested in an earlier post: have IoT devices carry a manifest (both printed on the box and in software) of the addresses / ports it needs to access.  If we'd have a protocol for this, it could ask the router for that access automatically and prompt</div>
	</div>

	<div class="commentSub" id="comment_sub_53330591">

</div>
</div>

<div id="replyto_53330591"></div>

<ul id="group_53330591">
	<li id="hiddens_53330591" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329045" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329045" class="commentstatus"></div>
<div id="comment_53329045" class="cw">
	<div id="comment_top_53329045" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329045" name="comment_link_53329045" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329045" onclick="return D2.setFocusComment(53329045)" >A strong firewall</a>


		 	<span id="comment_score_53329045" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329045); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fred911">fred911</a>  <span class="uid"><a href="//slashdot.org/~fred911">( 83970 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329045"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329045"><p><a href="https://en.wikipedia.org/wiki/Faraday_cage" title="wikipedia.org">https://en.wikipedia.org/wiki/...</a> [wikipedia.org]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329045">

</div>
</div>

<div id="replyto_53329045"></div>

<ul id="group_53329045">
	<li id="hiddens_53329045" class="hide"></li>
</ul>

</li><li id="tree_53329081" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329081" class="commentstatus"></div>
<div id="comment_53329081" class="cw">
	<div id="comment_top_53329081" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329081" name="comment_link_53329081" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329081" onclick="return D2.setFocusComment(53329081)" >How is this different from any firewall</a>


		 	<span id="comment_score_53329081" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329081); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Paul+Carver">Paul Carver</a>  <span class="uid"><a href="//slashdot.org/~Paul+Carver">( 4555 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329081">		
		on Sunday November 20, 2016 @08:02PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329081">#53329081</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329081"><p>I'm pretty sure that this "smart firewall" is more commonly known as a "firewall". Any firewall that can't block traffic can't legitimately be called a firewall at all.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329081">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="How is this different from any firewall by Paul Carver @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329081" data-title="How is this different from any firewall">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="How is this different from any firewall by Paul Carver" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329081" data-title="How is this different from any firewall">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="How is this different from any firewall by Paul Carver" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329081" data-title="How is this different from any firewall">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329081" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329081"></div>

<ul id="group_53329081">
	<li id="hiddens_53329081" class="hide"></li>
</ul>

<ul id="commtree_53329081"><li id="tree_53329105" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329105" class="commentstatus"></div>
<div id="comment_53329105" class="cw">
	<div id="comment_top_53329105" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329105" name="comment_link_53329105" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329105" onclick="return D2.setFocusComment(53329105)" >Re:</a>


		 	<span id="comment_score_53329105" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329105); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~johnjones">johnjones</a>  <span class="uid"><a href="//slashdot.org/~johnjones">( 14274 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329105"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329105"><p>exactly its just a firewall with IDS...</p><p>scary...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329105">

</div>
</div>

<div id="replyto_53329105"></div>

<ul id="group_53329105">
	<li id="hiddens_53329105" class="hide"></li>
</ul>

</li><li id="tree_53329137" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329137" class="commentstatus"></div>
<div id="comment_53329137" class="cw">
	<div id="comment_top_53329137" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329137" name="comment_link_53329137" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329137" onclick="return D2.setFocusComment(53329137)" >Smart part is auto-config</a>


		 	<span id="comment_score_53329137" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329137); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SuperKendall">SuperKendall</a>  <span class="uid"><a href="//slashdot.org/~SuperKendall">( 25149 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329137"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329137"><p>Yes it's just a firewall.</p><p>The smart part would be it only acts as a firewall for IoT devices (welbcams, toasters, receivers) - basically anything with embedded networking in the user would not think to monitor. And it would know what app traffic to allow to connect to the device externally...</p><p>Someone like you or me can easily just configure a firewall to do whatever.  But such a device would be great to be able to point non-technical (or even technical but uninteresting in networking) friends and family at.</p><p>I<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329137">

</div>
</div>

<div id="replyto_53329137"></div>

<ul id="group_53329137">
	<li id="hiddens_53329137" class="hide"></li>
</ul>

</li><li id="tree_53329195" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329195" class="commentstatus"></div>
<div id="comment_53329195" class="cw">
	<div id="comment_top_53329195" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329195" name="comment_link_53329195" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329195" onclick="return D2.setFocusComment(53329195)" >Re:</a>


		 	<span id="comment_score_53329195" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329195); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329195"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329195">It all works well until the user lets the internet see a device and a device see the internet so it will finally work on their phone or on another computer.<br>
That ramp up of packets out is hard to stop if its left wide open for CCTV been recorded on an internal network but it then becomes part of a swarm flooding an ip in another nation.<br>
Users with click on anything in a GUI to finally get something networked but then feel safe they have hardware securing their network.  <br>
AV is really the better step.  Try a</div>
	</div>

	<div class="commentSub" id="comment_sub_53329195">

</div>
</div>

<div id="replyto_53329195"></div>

<ul id="group_53329195">
	<li id="hiddens_53329195" class="hide"></li>
</ul>

</li><li id="tree_53329103" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329103" class="commentstatus"></div>
<div id="comment_53329103" class="cw">
</div>

<div id="replyto_53329103"></div>

<ul id="group_53329103">
	<li id="hiddens_53329103" class="hide"></li>
</ul>

<ul id="commtree_53329103"><li id="tree_53329643" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329643" class="commentstatus"></div>
<div id="comment_53329643" class="cw">
</div>

<div id="replyto_53329643"></div>

<ul id="group_53329643">
	<li id="hiddens_53329643" class="hide"></li>
</ul>

<ul id="commtree_53329643"><li id="tree_53329881" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329881" class="commentstatus"></div>
<div id="comment_53329881" class="cw">
	<div id="comment_top_53329881" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329881" name="comment_link_53329881" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329881" onclick="return D2.setFocusComment(53329881)" >Re:</a>


		 	<span id="comment_score_53329881" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329881); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329881"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329881"><p>The dime-a-dozen solutions are not up to this task.  It would require a subscription to an actively maintained (by the manufacturer or a third party security shop) set of behavioral profiles and updates for when the cloud/app vendors switch things around unannounced.  What we're talking about here is the ability to differentiate between typical behavior and aberrant behavior.  Such exists in the professional NGFW space, mostly.  Note that IoT devices generally do not take direct inbound connections through<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329881">

</div>
</div>

<div id="replyto_53329881"></div>

<ul id="group_53329881">
	<li id="hiddens_53329881" class="hide"></li>
</ul>

<ul id="commtree_53329881"><li id="tree_53329997" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329997" class="commentstatus"></div>
<div id="comment_53329997" class="cw">
	<div id="comment_top_53329997" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329997" name="comment_link_53329997" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329997" onclick="return D2.setFocusComment(53329997)" >Re:</a>


		 	<span id="comment_score_53329997" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329997); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~grahamsz">grahamsz</a>  <span class="uid"><a href="//slashdot.org/~grahamsz">( 150076 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329997"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329997"><p>Plus at that point wouldn't a good heuristic firewall be nearly as helpful. Something that could say "yo, this sprinkler controller is trying to send out lots more data than it normally does" would probably work almost as well but not need the ongoing configuration.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329997">

</div>
</div>

<div id="replyto_53329997"></div>

<ul id="group_53329997">
	<li id="hiddens_53329997" class="hide"></li>
</ul>

<ul id="commtree_53329997"><li id="tree_53331415" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331415" class="commentstatus"></div>
<div id="comment_53331415" class="cw">
	<div id="comment_top_53331415" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331415" name="comment_link_53331415" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331415" onclick="return D2.setFocusComment(53331415)" >Re:</a>


		 	<span id="comment_score_53331415" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331415); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331415"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331415"><p>To some extent that might work, until the IoT vendor updates the firmware or cloud service to legitimately send more traffic than it normally used to.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331415">

</div>
</div>

<div id="replyto_53331415"></div>

<ul id="group_53331415">
	<li id="hiddens_53331415" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li></ul></li><li id="tree_53329099" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329099" class="commentstatus"></div>
<div id="comment_53329099" class="cw">
	<div id="comment_top_53329099" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329099" name="comment_link_53329099" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329099" onclick="return D2.setFocusComment(53329099)" >mssp</a>


		 	<span id="comment_score_53329099" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329099); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jbmartin6">jbmartin6</a>  <span class="uid"><a href="//slashdot.org/~jbmartin6">( 1232050 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329099">		
		on Sunday November 20, 2016 @08:07PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329099">#53329099</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329099">Sounds like you want to spin up a managed security provider for home users, to manage their gateways. It's been tried before, but not enough people want to pay for it. Much easier and more economical to just get large ISPs to do it. All we need is the right leverage. As Bruce Schneier observed, it is in part a problem because the device manufacturers and the home users really don't have a strong motivation (yet) to do anything.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329099">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="mssp by jbmartin6 @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329099" data-title="mssp">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="mssp by jbmartin6" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329099" data-title="mssp">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="mssp by jbmartin6" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329099" data-title="mssp">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329099" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329099"></div>

<ul id="group_53329099">
	<li id="hiddens_53329099" class="hide"></li>
</ul>

<ul id="commtree_53329099"><li id="tree_53329639" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329639" class="commentstatus"></div>
<div id="comment_53329639" class="cw">
	<div id="comment_top_53329639" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329639" name="comment_link_53329639" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329639" onclick="return D2.setFocusComment(53329639)" >Re:</a>


		 	<span id="comment_score_53329639" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329639); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nnull">nnull</a>  <span class="uid"><a href="//slashdot.org/~nnull">( 1148259 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329639"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329639">Most home owners don't care. They want to plugin their device and use it. They don't worry about security or even care about it most of the time because they don't understand it at all. When you make your device to restrictive, they complain.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329639">

</div>
</div>

<div id="replyto_53329639"></div>

<ul id="group_53329639">
	<li id="hiddens_53329639" class="hide"></li>
</ul>

</li><li id="tree_53331119" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331119" class="commentstatus"></div>
<div id="comment_53331119" class="cw">
	<div id="comment_top_53331119" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331119" name="comment_link_53331119" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331119" onclick="return D2.setFocusComment(53331119)" >Re:</a>


		 	<span id="comment_score_53331119" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331119); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331119"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331119"><p>If we create a standard via RfC for it, and routers start to implement it, then in a few years it will become prevalent like WPS and UPnP did. You don't need 100% coverage for it to be useful. Manufacturers can sell it as a feature, "IoT Security(TM)" or whatever.</p><p>ISPs will soon upgrade the free routers that they gave to their customers if it prevents their networks becoming massive botnets and cuts down on support costs.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331119">

</div>
</div>

<div id="replyto_53331119"></div>

<ul id="group_53331119">
	<li id="hiddens_53331119" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329115" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329115" class="commentstatus"></div>
<div id="comment_53329115" class="cw">
	<div id="comment_top_53329115" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329115" name="comment_link_53329115" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329115" onclick="return D2.setFocusComment(53329115)" >Social problem, not technical</a>


		 	<span id="comment_score_53329115" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329115); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Areyoukiddingme">Areyoukiddingme</a>  <span class="uid"><a href="//slashdot.org/~Areyoukiddingme">( 1289470 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329115"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329115"><p>As is so frequently the case, you're trying to solve a social problem with a purely technical solution.  Would such a device work?  Of course.  Would many of the dozens of existing router products work, if properly configured?  Yes.  Does any of this matter?  No.  People don't care what devices on their network are doing as long as they appear to mostly be doing what they want.  If they're doing other things, people are completely oblivious, and get petulant if you point out their ignorance.</p><p>The only market-<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329115">

</div>
</div>

<div id="replyto_53329115"></div>

<ul id="group_53329115">
	<li id="hiddens_53329115" class="hide"></li>
</ul>

</li><li id="tree_53329119" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329119" class="commentstatus"></div>
<div id="comment_53329119" class="cw">
	<div id="comment_top_53329119" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329119" name="comment_link_53329119" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329119" onclick="return D2.setFocusComment(53329119)" >Why yes! There is. It's called </a>


		 	<span id="comment_score_53329119" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329119); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RightwingNutjob">RightwingNutjob</a>  <span class="uid"><a href="//slashdot.org/~RightwingNutjob">( 1302813 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329119">		
		on Sunday November 20, 2016 @08:09PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329119">#53329119</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329119">not plugging your fucking toaster into the internet so it cat tweet out whenever your toast is done.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329119">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Why yes! There is. It's called  by RightwingNutjob @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329119" data-title="Why yes! There is. It's called ">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Why yes! There is. It's called  by RightwingNutjob" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329119" data-title="Why yes! There is. It's called ">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Why yes! There is. It's called  by RightwingNutjob" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329119" data-title="Why yes! There is. It's called ">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329119" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329119"></div>

<ul id="group_53329119">
	<li id="hiddens_53329119" class="hide"></li>
</ul>

</li><li id="tree_53329135" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329135" class="commentstatus"></div>
<div id="comment_53329135" class="cw">
	<div id="comment_top_53329135" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329135" name="comment_link_53329135" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329135" onclick="return D2.setFocusComment(53329135)" >I think this would be a major challenge</a>


		 	<span id="comment_score_53329135" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329135); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~eth1">eth1</a>  <span class="uid"><a href="//slashdot.org/~eth1">( 94901 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329135"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329135"><p>One of the things I do for a living is write firewall policy. We use Palo Alto gear, which seems to be some of the best available at automatically identifying what stuff is.</p><p>Even with a company like that behind the gear spending a lot of time and money keeping things up to date, it doesn't know about every little thing it sees.</p><p>Another challenge is that this device would need to be able to do SSL forward proxy for everything, or all it will know is there's an ssl connection to somewhere (although you can use<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329135">

</div>
</div>

<div id="replyto_53329135"></div>

<ul id="group_53329135">
	<li id="hiddens_53329135" class="hide"></li>
</ul>

<ul id="commtree_53329135"><li id="tree_53329271" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329271" class="commentstatus"></div>
<div id="comment_53329271" class="cw">
	<div id="comment_top_53329271" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329271" name="comment_link_53329271" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329271" onclick="return D2.setFocusComment(53329271)" >Re:</a>


		 	<span id="comment_score_53329271" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329271); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329271"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329271">"CIA Chief: We&rsquo;ll Spy on You Through Your Dishwasher" <br>
<a href="https://www.wired.com/2012/03/petraeus-tv-remote/" title="wired.com">https://www.wired.com/2012/03/...<span class="substr"> </span></a> [wired.com] <br> and the UK having its Investigatory Powers Act 2016https://en.wikipedia.org/wiki/Investigatory_Powers_Act_2016 with equipment interference. <br>
With so many mil and gov groups now interested in the IoT what can any firewall be ready for?<br>
Be able to look for alterations, strange pushed updates not from the user, developer?<br>
Re 'That means somehow getting a signing cert onto the device that all of the IoT things trust.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329271">

</div>
</div>

<div id="replyto_53329271"></div>

<ul id="group_53329271">
	<li id="hiddens_53329271" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329143" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329143" class="commentstatus"></div>
<div id="comment_53329143" class="cw">
	<div id="comment_top_53329143" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329143" name="comment_link_53329143" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329143" onclick="return D2.setFocusComment(53329143)" >VPN only</a>


		 	<span id="comment_score_53329143" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329143); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~manu0601">manu0601</a>  <span class="uid"><a href="//slashdot.org/~manu0601">( 2221348 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329143"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329143"><p>Such a device could turn IoT device connectivity into an on-demand VPN only setup.</p><p>Of course, having to fire a VPN client before interacting with the IoT device would be a hassle, but perhaps that could be made automatic. Another problem is that some IoT devices are useless if not connected to the cloud.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329143">

</div>
</div>

<div id="replyto_53329143"></div>

<ul id="group_53329143">
	<li id="hiddens_53329143" class="hide"></li>
</ul>

<ul id="commtree_53329143"><li id="tree_53329291" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329291" class="commentstatus"></div>
<div id="comment_53329291" class="cw">
</div>

<div id="replyto_53329291"></div>

<ul id="group_53329291">
	<li id="hiddens_53329291" class="hide"></li>
</ul>

<ul id="commtree_53329291"><li id="tree_53329965" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329965" class="commentstatus"></div>
<div id="comment_53329965" class="cw">
	<div id="comment_top_53329965" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329965" name="comment_link_53329965" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329965" onclick="return D2.setFocusComment(53329965)" >Re:</a>


		 	<span id="comment_score_53329965" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329965); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~skids">skids</a>  <span class="uid"><a href="//slashdot.org/~skids">( 119237 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329965"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329965"><p>In the minds of the vendors, it is "necessary" because a) their software only barely works at ship-time and is still under active development for the first few years of product support, so the more of it that is server side, the better and b) their business model involves selling the below actual cost and making up the difference by selling to big-data consumers.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329965">

</div>
</div>

<div id="replyto_53329965"></div>

<ul id="group_53329965">
	<li id="hiddens_53329965" class="hide"></li>
</ul>

<ul id="commtree_53329965"><li id="tree_53331317" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331317" class="commentstatus"></div>
<div id="comment_53331317" class="cw">
	<div id="comment_top_53331317" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331317" name="comment_link_53331317" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331317" onclick="return D2.setFocusComment(53331317)" >Re:</a>


		 	<span id="comment_score_53331317" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331317); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~silas_moeckel">silas_moeckel</a>  <span class="uid"><a href="//slashdot.org/~silas_moeckel">( 234313 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331317"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331317"><p>Not to sure on that selling under cost.  A single nest costs more than the vera and the 4 zwave thermostats I needed.  And a Vera works fine with no internet access.</p><p>Really though a smart local controller and dumb devices is a good model.  I dont want to replace ever dimmer in my house every few years thats something that should last decades.  On the other hand the controller needs security updates new features etc etc.  That also gives you a very defined exposure point the be hardened.  While the M&amp;M se<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331317">

</div>
</div>

<div id="replyto_53331317"></div>

<ul id="group_53331317">
	<li id="hiddens_53331317" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_53329321" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329321" class="commentstatus"></div>
<div id="comment_53329321" class="cw">
	<div id="comment_top_53329321" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329321" name="comment_link_53329321" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329321" onclick="return D2.setFocusComment(53329321)" >Endian UTM</a>


		 	<span id="comment_score_53329321" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329321); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thechemic">thechemic</a>  <span class="uid"><a href="//slashdot.org/~thechemic">( 1329333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329321"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329321">I'd recommend Endian Firewall.  It could accomplish this quite easily, and its simple to setup.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329321">

</div>
</div>

<div id="replyto_53329321"></div>

<ul id="group_53329321">
	<li id="hiddens_53329321" class="hide"></li>
</ul>

</li><li id="tree_53329351" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329351" class="commentstatus"></div>
<div id="comment_53329351" class="cw">
	<div id="comment_top_53329351" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329351" name="comment_link_53329351" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329351" onclick="return D2.setFocusComment(53329351)" >The answer is no, this is pointless</a>


		 	<span id="comment_score_53329351" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329351); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~caseih">caseih</a>  <span class="uid"><a href="//slashdot.org/~caseih">( 160668 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329351">		
		on Sunday November 20, 2016 @08:51PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329351">#53329351</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329351"><p>Something about these recent DDoS attacks originating from IoT has always bothered me. And I think it's that many of these vulnerable IoT devices are already behind firewalls from the open internet.  I'd wager that most people's thermostats, smart lights, sprinkerly systems, etc are all attached to their local WiFi, not the open Internet.  So the question is, how were these devices compromised?  I've not read anything on the internet that explains this, other then lists of default usernames and passwords.  So I'm left with the conclusion that most IoT devices are hacked probably by malware on the local LAN from existing desktop computers.  And the compromise occurs over services that are purposely exposed to the LAN, like a web interface.  Of course compromised IoT devices then seek out and attack other IoT devices.</p><p>But the point I'm getting at is that a firewall just isn't going to stop this from happening, since the exploited services are open to incoming connections (from the LAN) by design.  Obviously a device on the open internet is stupid and needs to be firewalled.  But on your LAN a custom little smart firewall is not going to do squat.</p><p>The only vendors take security seriously and stop using default passwords and actively try to stamp out security flaws in the software itself such as buffer overruns, cross-site scripting flaws, or database injection, will IoT devices cease to become vulnerable.  But I have my doubts these devices will ever be secured.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329351">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="The answer is no, this is pointless by caseih @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329351" data-title="The answer is no, this is pointless">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="The answer is no, this is pointless by caseih" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329351" data-title="The answer is no, this is pointless">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="The answer is no, this is pointless by caseih" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329351" data-title="The answer is no, this is pointless">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329351" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329351"></div>

<ul id="group_53329351">
	<li id="hiddens_53329351" class="hide"></li>
</ul>

<ul id="commtree_53329351"><li id="tree_53329461" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329461" class="commentstatus"></div>
<div id="comment_53329461" class="cw">
	<div id="comment_top_53329461" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329461" name="comment_link_53329461" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329461" onclick="return D2.setFocusComment(53329461)" >Re:The answer is no, this is pointless</a>


		 	<span id="comment_score_53329461" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329461); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Wizarth">Wizarth</a>  <span class="uid"><a href="//slashdot.org/~Wizarth">( 785742 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329461">		
		on Sunday November 20, 2016 @09:21PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329461">#53329461</a>)
		<small><a href="http://www.wizarth.com.au/" title="http://www.wizarth.com.au/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329461"><p>I understand there is also some sillyness involving UPNP in some devices, so you can connect to the device "from your phone", as in, from the wider Internet. This probably includes the initial connection brokered through a central service, but much of the bulk data via direct connection.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329461">
<span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53329351" onclick="return D2.selectParent(53329351)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:The answer is no, this is pointless by Wizarth @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329461" data-title="Re:The answer is no, this is pointless">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:The answer is no, this is pointless by Wizarth" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329461" data-title="Re:The answer is no, this is pointless">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:The answer is no, this is pointless by Wizarth" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329461" data-title="Re:The answer is no, this is pointless">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329461" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329461"></div>

<ul id="group_53329461">
	<li id="hiddens_53329461" class="hide"></li>
</ul>

<ul id="commtree_53329461"><li id="tree_53329583" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329583" class="commentstatus"></div>
<div id="comment_53329583" class="cw">
	<div id="comment_top_53329583" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329583" name="comment_link_53329583" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329583" onclick="return D2.setFocusComment(53329583)" >Re:</a>


		 	<span id="comment_score_53329583" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329583); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~caseih">caseih</a>  <span class="uid"><a href="//slashdot.org/~caseih">( 160668 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329583"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329583"><p>Okay that makes a lot of sense. I hadn't thought about the implications of things like UDP NAT traversal (and apparently neither did any of the companies involved in compromised IoT devices).  It makes sense that devices that use unencrypted traffic, after using a third party to establish the connection, are vulnerable to third parties messing with those packets and executing an exploit.</p><p>This makes the answer to the Ask Slashdot question even more of a solid NO!  A smart firewall just isn't going to help us<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329583">

</div>
</div>

<div id="replyto_53329583"></div>

<ul id="group_53329583">
	<li id="hiddens_53329583" class="hide"></li>
</ul>

</li><li id="tree_53329593" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329593" class="commentstatus"></div>
<div id="comment_53329593" class="cw">
	<div id="comment_top_53329593" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329593" name="comment_link_53329593" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329593" onclick="return D2.setFocusComment(53329593)" >Re:</a>


		 	<span id="comment_score_53329593" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329593); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Orgasmatron">Orgasmatron</a>  <span class="uid"><a href="//slashdot.org/~Orgasmatron">( 8103 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329593"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329593"><p>Yup, this.  Virtually all commercially available IOT crap is spyware.  It opens a port on your firewall with UPNP, then phones home to the device's owner (aka not you).  The device's owner also gives you an app for your phone that snoops on you and connects to their device that you've installed in your home.</p><p>Building a botnet can be as easy as port-scanning the UPNP-assignable ranges of a few popular home routers on a few big ISPs and exploiting any vulnerable devices that respond.</p><p>Oh, and if you already have<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329593">

</div>
</div>

<div id="replyto_53329593"></div>

<ul id="group_53329593">
	<li id="hiddens_53329593" class="hide"></li>
</ul>

<ul id="commtree_53329593"><li id="tree_53330019" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330019" class="commentstatus"></div>
<div id="comment_53330019" class="cw">
	<div id="comment_top_53330019" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330019" name="comment_link_53330019" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330019" onclick="return D2.setFocusComment(53330019)" >Re:</a>


		 	<span id="comment_score_53330019" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330019); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~grahamsz">grahamsz</a>  <span class="uid"><a href="//slashdot.org/~grahamsz">( 150076 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330019"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330019"><p>Virtually all of mine is zwave. It connects through a bridge to the internet and so while you could compromise the bridge you'd never really compromise the device. The light switch lacks wifi, lacks any concept of an IP address and I struggle to see any viable exploit against that.</p><p>The idea of buying a mismatch of nonstandard wifi bulbs from different suppliers just sounds like a nightmare.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330019">

</div>
</div>

<div id="replyto_53330019"></div>

<ul id="group_53330019">
	<li id="hiddens_53330019" class="hide"></li>
</ul>

</li><li id="tree_53330845" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330845" class="commentstatus"></div>
<div id="comment_53330845" class="cw">
	<div id="comment_top_53330845" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330845" name="comment_link_53330845" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330845" onclick="return D2.setFocusComment(53330845)" >Re:</a>


		 	<span id="comment_score_53330845" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330845); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jabuzz">jabuzz</a>  <span class="uid"><a href="//slashdot.org/~jabuzz">( 182671 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330845"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330845"><p>I have upnp turned off on every router that I can. It is basically the biggest heap of junk there has ever been.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330845">

</div>
</div>

<div id="replyto_53330845"></div>

<ul id="group_53330845">
	<li id="hiddens_53330845" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53329603" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329603" class="commentstatus"></div>
<div id="comment_53329603" class="cw">
	<div id="comment_top_53329603" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329603" name="comment_link_53329603" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329603" onclick="return D2.setFocusComment(53329603)" >Re:</a>


		 	<span id="comment_score_53329603" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329603); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~complete+loony">complete loony</a>  <span class="uid"><a href="//slashdot.org/~complete+loony">( 663508 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329603"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329603"><p>Many IOT devices have some kind of incoming data stream from the internet so that you can control them from your phone. This might be is via some company run cloud service, with questionable security.
</p><p> <a href="https://mjg59.dreamwidth.org/40397.html" title="dreamwidth.org">For example</a> [dreamwidth.org],</p><p><div class="quote"><p>it's a device that infringes my copyright, gives you root access in response to trivial credentials, has access control that depends entirely on nobody ever looking at the packets, is sufficiently poorly implemented that you can crash both it and the bulbs, has a cloud access protocol that has no security whatsoever and also acts as an easy mechanism for people to circumvent your network security</p></div></div>
	</div>

	<div class="commentSub" id="comment_sub_53329603">

</div>
</div>

<div id="replyto_53329603"></div>

<ul id="group_53329603">
	<li id="hiddens_53329603" class="hide"></li>
</ul>

</li><li id="tree_53329747" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329747" class="commentstatus"></div>
<div id="comment_53329747" class="cw">
	<div id="comment_top_53329747" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329747" name="comment_link_53329747" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329747" onclick="return D2.setFocusComment(53329747)" >Re:</a>


		 	<span id="comment_score_53329747" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329747); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aaarrrgggh">aaarrrgggh</a>  <span class="uid"><a href="//slashdot.org/~aaarrrgggh">( 9205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329747"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329747">Most consumer firewalls are effectively just stateful firewalls: they trust the local network explicitly, and trust any connections they make to the outside are legitimate, and trust any outside connections back as necessary.</div>
	</div>

	<div class="commentSub" id="comment_sub_53329747">

</div>
</div>

<div id="replyto_53329747"></div>

<ul id="group_53329747">
	<li id="hiddens_53329747" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329397" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329397" class="commentstatus"></div>
<div id="comment_53329397" class="cw">
	<div id="comment_top_53329397" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329397" name="comment_link_53329397" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329397" onclick="return D2.setFocusComment(53329397)" >Too much think about and too much to deal with</a>


		 	<span id="comment_score_53329397" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329397); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dugancent">dugancent</a>  <span class="uid"><a href="//slashdot.org/~dugancent">( 2616577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329397"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329397"><p>I have exactly four items that connect to the internet, my laptop, roku, wii and iPhone.  I'm not connecting my lightbulbs, outlets, fridge, thermostat or any other ridiculous crap.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329397">

</div>
</div>

<div id="replyto_53329397"></div>

<ul id="group_53329397">
	<li id="hiddens_53329397" class="hide"></li>
</ul>

</li><li id="tree_53329463" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329463" class="commentstatus"></div>
<div id="comment_53329463" class="cw">
	<div id="comment_top_53329463" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329463" name="comment_link_53329463" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329463" onclick="return D2.setFocusComment(53329463)" >For this to really work</a>


		 	<span id="comment_score_53329463" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329463); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~taustin">taustin</a>  <span class="uid"><a href="//slashdot.org/~taustin">( 171655 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329463"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329463"><p>the manufacturers would have to provide, in some form, what their devices are supposed to be able to connect to, so that the firewall can block it from connecting to everything else.</p><p>In other words, manufacturers would have to admit how extensively their devices spy on you, and phone home with it, and open themselves up to easy consumer monitoring of what their devices send back.</p><p>I'm not holding my breath.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329463">

</div>
</div>

<div id="replyto_53329463"></div>

<ul id="group_53329463">
	<li id="hiddens_53329463" class="hide"></li>
</ul>

<ul id="commtree_53329463"><li id="tree_53329537" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329537" class="commentstatus"></div>
<div id="comment_53329537" class="cw">
</div>

<div id="replyto_53329537"></div>

<ul id="group_53329537">
	<li id="hiddens_53329537" class="hide"></li>
</ul>

<ul id="commtree_53329537"><li id="tree_53330423" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330423" class="commentstatus"></div>
<div id="comment_53330423" class="cw">
	<div id="comment_top_53330423" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330423" name="comment_link_53330423" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330423" onclick="return D2.setFocusComment(53330423)" >Re:</a>


		 	<span id="comment_score_53330423" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330423); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~stooo">stooo</a>  <span class="uid"><a href="//slashdot.org/~stooo">( 2202012 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330423"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330423"><p>&gt;&gt; This is the sort of malware signature/whitelist-pattern database that can be easily generated and maintained<br>No. If it was easy, it would already have been done.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330423">

</div>
</div>

<div id="replyto_53330423"></div>

<ul id="group_53330423">
	<li id="hiddens_53330423" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53329481" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329481" class="commentstatus"></div>
<div id="comment_53329481" class="cw">
	<div id="comment_top_53329481" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329481" name="comment_link_53329481" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329481" onclick="return D2.setFocusComment(53329481)" >Put them on a different service.</a>


		 	<span id="comment_score_53329481" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329481); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~0100010001010011">0100010001010011</a>  <span class="uid"><a href="//slashdot.org/~0100010001010011">( 652467 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329481"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329481"><p>My IoT switches are Z-wave. My thermostat is RS485. My individual temp feedback sensors are passive 433 MHz.</p><p>It's another layer of abstraction and less holes to plug than just letting everything have unfettered access to the outside world.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329481">

</div>
</div>

<div id="replyto_53329481"></div>

<ul id="group_53329481">
	<li id="hiddens_53329481" class="hide"></li>
</ul>

</li><li id="tree_53329545" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329545" class="commentstatus"></div>
<div id="comment_53329545" class="cw">
	<div id="comment_top_53329545" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329545" name="comment_link_53329545" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329545" onclick="return D2.setFocusComment(53329545)" >There may be a probem here...</a>


		 	<span id="comment_score_53329545" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329545); return false"><span class=opt>Score:</span>3</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Eezy+Bordone">Eezy Bordone</a>  <span class="uid"><a href="//slashdot.org/~Eezy+Bordone">( 645987 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329545">		
		on Sunday November 20, 2016 @09:41PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329545">#53329545</a>)
		<small><a href="http://www.bordone.com/" title="http://www.bordone.com/" class="user_homepage_display" rel="nofollow">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329545">Wait a minute. You want someone to make a device that will identify random IoT devices when we can't even get current home/soho router/firewall device makers to update <b>THEIR</b> firmware?</div>
	</div>

	<div class="commentSub" id="comment_sub_53329545">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="There may be a probem here... by Eezy Bordone @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329545" data-title="There may be a probem here...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="There may be a probem here... by Eezy Bordone" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329545" data-title="There may be a probem here...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="There may be a probem here... by Eezy Bordone" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329545" data-title="There may be a probem here...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329545" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329545"></div>

<ul id="group_53329545">
	<li id="hiddens_53329545" class="hide"></li>
</ul>

</li><li id="tree_53329767" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53329767" class="commentstatus"></div>
<div id="comment_53329767" class="cw">
	<div id="comment_top_53329767" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329767" name="comment_link_53329767" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329767" onclick="return D2.setFocusComment(53329767)" >Yes.  With a single acronym change.</a>


		 	<span id="comment_score_53329767" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329767); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tlambert">tlambert</a>  <span class="uid"><a href="//slashdot.org/~tlambert">( 566799 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329767">		
		on Sunday November 20, 2016 @11:00PM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329767">#53329767</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329767"><p>Yes.  With a single acronym change.</p><p>IoT "Internet of Things" --&gt; IoT "Intranet of Things"</p><p>Connect them to a local Intranet server, instead of trying to connect them to a server in China, or at Google, or to everyone in the world, and they are no longer a problem.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329767">
	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Yes.  With a single acronym change. by tlambert @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329767" data-title="Yes.  With a single acronym change.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Yes.  With a single acronym change. by tlambert" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329767" data-title="Yes.  With a single acronym change.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Yes.  With a single acronym change. by tlambert" data-url="https://ask.slashdot.org/comments.pl?sid=9903511&cid=53329767" data-title="Yes.  With a single acronym change.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=9903511%26cid=53329767" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>

</div>
</div>

<div id="replyto_53329767"></div>

<ul id="group_53329767">
	<li id="hiddens_53329767" class="hide"></li>
</ul>

</li><li id="tree_53330411" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330411" class="commentstatus"></div>
<div id="comment_53330411" class="cw">
	<div id="comment_top_53330411" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330411" name="comment_link_53330411" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330411" onclick="return D2.setFocusComment(53330411)" >A Fire</a>


		 	<span id="comment_score_53330411" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330411); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~stooo">stooo</a>  <span class="uid"><a href="//slashdot.org/~stooo">( 2202012 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330411"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330411"><p>&gt;&gt; Could A 'Smart Firewall' Protect IoT Devices?<br>No. A big fire would be more adequate.<br>IOT is BS.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330411">

</div>
</div>

<div id="replyto_53330411"></div>

<ul id="group_53330411">
	<li id="hiddens_53330411" class="hide"></li>
</ul>

</li><li id="tree_53330593" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330593" class="commentstatus"></div>
<div id="comment_53330593" class="cw">
	<div id="comment_top_53330593" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330593" name="comment_link_53330593" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330593" onclick="return D2.setFocusComment(53330593)" >Not the right audience</a>


		 	<span id="comment_score_53330593" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330593); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~flux">flux</a>  <span class="uid"><a href="//slashdot.org/~flux">( 5274 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330593"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330593"><p>You don't need to be worried about people who might think about hooking up a special router or even RPi to their network to deal with IoT devices, but rather with people that don't. And that's going to be pretty difficult to solve before all consumer routers come with decent default firewall rules or such additional functionality you're describing.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330593">

</div>
</div>

<div id="replyto_53330593"></div>

<ul id="group_53330593">
	<li id="hiddens_53330593" class="hide"></li>
</ul>

</li><li id="tree_53330669" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330669" class="commentstatus"></div>
<div id="comment_53330669" class="cw">
	<div id="comment_top_53330669" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330669" name="comment_link_53330669" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330669" onclick="return D2.setFocusComment(53330669)" >Already exists.</a>


		 	<span id="comment_score_53330669" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330669); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CountBrass">CountBrass</a>  <span class="uid"><a href="//slashdot.org/~CountBrass">( 590228 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330669"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330669"><p>It's called a<nobr> <wbr></nobr>... wait for it... a network firewall!</p><p>You would then whitelist the routes you want to allow.</p><p>And whatever you do, you would not let your IoT device update the firewall's ruleset!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330669">

</div>
</div>

<div id="replyto_53330669"></div>

<ul id="group_53330669">
	<li id="hiddens_53330669" class="hide"></li>
</ul>

</li><li id="tree_53330849" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330849" class="commentstatus"></div>
<div id="comment_53330849" class="cw">
	<div id="comment_top_53330849" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330849" name="comment_link_53330849" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330849" onclick="return D2.setFocusComment(53330849)" >Could A 'Smart Firewall' Protect IoT Devices?</a>


		 	<span id="comment_score_53330849" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330849); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cheetah_spottycat">cheetah_spottycat</a>  <span class="uid"><a href="//slashdot.org/~cheetah_spottycat">( 106624 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330849"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330849">Could A 'Smart Firewall' Protect IoT Devices?

No.

"Smart" firewalls are in fact the problem. Getting rid of them, and using regular non-smart firewalls that only allow incoming connections when you explicitly and manually configured them to do so can protect your IoT devices.</div>
	</div>

	<div class="commentSub" id="comment_sub_53330849">

</div>
</div>

<div id="replyto_53330849"></div>

<ul id="group_53330849">
	<li id="hiddens_53330849" class="hide"></li>
</ul>

</li><li id="tree_53331259" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331259" class="commentstatus"></div>
<div id="comment_53331259" class="cw">
	<div id="comment_top_53331259" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331259" name="comment_link_53331259" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331259" onclick="return D2.setFocusComment(53331259)" >It Could Work</a>


		 	<span id="comment_score_53331259" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331259); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~yithar7153">yithar7153</a>  <span class="uid"><a href="//slashdot.org/~yithar7153">( 4137793 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331259"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331259">I use a Raspberry Pi as a firewall between the ISP's router and my network. And I could only allow specific access for certain devices while denying the rest of the access. The downside is that even a RPi3 has limits on bandwidth, but eh, my speeds are crap anyways. 11.8 Mbps download, and 9.8 MBps upload.</div>
	</div>

	<div class="commentSub" id="comment_sub_53331259">

</div>
</div>

<div id="replyto_53331259"></div>

<ul id="group_53331259">
	<li id="hiddens_53331259" class="hide"></li>
</ul>

</li><li id="tree_53331293" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331293" class="commentstatus"></div>
<div id="comment_53331293" class="cw">
	<div id="comment_top_53331293" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331293" name="comment_link_53331293" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331293" onclick="return D2.setFocusComment(53331293)" >sure</a>


		 	<span id="comment_score_53331293" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331293); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Torvac">Torvac</a>  <span class="uid"><a href="//slashdot.org/~Torvac">( 691504 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331293"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331293">hide a potentially broken/hackable device behind another potentially broken/misconfigured device. the internet of things is bullshit, just remove these items and never talk about them again.</div>
	</div>

	<div class="commentSub" id="comment_sub_53331293">

</div>
</div>

<div id="replyto_53331293"></div>

<ul id="group_53331293">
	<li id="hiddens_53331293" class="hide"></li>
</ul>

</li><li id="tree_53331349" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331349" class="commentstatus"></div>
<div id="comment_53331349" class="cw">
	<div id="comment_top_53331349" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331349" name="comment_link_53331349" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331349" onclick="return D2.setFocusComment(53331349)" >Isn't the problem more to do with default username</a>


		 	<span id="comment_score_53331349" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331349); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mrmaster">mrmaster</a>  <span class="uid"><a href="//slashdot.org/~mrmaster">( 535266 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331349"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331349">Isn't the problem the default usernames and passwords not being changed instead of what ports they are listening on? I know I got an infected raspberry pi because I forgot to change the root password.  The pi did need outside access so blocking the ports would have made the device useless to me. Stupid mistake I know but most people don't know. Look at consumer routers and their default usernames and passwords.</div>
	</div>

	<div class="commentSub" id="comment_sub_53331349">

</div>
</div>

<div id="replyto_53331349"></div>

<ul id="group_53331349">
	<li id="hiddens_53331349" class="hide"></li>
</ul>

</li><li id="tree_53331359" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331359" class="commentstatus"></div>
<div id="comment_53331359" class="cw">
	<div id="comment_top_53331359" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331359" name="comment_link_53331359" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331359" onclick="return D2.setFocusComment(53331359)" >What About The Router Designers?</a>


		 	<span id="comment_score_53331359" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331359); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Toad-san">Toad-san</a>  <span class="uid"><a href="//slashdot.org/~Toad-san">( 64810 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331359"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331359"><p>Couldn't a halfway decent modern router be designed to do something like this?</p><p>Naw<nobr> <wbr></nobr>.. never mind<nobr> <wbr></nobr>.. that's just crazy talk.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53331359">

</div>
</div>

<div id="replyto_53331359"></div>

<ul id="group_53331359">
	<li id="hiddens_53331359" class="hide"></li>
</ul>

</li><li id="tree_53331961" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53331961" class="commentstatus"></div>
<div id="comment_53331961" class="cw">
	<div id="comment_top_53331961" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53331961" name="comment_link_53331961" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53331961" onclick="return D2.setFocusComment(53331961)" >I've got the answer</a>


		 	<span id="comment_score_53331961" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53331961); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~wjcofkc">wjcofkc</a>  <span class="uid"><a href="//slashdot.org/~wjcofkc">( 964165 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53331961"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53331961">Let's replace the whole clusterfuck with a... FireCloud!</div>
	</div>

	<div class="commentSub" id="comment_sub_53331961">

</div>
</div>

<div id="replyto_53331961"></div>

<ul id="group_53331961">
	<li id="hiddens_53331961" class="hide"></li>
</ul>

</li><li id="tree_53329001" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329001" class="commentstatus"></div>
<div id="comment_53329001" class="cw">
</div>

<div id="replyto_53329001"></div>

<ul id="group_53329001">
	<li id="hiddens_53329001" class="hide"></li>
</ul>

<ul id="commtree_53329001"><li id="tree_53329093" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329093" class="commentstatus"></div>
<div id="comment_53329093" class="cw">
	<div id="comment_top_53329093" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329093" name="comment_link_53329093" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329093" onclick="return D2.setFocusComment(53329093)" >Re:</a>


		 	<span id="comment_score_53329093" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329093); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Great+Big+Bird">Great Big Bird</a>  <span class="uid"><a href="//slashdot.org/~Great+Big+Bird">( 1751616 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329093"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329093"><p>No, I think people of all ethnic persuasions could have this issue. Bravo for bringing race into it, do you have any particular list of people you want to express outrage for on their behalf? Because no, they can't speak for themselves. This white devil here forgot to check his privilege on the way in, I am so sorry about that.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329093">

</div>
</div>

<div id="replyto_53329093"></div>

<ul id="group_53329093">
	<li id="hiddens_53329093" class="hide"></li>
</ul>

<ul id="commtree_53329093"><li id="tree_53329159" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329159" class="commentstatus"></div>
<div id="comment_53329159" class="cw">
	<div id="comment_top_53329159" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329159" name="comment_link_53329159" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329159" onclick="return D2.setFocusComment(53329159)" >Re:</a>


		 	<span id="comment_score_53329159" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329159); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Patent+Lover">Patent Lover</a>  <span class="uid"><a href="//slashdot.org/~Patent+Lover">( 779809 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329159"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329159">  Good lord. I hope the diamonds in your ass don't hurt on the way out.

<a href="http://www.hulu.com/watch/317011" title="hulu.com">http://www.hulu.com/watch/3170...</a> [hulu.com]</div>
	</div>

	<div class="commentSub" id="comment_sub_53329159">

</div>
</div>

<div id="replyto_53329159"></div>

<ul id="group_53329159">
	<li id="hiddens_53329159" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53329057" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329057" class="commentstatus"></div>
<div id="comment_53329057" class="cw">
</div>

<div id="replyto_53329057"></div>

<ul id="group_53329057">
	<li id="hiddens_53329057" class="hide"></li>
</ul>

<ul id="commtree_53329057"><li id="tree_53329333" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329333" class="commentstatus"></div>
<div id="comment_53329333" class="cw">
	<div id="comment_top_53329333" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329333" name="comment_link_53329333" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329333" onclick="return D2.setFocusComment(53329333)" >Re:</a>


		 	<span id="comment_score_53329333" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329333); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hey!">hey!</a>  <span class="uid"><a href="//slashdot.org/~hey!">( 33014 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329333"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329333"><p><div class="quote"><p>No</p></div><p>Or <em>just as accurately</em>: yes.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53329333">

</div>
</div>

<div id="replyto_53329333"></div>

<ul id="group_53329333">
	<li id="hiddens_53329333" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329421" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329421" class="commentstatus"></div>
<div id="comment_53329421" class="cw">
</div>

<div id="replyto_53329421"></div>

<ul id="group_53329421">
	<li id="hiddens_53329421" class="hide"></li>
</ul>

<ul id="commtree_53329421"><li id="tree_53329509" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329509" class="commentstatus"></div>
<div id="comment_53329509" class="cw">
	<div id="comment_top_53329509" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329509" name="comment_link_53329509" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329509" onclick="return D2.setFocusComment(53329509)" >Re:</a>


		 	<span id="comment_score_53329509" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329509); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRealMindChild">TheRealMindChild</a>  <span class="uid"><a href="//slashdot.org/~TheRealMindChild">( 743925 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329509"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329509">If someone can access a device to which it can use port knocking, you already failed. Communication should only be done on the local network. If you wish to interface with it, set up a VPN tunnel to the local network</div>
	</div>

	<div class="commentSub" id="comment_sub_53329509">

</div>
</div>

<div id="replyto_53329509"></div>

<ul id="group_53329509">
	<li id="hiddens_53329509" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53328979" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53328979" class="commentstatus"></div>
<div id="comment_53328979" class="cw">
</div>

<div id="replyto_53328979"></div>

<ul id="group_53328979">
	<li id="hiddens_53328979" class="hide"></li>
</ul>

<ul id="commtree_53328979"><li id="tree_53329575" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53329575" class="commentstatus"></div>
<div id="comment_53329575" class="cw">
	<div id="comment_top_53329575" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53329575" name="comment_link_53329575" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53329575" onclick="return D2.setFocusComment(53329575)" >Re: Plenty of examples to go by</a>


		 	<span id="comment_score_53329575" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53329575); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~vocatan">vocatan</a>  <span class="uid"><a href="//slashdot.org/~vocatan">( 1374285 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53329575"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53329575">Steve Gibson had suggested a configuration of three routers to isolate IoT devices.

<a href="https://www.grc.com/sn/sn-545.pdf" title="grc.com" rel="nofollow">https://www.grc.com/sn/sn-545....</a> [grc.com]

Again, it depends on how much you want to put "common consumers" through.

I'd submit that unless it's ridiculously easy, the vast majority of consumers would simply scoff and claim it wasn't worth the trouble. (And those are the folks who probably were the main constituents of the recent botnets)</div>
	</div>

	<div class="commentSub" id="comment_sub_53329575">

</div>
</div>

<div id="replyto_53329575"></div>

<ul id="group_53329575">
	<li id="hiddens_53329575" class="hide"></li>
</ul>

</li><li id="tree_53330351" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330351" class="commentstatus"></div>
<div id="comment_53330351" class="cw">
	<div id="comment_top_53330351" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330351" name="comment_link_53330351" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330351" onclick="return D2.setFocusComment(53330351)" >Re: Plenty of examples to go by</a>


		 	<span id="comment_score_53330351" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330351); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~shitzu">shitzu</a>  <span class="uid"><a href="//slashdot.org/~shitzu">( 931108 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330351"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330351"><p>This does not need a special product. Any firewall will do, even a random consumer wifi router that has customizable firewall rules.<br>a) assign iot devices certain ip addresses<br>b) block all outgoing traffic from these</p><p>I have it done in a bit of more advanced way (VLANs), but thats not strictly necessary.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330351">

</div>
</div>

<div id="replyto_53330351"></div>

<ul id="group_53330351">
	<li id="hiddens_53330351" class="hide"></li>
</ul>

<ul id="commtree_53330351"><li id="tree_53330729" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330729" class="commentstatus"></div>
<div id="comment_53330729" class="cw">
	<div id="comment_top_53330729" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330729" name="comment_link_53330729" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330729" onclick="return D2.setFocusComment(53330729)" >Re:</a>


		 	<span id="comment_score_53330729" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330729); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330729"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330729"><p>The problem is that most IoT devices rely on a centralised server for their operation, so your (b) will prevent them from working.  Their smartphone app talks to the vendor's server and won't work without it.  You need to allow it to talk to the vendor's server, but not to anything else.</p><p>
That's also why the example in TFA won't work: you can't do this sort of filtering based on IP, because a lot of the vendors use multiple servers or even cloud hosting for the server component, so you'll end up having to al<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330729">

</div>
</div>

<div id="replyto_53330729"></div>

<ul id="group_53330729">
	<li id="hiddens_53330729" class="hide"></li>
</ul>

<ul id="commtree_53330729"><li id="tree_53330781" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330781" class="commentstatus"></div>
<div id="comment_53330781" class="cw">
	<div id="comment_top_53330781" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330781" name="comment_link_53330781" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330781" onclick="return D2.setFocusComment(53330781)" >Re:</a>


		 	<span id="comment_score_53330781" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330781); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~shitzu">shitzu</a>  <span class="uid"><a href="//slashdot.org/~shitzu">( 931108 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330781"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330781"><p>Yes, true. My iot things talk with my own OpenHAB installation and therefore I do not have that issue. But a generic out of the box behaviour on most of the iot stuff is to phone home as it simply cannot be connected by an app in your phone without forwarding ports etc (which is beyond a normal user's abilities).</p><p>TFA is a a question by a person who has no idea how ip networks and client/server/app communication works.</p><p>My only point was that we do not need a special IOT isolating appliance, this can all be don<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330781">

</div>
</div>

<div id="replyto_53330781"></div>

<ul id="group_53330781">
	<li id="hiddens_53330781" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53330953" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330953" class="commentstatus"></div>
<div id="comment_53330953" class="cw">
	<div id="comment_top_53330953" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330953" name="comment_link_53330953" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330953" onclick="return D2.setFocusComment(53330953)" >Why pay?</a>


		 	<span id="comment_score_53330953" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330953); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sabbede">sabbede</a>  <span class="uid"><a href="//slashdot.org/~sabbede">( 2678435 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330953"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330953">pfSense with Snort will block access to CnC servers.  Add in a DNS blackhole and you'll be in pretty good shape, for free.</div>
	</div>

	<div class="commentSub" id="comment_sub_53330953">

</div>
</div>

<div id="replyto_53330953"></div>

<ul id="group_53330953">
	<li id="hiddens_53330953" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329401" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329401" class="commentstatus"></div>
<div id="comment_53329401" class="cw">
</div>

<div id="replyto_53329401"></div>

<ul id="group_53329401">
	<li id="hiddens_53329401" class="hide"></li>
</ul>

<ul id="commtree_53329401"><li id="tree_53330031" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330031" class="commentstatus"></div>
<div id="comment_53330031" class="cw">
	<div id="comment_top_53330031" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330031" name="comment_link_53330031" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330031" onclick="return D2.setFocusComment(53330031)" >Re:</a>


		 	<span id="comment_score_53330031" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330031); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~grahamsz">grahamsz</a>  <span class="uid"><a href="//slashdot.org/~grahamsz">( 150076 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330031"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330031"><p>I think there are other exploits. Some of my cheap audio devices hit chinese IPs looking for firmware upgrades. If you could hack those IPs then you could deliver a malicious firmware while the network didn't see anything but a web request.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330031">

</div>
</div>

<div id="replyto_53330031"></div>

<ul id="group_53330031">
	<li id="hiddens_53330031" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53329201" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53329201" class="commentstatus"></div>
<div id="comment_53329201" class="cw">
</div>

<div id="replyto_53329201"></div>

<ul id="group_53329201">
	<li id="hiddens_53329201" class="hide"></li>
</ul>

<ul id="commtree_53329201"><li id="tree_53330083" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53330083" class="commentstatus"></div>
<div id="comment_53330083" class="cw">
	<div id="comment_top_53330083" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53330083" name="comment_link_53330083" href="//ask.slashdot.org/comments.pl?sid=9903511&amp;cid=53330083" onclick="return D2.setFocusComment(53330083)" >Re:</a>


		 	<span id="comment_score_53330083" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53330083); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jenningsthecat">jenningsthecat</a>  <span class="uid"><a href="//slashdot.org/~jenningsthecat">( 1525947 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53330083"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53330083"><p><div class="quote"><p>...There are very few IoT devices that couldn't provide near 100% of their functionality without ever having to talk outside your local network.</p><p>Develop some IoT devices that can do that and that can gracefully handle it when it loses all communication (e.g., your thermostat should still work)...</p></div><p>Great idea, but who's going to do it? The makers of such gear are much more interested in the big bucks they can make from data mining than they are in the chump change they make by selling you an IoT widget. The only reason big companies make IoT gear is data collection; the customers' needs are incidental to that endeavour, and the customers' connection to servers in the cloud is the whole point of the exercise.</p><p><div class="quote"><p><nobr> <wbr></nobr>...and prepare yourself to take the market by storm.  There are a lot of people out there looking for smart devices that don't work worse than their existing ones.</p></div><p>"There are a lot of <b>technically savvy</b> people out there looking for smart devices that don't wor<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53330083">

</div>
</div>

<div id="replyto_53330083"></div>

<ul id="group_53330083">
	<li id="hiddens_53330083" class="hide"></li>
</ul>

</li></ul></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//ask.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 0;
		D2.currents()['full']     = 18;
		D2.currents()['oneline']  = 82;
		// D2.currents_total(100);

		D2.abbrev_comments({53329249:515,53329271:176,53332779:512,53329195:524,53332027:624,53330729:522,53329137:535,53332143:515,53329593:529,53330781:529,53331087:522,53334691:632,53329881:514,53329475:521,53331327:515,53330983:522,53331317:522,53329583:521,53331721:776,53330083:1084,53329135:528,53329115:522,53330591:520,53332155:536});
		D2.noshow_comments([53331473,53329207,53331517,53329671,53329103,53329643,53329291,53329537,53329001,53329057,53329421,53328979,53329401,53329201]);
		D2.pieces_comments([53331087,53334691,53329673,53329699,53331099,53330983,53330169,53330217,53330517,53332027,53332045,53331553,53332779,53329475,53329729,53330123,53329039,53329255,53329535,53329445,53331327,53332143,53332177,53331721,53331795,53329249,53329739,53329275,53329473,53330721,53332155,53329707,53330579,53330741,53329971,53330591,53329045,53329105,53329137,53329195,53329881,53329997,53331415,53329639,53331119,53329115,53329135,53329271,53329143,53329965,53331317,53329321,53329583,53329593,53330019,53330845,53329603,53329747,53329397,53329463,53330423,53329481,53330411,53330593,53330669,53330849,53331259,53331293,53331349,53331359,53331961,53329093,53329159,53329333,53329509,53329575,53330351,53330729,53330781,53330953,53330031,53330083]);
		D2.init_hiddens([]);

		D2.finishLoading();



//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(319027);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1839<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/02/03/0126235/ask-slashdot-how-can-we-improve-slashdot?sdsrc=popbyskidbtmprev">Ask Slashdot: How Can We Improve Slashdot?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1144<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/06/13/0159223/ask-slashdot-can-technology-prevent-shootings?sdsrc=popbyskidbtmprev">Ask Slashdot:  Can Technology Prevent Shootings?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>637<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/06/06/0119217/ask-slashdot-how-do-you-create-a-highly-secure-password?sdsrc=popbyskidbtmprev">Ask Slashdot: How Do You Create A Highly-Secure Password?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>609<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/12/21/151229/slashdot-asks-why-are-browsers-so-slow?sdsrc=popbyskidbtmprev">Slashdot Asks: Why Are Browsers So Slow?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>587<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/11/07/0225204/ask-slashdot-why-are-american-tech-workers-paid-so-well?sdsrc=popbyskidbtmprev">Ask Slashdot: Why Are American Tech Workers Paid So Well?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//games.slashdot.org/story/16/11/21/007252/2016-winners-announced-for-interactive-fiction-competition?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/classicgames_64.png" width="64" height="64" alt="Classic Games (Games)"></span>
	    
					<p class="grid_12"><a href="//games.slashdot.org/story/16/11/21/007252/2016-winners-announced-for-interactive-fiction-competition?sdsrc=nextbtmprev">2016 Winners Announced For Interactive Fiction Competition</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>24<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//news.slashdot.org/story/16/11/20/2225225/one-third-of-californias-trees-are-dead?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/usa_64.png" width="64" height="64" alt="United States"></span>
	    
					<p class="grid_12"><a href="//news.slashdot.org/story/16/11/20/2225225/one-third-of-californias-trees-are-dead?sdsrc=prevbtmprev">One Third of California's Trees Are Dead</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>393<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="railad">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
					
						<button class="btn" disabled="disabled">Archived Discussion</button>
					
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">230</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>It's not so hard to lift yourself by your bootstraps once you're off the ground.
		-- Daniel B. Luten</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2016 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                $('#firehoselist article').eq(2).after(html);
            }
        });
        
        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?549">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?145">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->