<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '307665444597322494',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Slashdot Asks: How Do You Know a Developer is Doing a Good Job? - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="An anonymous reader writes: One of the easiest ways to evaluate a developer is keeping a tab on the amount of value they provide to a business. But the problem with this approach is that the nature of software development does not make it easy to measure the value a single developer brings. Some man...">
		<meta itemprop="name" content="Slashdot Asks: How Do You Know a Developer is Doing a Good Job? - Slashdot">
		<meta itemprop="description" content="An anonymous reader writes: One of the easiest ways to evaluate a developer is keeping a tab on the amount of value they provide to a business. But the problem with this approach is that the nature of software development does not make it easy to measure the value a single developer brings. Some man...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/programming_64.png">
	
	
		<link rel="canonical" href="https://ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/322333" >
	

		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?release_20170126.1" ><![endif]-->
		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?release_20170126.1" >
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?release_20170126.1" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?release_20170126.1">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: askslashdot programming developer programmer slashdotasks
  
  var backend_tpc = [[ "programming", "askslashdot", "developer", "programmer", "slashdotasks" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?release_20170126.1"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?release_20170126.1" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//ask.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotAskSlashdot" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //ask.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Slashdot is powered by <strong><a href="//ask.slashdot.org/submission">your submissions</a></strong>, so send in your scoop
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="adwrap adwrap-unviewed">
				
				<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
				<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 Trust the World's Fastest VPN with Your Internet Security & Freedom - <strong><a href="https://deals.slashdot.org/sales/lifetime-of-purevpn?utm_source=slashdot&utm_medium=announcementbar&utm_campaign=lifetime-of-purevpn" rel="nofollow">A Lifetime Subscription of PureVPN at 88% off</a></strong>. Also, <strong>Slashdot's <a href="https://facebook.com/slashdot/" rel="nofollow">Facebook page</a></strong> has a chat bot now. Message it for stories and more.
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-89126539" data-fhid="89126539" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">89126539</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-89126539">
			<a href="//ask.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-89126539" class="story-title"> <a   href="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job">Slashdot Asks: How Do You Know a Developer is Doing a Good Job?</a></span>

		
		
		<!--<span class="comments commentcnt-89126539" >72</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job#comments" title="">72</a></span>
		
	</h2>
	<div class="details" id="details-89126539">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  msmash
			
		
		

		
		
		<time id="fhtime-89126539" datetime="on Friday February 10, 2017 @09:00AM">on Friday February 10, 2017 @09:00AM</time>
		
		
			 from the <span class="dept-text">interesting-questions</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-89126539">
	
		
	

	
		
		<div id="text-89126539" class="p">
			
		 	
				An anonymous reader writes:<i> One of the easiest ways to evaluate a developer is keeping a tab on the amount of value they provide to a business. But the problem with this approach is that the nature of software development does not make it easy to measure the value a single developer brings. Some managers are aware of this, and they look at the number of lines of code a developer has written. The fewer, the better, many believe. I recently came across this in a blog post, "If you paid your developers per line of code, you would reward the inefficient developers.  An analogy to this is writing essays, novels, blog posts, etc. Would you judge a writer solely on the number of words written? Probably not. There are a minimum number of words needed to get a complex point across, but those points get lost when a writer clutters their work with useless sentences. So <a href="http://blog.professorbeekums.com/2017/01/how-do-you-know-developer-is-doing-good.html">the lines of code metric doesn't work</a>. The notion of a quantifiable metric for evaluating developers is still attractive though.  Some may argue that creating many code branches is the mark of a great developer. Yet I once worked with a developer who would create code branches to hide the fact that he wasn't very productive." Good point. But then, what other options do we have?</i>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-89126539" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job"
								  data-janrain-title="Slashdot Asks: How Do You Know a Developer is Doing a Good Job?"
								  data-janrain-message="Slashdot Asks: How Do You Know a Developer is Doing a Good Job? @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-89126539" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/askslashdot" target="_blank">askslashdot</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/programming" target="_blank">programming</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/developer" target="_blank">developer</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//tech.slashdot.org/story/17/02/10/0234215/tesla-employee-calls-for-unionization-musk-says-thats-morally-outrageous?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>You may like to read:</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//news.slashdot.org/story/17/02/10/1255245/most-of-the-web-really-sucks-if-you-have-a-slow-connection?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//tech.slashdot.org/story/17/02/10/0234215/tesla-employee-calls-for-unionization-musk-says-thats-morally-outrageous?sdsrc=prev">Tesla Employee Calls For Unionization, Musk Says That's 'Morally Outrageous' </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
									
									
									
									

																				<h2><a href="//ask.slashdot.org/story/16/06/13/0159223/ask-slashdot-can-technology-prevent-shootings?sdsrc=popbyskid">Ask Slashdot:  Can Technology Prevent Shootings?</a><br></h2>
																				<h2><a href="//ask.slashdot.org/story/16/12/21/151229/slashdot-asks-why-are-browsers-so-slow?sdsrc=popbyskid">Slashdot Asks: Why Are Browsers So Slow?</a><br></h2>
																				<h2><a href="//ask.slashdot.org/story/16/06/06/0119217/ask-slashdot-how-do-you-create-a-highly-secure-password?sdsrc=popbyskid">Ask Slashdot: How Do You Create A Highly-Secure Password?</a><br></h2>
																				<h2><a href="//ask.slashdot.org/story/16/11/07/0225204/ask-slashdot-why-are-american-tech-workers-paid-so-well?sdsrc=popbyskid">Ask Slashdot: Why Are American Tech Workers Paid So Well?</a><br></h2>
																				<h2><a href="//ask.slashdot.org/story/16/04/24/183245/slashdot-asks-have-you-experienced-ageism?sdsrc=popbyskid">Slashdot Asks: Have You Experienced Ageism?</a><br></h2>
									
								
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//news.slashdot.org/story/17/02/10/1255245/most-of-the-web-really-sucks-if-you-have-a-slow-connection?sdsrc=next">Most of the Web Really Sucks If You Have a Slow Connection</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job" title="Back to Article - Slashdot Asks: How Do You Know a Developer is Doing a Good Job?">Slashdot Asks: How Do You Know a Developer is Doing a Good Job?</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Slashdot Asks: How Do You Know a Developer is Doing a Good Job?" href="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job">Slashdot Asks: How Do You Know a Developer is Doing a Good Job?</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=10230439" class="btn">Search <span class="totalcommentcnt">74</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//ask.slashdot.org/comments.pl?sid=10230439">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=10230439" class="ui-icon search_comments">Search <span class="totalcommentcnt">74</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//ask.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/02/10/1244250/slashdot-asks-how-do-you-know-a-developer-is-doing-a-good-job/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?release_20170126.1" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_53838655" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838655" class="commentstatus"></div>
<div id="comment_53838655" class="cw">
	<div id="comment_top_53838655" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838655" name="comment_link_53838655" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838655" onclick="return D2.setFocusComment(53838655)" >Coffee</a>


		 	<span id="comment_score_53838655" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838655); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Big+Hairy+Ian">Big Hairy Ian</a>  <span class="uid"><a href="//slashdot.org/~Big+Hairy+Ian">( 1155547 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838655"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838655">When the coffee machine runs out<nobr> <wbr></nobr>:D</div>
	</div>

	<div class="commentSub" id="comment_sub_53838655">

</div>
</div>

<div id="replyto_53838655"></div>

<ul id="group_53838655">
	<li id="hiddens_53838655" class="hide"></li>
</ul>

<ul id="commtree_53838655"><li id="tree_53838789" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53838789" class="commentstatus"></div>
<div id="comment_53838789" class="cw">
	<div id="comment_top_53838789" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838789" name="comment_link_53838789" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838789" onclick="return D2.setFocusComment(53838789)" >Re:Coffee</a>


		 	<span id="comment_score_53838789" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838789); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xest">Xest</a>  <span class="uid"><a href="//slashdot.org/~Xest">( 935314 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838789">		
		on Friday February 10, 2017 @09:18AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838789">#53838789</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838789"><p>Jokes aside I'd argue there's actually a more fundamental question that stems from the question being asked.</p><p>Why aren't your senior/lead developers weeding this people out? That's their job, they'll spot bad developers by working with them based on a number of metrics from readability of code, number of bugs, performance, amount of useful code produced and so on, not just a single metric.</p><p>If your senior/lead developers aren't doing this then you've probably not paid enough, you've probably paid too little and ended up putting a low to mid level developer in what you've called a senior role.</p><p>If it's your senior/lead you're concerned about then you should just be able to go on track record - do they have a history of delivering high quality software in a reasonable timeframe? Are you confused about what a reasonable timeframe is? Look at other software on the market, how long does it take Microsoft to release a new version of Word? Adobe a new version of Acrobat? and so on. There is plenty of evidence out there as to how long it takes a succesful company to release a piece of software - find something with a similar scale to what you're doing and see how rapidly they release. If you're paying competitively against those companies, and your developer isn't delivering as rapidly then they're underperforming, if you're not paying as much as they are then don't expect them to be able to produce as much quality in as little time. If they're overperforming in quality and delivery speed and you're paying them less than the big boys then thank yourself that you've found a fucking star and spend a lot of time thanking them for giving you more for less money and do everything you can to make them happy and keep them, because if they leave, you might not be so lucky next time.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838789">
<span class="ind"></span><a id="reply_link_53838789" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838789" onclick="D2.replyTo(53838789); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53838655" onclick="return D2.selectParent(53838655)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Coffee by Xest @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838789" data-title="Re:Coffee">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Coffee by Xest" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838789" data-title="Re:Coffee">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Coffee by Xest" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838789" data-title="Re:Coffee">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10230439%26cid=53838789" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53838789" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838789" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53838789"></div>

<ul id="group_53838789">
	<li id="hiddens_53838789" class="hide"></li>
</ul>

<ul id="commtree_53838789"><li id="tree_53838905" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838905" class="commentstatus"></div>
<div id="comment_53838905" class="cw">
</div>

<div id="replyto_53838905"></div>

<ul id="group_53838905">
	<li id="hiddens_53838905" class="hide"></li>
</ul>

<ul id="commtree_53838905"><li id="tree_53839001" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839001" class="commentstatus"></div>
<div id="comment_53839001" class="cw">
	<div id="comment_top_53839001" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839001" name="comment_link_53839001" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839001" onclick="return D2.setFocusComment(53839001)" >Re:</a>


		 	<span id="comment_score_53839001" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839001); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xest">Xest</a>  <span class="uid"><a href="//slashdot.org/~Xest">( 935314 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839001"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839001"><p>No, stupid. Pay enough to get sufficiently competent people from the marketplace in the first place. People with a track record of leadership in software development sufficient to command good pay because they do a good job. Many companies fail at this, pay below competitive levels and just fill their senior jobs with junior/mid-level staff then wonder why their software development department isn't competitive.</p><p>Of course throwing money at someone who is incompetent wont magically make them competent, why wo<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839001">

</div>
</div>

<div id="replyto_53839001"></div>

<ul id="group_53839001">
	<li id="hiddens_53839001" class="hide"></li>
</ul>

<ul id="commtree_53839001"><li id="tree_53839099" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53839099" class="commentstatus"></div>
<div id="comment_53839099" class="cw">
</div>

<div id="replyto_53839099"></div>

<ul id="group_53839099">
	<li id="hiddens_53839099" class="hide"></li>
</ul>

<ul id="commtree_53839099"><li id="tree_53839175" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839175" class="commentstatus"></div>
<div id="comment_53839175" class="cw">
	<div id="comment_top_53839175" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839175" name="comment_link_53839175" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839175" onclick="return D2.setFocusComment(53839175)" >Re:</a>


		 	<span id="comment_score_53839175" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839175); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xest">Xest</a>  <span class="uid"><a href="//slashdot.org/~Xest">( 935314 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839175"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839175"><p>No, I think someone's skill is based on how succesful they are at doing the job as demonstrated by their track record. What they tell you is irrelevant, what they've done, and what can be backed up by research, references, and a competent interview process is really what matters.</p><p>"In bumfuck, USA, there is nothing but small developers, even the ones that charge 6 figures."</p><p>I've no doubt, but how is having an effective way to measure competence going to help that? If you don't have the local talent available y<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839175">

</div>
</div>

<div id="replyto_53839175"></div>

<ul id="group_53839175">
	<li id="hiddens_53839175" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53839123" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53839123" class="commentstatus"></div>
<div id="comment_53839123" class="cw">
</div>

<div id="replyto_53839123"></div>

<ul id="group_53839123">
	<li id="hiddens_53839123" class="hide"></li>
</ul>

</li><li id="hidestring_53839001"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53839001">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_53838997" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838997" class="commentstatus"></div>
<div id="comment_53838997" class="cw">
	<div id="comment_top_53838997" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838997" name="comment_link_53838997" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838997" onclick="return D2.setFocusComment(53838997)" >Re:</a>


		 	<span id="comment_score_53838997" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838997); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iamgnat">iamgnat</a>  <span class="uid"><a href="//slashdot.org/~iamgnat">( 1015755 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838997"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838997"><p><div class="quote"><p>There is plenty of evidence out there as to how long it takes a succesful company to release a piece of software - find something with a similar scale to what you're doing and see how rapidly they release.</p></div><p>Like all the other measures, it's not that simple. Is it code that the development team wrote themselves or did they inherit it? If they inherited it, how well was it originally designed, coded, and documented? Is the project using the best tools for the job or has it been forced to work around suboptimal tools for various reasons? Does the project have a solid design/direction or is the whole thing made up as it goes along? Are there defined use cases the developers can work against? Is there a clear custo<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838997">

</div>
</div>

<div id="replyto_53838997"></div>

<ul id="group_53838997">
	<li id="hiddens_53838997" class="hide"></li>
</ul>

<ul id="commtree_53838997"><li id="tree_53839127" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839127" class="commentstatus"></div>
<div id="comment_53839127" class="cw">
	<div id="comment_top_53839127" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839127" name="comment_link_53839127" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839127" onclick="return D2.setFocusComment(53839127)" >Re:</a>


		 	<span id="comment_score_53839127" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839127); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Xest">Xest</a>  <span class="uid"><a href="//slashdot.org/~Xest">( 935314 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839127"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839127"><p>That's precisely why you need to find a similar case, or ideally, many similar cases.</p><p>In terms of distractions, if you're in a lead development role then it's your responsibility to raise at the highest levels of management and evidence the fact that your team just isn't being given sufficient time to work on actually writing software and documenting interruptions as evidence isn't difficult. Similarly taking a poor specification up the chain and explaining why it's poor also isn't difficult - explaining whe<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839127">

</div>
</div>

<div id="replyto_53839127"></div>

<ul id="group_53839127">
	<li id="hiddens_53839127" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53839013" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839013" class="commentstatus"></div>
<div id="comment_53839013" class="cw">
	<div id="comment_top_53839013" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839013" name="comment_link_53839013" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839013" onclick="return D2.setFocusComment(53839013)" >Re:</a>


		 	<span id="comment_score_53839013" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839013); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839013"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839013"><p>From what I have seen in the industry, it is very simple: Either there are no senior developers that deserve the name, or they are not asked on anything that is "management".</p><p>I fully agree with you. The job to evaluate technological skills must always be done by a chief engineer (or equivalent). If you do not have a chief engineer, then you cannot evaluate the technological skills of people, and that is it. Other engineering disciplines do understand this. But "coders" are often not even viewed as engineers<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839013">

</div>
</div>

<div id="replyto_53839013"></div>

<ul id="group_53839013">
	<li id="hiddens_53839013" class="hide"></li>
</ul>

</li><li id="tree_53839059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839059" class="commentstatus"></div>
<div id="comment_53839059" class="cw">
	<div id="comment_top_53839059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839059" name="comment_link_53839059" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839059" onclick="return D2.setFocusComment(53839059)" >Re:</a>


		 	<span id="comment_score_53839059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839059); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mwvdlee">mwvdlee</a>  <span class="uid"><a href="//slashdot.org/~mwvdlee">( 775178 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839059"><p>"Senior" in most companies literally means whoever worked there longest.<br>It says nothing about abilities or quality.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839059">

</div>
</div>

<div id="replyto_53839059"></div>

<ul id="group_53839059">
	<li id="hiddens_53839059" class="hide"></li>
</ul>

</li><li id="hidestring_53838789"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838789">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838815" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838815" class="commentstatus"></div>
<div id="comment_53838815" class="cw">
	<div id="comment_top_53838815" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838815" name="comment_link_53838815" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838815" onclick="return D2.setFocusComment(53838815)" >Re:</a>


		 	<span id="comment_score_53838815" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838815); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Joce640k">Joce640k</a>  <span class="uid"><a href="//slashdot.org/~Joce640k">( 829181 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838815"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838815"><p><div class="quote"><p>When the coffee machine runs out<nobr> <wbr></nobr>:D</p></div><p>There's no 'metric' that can't be gamed. If I was being paid to drink coffee I'd be emptying it into secret buckets.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838815">

</div>
</div>

<div id="replyto_53838815"></div>

<ul id="group_53838815">
	<li id="hiddens_53838815" class="hide"></li>
</ul>

<ul id="commtree_53838815"><li id="tree_53838861" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838861" class="commentstatus"></div>
<div id="comment_53838861" class="cw">
	<div id="comment_top_53838861" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838861" name="comment_link_53838861" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838861" onclick="return D2.setFocusComment(53838861)" >Re:</a>


		 	<span id="comment_score_53838861" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838861); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838861"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838861">Like a toilet?  Drinking more fluids naturally makes you pee more, and on top of that, caffeine is a diuretic.</div>
	</div>

	<div class="commentSub" id="comment_sub_53838861">

</div>
</div>

<div id="replyto_53838861"></div>

<ul id="group_53838861">
	<li id="hiddens_53838861" class="hide"></li>
</ul>

</li><li id="tree_53839031" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839031" class="commentstatus"></div>
<div id="comment_53839031" class="cw">
	<div id="comment_top_53839031" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839031" name="comment_link_53839031" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839031" onclick="return D2.setFocusComment(53839031)" >Re:</a>


		 	<span id="comment_score_53839031" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839031); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839031"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839031"><p>Indeed. Trying to come up with metrics that people whose primary skill is analytic and secondary main skill is coming up with procedures cannot game is about the most stupid thing possible.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839031">

</div>
</div>

<div id="replyto_53839031"></div>

<ul id="group_53839031">
	<li id="hiddens_53839031" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53839025" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839025" class="commentstatus"></div>
<div id="comment_53839025" class="cw">
	<div id="comment_top_53839025" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839025" name="comment_link_53839025" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839025" onclick="return D2.setFocusComment(53839025)" >Re: Coffee</a>


		 	<span id="comment_score_53839025" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839025); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dougdonovan">dougdonovan</a>  <span class="uid"><a href="//slashdot.org/~dougdonovan">( 646766 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839025"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839025">is there not a *bucks in the area.  dont u guys make a min of $50hr.</div>
	</div>

	<div class="commentSub" id="comment_sub_53839025">

</div>
</div>

<div id="replyto_53839025"></div>

<ul id="group_53839025">
	<li id="hiddens_53839025" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53838673" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838673" class="commentstatus"></div>
<div id="comment_53838673" class="cw">
</div>

<div id="replyto_53838673"></div>

<ul id="group_53838673">
	<li id="hiddens_53838673" class="hide"></li>
</ul>

<ul id="commtree_53838673"><li id="tree_53838701" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838701" class="commentstatus"></div>
<div id="comment_53838701" class="cw">
	<div id="comment_top_53838701" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838701" name="comment_link_53838701" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838701" onclick="return D2.setFocusComment(53838701)" >Re:</a>


		 	<span id="comment_score_53838701" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838701); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Big+Hairy+Ian">Big Hairy Ian</a>  <span class="uid"><a href="//slashdot.org/~Big+Hairy+Ian">( 1155547 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838701"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838701">For desktop apps Clarion (From Softvelocity) has been doing that since the 1980's.  Fortunately their marketing Dept Sucks so hardly anyone is aware of it.</div>
	</div>

	<div class="commentSub" id="comment_sub_53838701">

</div>
</div>

<div id="replyto_53838701"></div>

<ul id="group_53838701">
	<li id="hiddens_53838701" class="hide"></li>
</ul>

<ul id="commtree_53838701"><li id="tree_53838839" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838839" class="commentstatus"></div>
<div id="comment_53838839" class="cw">
</div>

<div id="replyto_53838839"></div>

<ul id="group_53838839">
	<li id="hiddens_53838839" class="hide"></li>
</ul>

</li><li id="tree_53839113" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839113" class="commentstatus"></div>
<div id="comment_53839113" class="cw">
	<div id="comment_top_53839113" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839113" name="comment_link_53839113" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839113" onclick="return D2.setFocusComment(53839113)" >Re:</a>


		 	<span id="comment_score_53839113" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839113); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mwvdlee">mwvdlee</a>  <span class="uid"><a href="//slashdot.org/~mwvdlee">( 775178 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839113"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839113"><p>Ah yes, 4GL... where you eliminate the easiest part of what a developer does (write code), make the most difficult part (specifying what it should do) harder and make it the responsibility of people who can't even grasp the easy part.<br>And as soon as you want to do something the 4GL language isn't designed for, your only option is porting it to a 3GL (or lower-level) language.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839113">

</div>
</div>

<div id="replyto_53839113"></div>

<ul id="group_53839113">
	<li id="hiddens_53839113" class="hide"></li>
</ul>

</li><li id="hidestring_53838701"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838701">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53839049" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839049" class="commentstatus"></div>
<div id="comment_53839049" class="cw">
	<div id="comment_top_53839049" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839049" name="comment_link_53839049" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839049" onclick="return D2.setFocusComment(53839049)" >Re:</a>


		 	<span id="comment_score_53839049" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839049); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839049"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839049"><p>Hahahahahaha, good one. I heard this first for the 5GL language project. That one started about 30 years ago and failed miserably more than 20 years ago. This time will not be any different.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839049">

</div>
</div>

<div id="replyto_53839049"></div>

<ul id="group_53839049">
	<li id="hiddens_53839049" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53838679" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53838679" class="commentstatus"></div>
<div id="comment_53838679" class="cw">
	<div id="comment_top_53838679" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838679" name="comment_link_53838679" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838679" onclick="return D2.setFocusComment(53838679)" >In my experience</a>


		 	<span id="comment_score_53838679" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838679); return false"><span class=opt>Score:</span>3</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~the_Bionic_lemming">the_Bionic_lemming</a>  <span class="uid"><a href="//slashdot.org/~the_Bionic_lemming">( 446569 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838679">		
		on Friday February 10, 2017 @09:04AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838679">#53838679</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838679"><p>Judge them on bugs. If they are constantly trying to fix their code then you have a metric on when to seek a better one.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838679">
<span class="ind"></span><a id="reply_link_53838679" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838679" onclick="D2.replyTo(53838679); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="In my experience by the_Bionic_lemming @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838679" data-title="In my experience">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="In my experience by the_Bionic_lemming" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838679" data-title="In my experience">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="In my experience by the_Bionic_lemming" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838679" data-title="In my experience">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10230439%26cid=53838679" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53838679" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838679" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53838679"></div>

<ul id="group_53838679">
	<li id="hiddens_53838679" class="hide"></li>
</ul>

<ul id="commtree_53838679"><li id="tree_53838721" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838721" class="commentstatus"></div>
<div id="comment_53838721" class="cw">
	<div id="comment_top_53838721" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838721" name="comment_link_53838721" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838721" onclick="return D2.setFocusComment(53838721)" >Re:</a>


		 	<span id="comment_score_53838721" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838721); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838721"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838721"><p>This. You can also see who is fixing bugs in other people's code. Give them a raise.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838721">

</div>
</div>

<div id="replyto_53838721"></div>

<ul id="group_53838721">
	<li id="hiddens_53838721" class="hide"></li>
</ul>

<ul id="commtree_53838721"><li id="tree_53838921" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838921" class="commentstatus"></div>
<div id="comment_53838921" class="cw">
</div>

<div id="replyto_53838921"></div>

<ul id="group_53838921">
	<li id="hiddens_53838921" class="hide"></li>
</ul>

</li><li id="tree_53838967" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838967" class="commentstatus"></div>
<div id="comment_53838967" class="cw">
	<div id="comment_top_53838967" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838967" name="comment_link_53838967" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838967" onclick="return D2.setFocusComment(53838967)" >Re:</a>


		 	<span id="comment_score_53838967" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838967); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838967"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838967"><p>Juniors write code, seniors fix bugs.</p><p>That's my approach to that problem at least. And so far I've been doing great with it.</p><p>90% of code is trivial bullshit. Anyone can do it, hell, even cargo-cult programming cannot fuck it up. Sitting a senior programmer down to do that is a waste of resources.</p><p>10% of code is insanely difficult to figure out, arcane mystical bullshit. Hard to write, hard to maintain, hard to understand and even harder to get right.</p><p>You could now either spend time and resources trying to ident<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838967">

</div>
</div>

<div id="replyto_53838967"></div>

<ul id="group_53838967">
	<li id="hiddens_53838967" class="hide"></li>
</ul>

</li><li id="hidestring_53838721"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838721">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838849" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838849" class="commentstatus"></div>
<div id="comment_53838849" class="cw">
	<div id="comment_top_53838849" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838849" name="comment_link_53838849" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838849" onclick="return D2.setFocusComment(53838849)" >Re:</a>


		 	<span id="comment_score_53838849" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838849); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Wootery">Wootery</a>  <span class="uid"><a href="//slashdot.org/~Wootery">( 1087023 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838849"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838849"><p>But <a href="https://ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838815" title="slashdot.org">like someone already pointed out</a> [slashdot.org], this metric is trivially gamed.</p><p>If I spent twice as long on each feature, I'd be able to reduce my bug-count, but I would probably be unduly costing my employer in the process.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838849">

</div>
</div>

<div id="replyto_53838849"></div>

<ul id="group_53838849">
	<li id="hiddens_53838849" class="hide"></li>
</ul>

<ul id="commtree_53838849"><li id="tree_53838885" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838885" class="commentstatus"></div>
<div id="comment_53838885" class="cw">
	<div id="comment_top_53838885" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838885" name="comment_link_53838885" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838885" onclick="return D2.setFocusComment(53838885)" >Re:</a>


		 	<span id="comment_score_53838885" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838885); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~the_Bionic_lemming">the_Bionic_lemming</a>  <span class="uid"><a href="//slashdot.org/~the_Bionic_lemming">( 446569 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838885"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838885"><p>That's assuming that you are the only coder. If 15 programmers are relatively bug free, and you are outputting half of what the other 14 are doing, Well, that's another metric you can use.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838885">

</div>
</div>

<div id="replyto_53838885"></div>

<ul id="group_53838885">
	<li id="hiddens_53838885" class="hide"></li>
</ul>

<ul id="commtree_53838885"><li id="tree_53839133" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839133" class="commentstatus"></div>
<div id="comment_53839133" class="cw">
	<div id="comment_top_53839133" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839133" name="comment_link_53839133" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839133" onclick="return D2.setFocusComment(53839133)" >Re:</a>


		 	<span id="comment_score_53839133" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839133); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~alvinrod">alvinrod</a>  <span class="uid"><a href="//slashdot.org/~alvinrod">( 889928 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839133"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839133">Still not a good metric, unless you assume all work is being divided evenly and is equally difficult or trivial. This is rarely true and good companies often identify who their most skilled employees are and assign them the difficult work that only they may be able to handle effectively. If you produce a small amount of code that only you could have produced because it was incredibly difficult, why should it matter if some other yahoo churned out three times as many features if they're all trivial by compar</div>
	</div>

	<div class="commentSub" id="comment_sub_53839133">

</div>
</div>

<div id="replyto_53839133"></div>

<ul id="group_53839133">
	<li id="hiddens_53839133" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53838901" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838901" class="commentstatus"></div>
<div id="comment_53838901" class="cw">
</div>

<div id="replyto_53838901"></div>

<ul id="group_53838901">
	<li id="hiddens_53838901" class="hide"></li>
</ul>

</li><li id="tree_53839043" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53839043" class="commentstatus"></div>
<div id="comment_53839043" class="cw">
</div>

<div id="replyto_53839043"></div>

<ul id="group_53839043">
	<li id="hiddens_53839043" class="hide"></li>
</ul>

</li><li id="tree_53839055" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839055" class="commentstatus"></div>
<div id="comment_53839055" class="cw">
	<div id="comment_top_53839055" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839055" name="comment_link_53839055" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839055" onclick="return D2.setFocusComment(53839055)" >Re:</a>


		 	<span id="comment_score_53839055" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839055); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iamgnat">iamgnat</a>  <span class="uid"><a href="//slashdot.org/~iamgnat">( 1015755 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839055"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839055"><p><div class="quote"><p>Judge them on bugs. If they are constantly trying to fix their code then you have a metric on when to seek a better one.</p></div><p>Are they their bugs or someone else's? Are they due to inherited code that was poorly designed and even more poorly documented? Are they because something was forced into a design/architecture that couldn't support it? Are they due to bad tools/frameworks being used (through no fault of the developer in question)? What's a bug versus an unclear/unknown requirement?</p><p>As far as seeking a better one, just how in the process of interviewing someone (even in one of those drawn out all day BS games that are favored<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839055">

</div>
</div>

<div id="replyto_53839055"></div>

<ul id="group_53839055">
	<li id="hiddens_53839055" class="hide"></li>
</ul>

</li><li id="hidestring_53838679"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838679">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838683" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838683" class="commentstatus"></div>
<div id="comment_53838683" class="cw">
</div>

<div id="replyto_53838683"></div>

<ul id="group_53838683">
	<li id="hiddens_53838683" class="hide"></li>
</ul>

</li><li id="tree_53838687" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838687" class="commentstatus"></div>
<div id="comment_53838687" class="cw">
	<div id="comment_top_53838687" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838687" name="comment_link_53838687" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838687" onclick="return D2.setFocusComment(53838687)" >Hint: It ain't the guy called in all the time</a>


		 	<span id="comment_score_53838687" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838687); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838687"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838687"><p>Here's a clue:</p><p>It's <b>NOT</b> the guy who always gets called in at 3 AM to fix something that <b>HE</b> wrote.</p><p>He's <b>NOT</b> your "hero".  He'e the moron you need to fire.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838687">

</div>
</div>

<div id="replyto_53838687"></div>

<ul id="group_53838687">
	<li id="hiddens_53838687" class="hide"></li>
</ul>

<ul id="commtree_53838687"><li id="tree_53838897" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53838897" class="commentstatus"></div>
<div id="comment_53838897" class="cw">
	<div id="comment_top_53838897" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838897" name="comment_link_53838897" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838897" onclick="return D2.setFocusComment(53838897)" >Re:Hint: It ain't the guy called in all the time</a>


		 	<span id="comment_score_53838897" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838897); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838897">		
		on Friday February 10, 2017 @09:33AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838897">#53838897</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838897"><p>Don't confuse him with the guy that you call at 3am who staggers in drunk and baked, sits down at the terminal and just before passing out and throwing up on the carpet at 3:15am returns your system to a running state despite the problem being in an area he has never worked in nor has any connection to.</p><p>That guy you should keep.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838897">
<span class="ind"></span><a id="reply_link_53838897" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838897" onclick="D2.replyTo(53838897); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=53838687" onclick="return D2.selectParent(53838687)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Hint: It ain't the guy called in all the time by Opportunist @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838897" data-title="Re:Hint: It ain't the guy called in all the time">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Hint: It ain't the guy called in all the time by Opportunist" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838897" data-title="Re:Hint: It ain't the guy called in all the time">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Hint: It ain't the guy called in all the time by Opportunist" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838897" data-title="Re:Hint: It ain't the guy called in all the time">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10230439%26cid=53838897" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53838897" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838897" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53838897"></div>

<ul id="group_53838897">
	<li id="hiddens_53838897" class="hide"></li>
</ul>

<ul id="commtree_53838897"><li id="tree_53839135" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839135" class="commentstatus"></div>
<div id="comment_53839135" class="cw">
	<div id="comment_top_53839135" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839135" name="comment_link_53839135" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839135" onclick="return D2.setFocusComment(53839135)" >Re:</a>


		 	<span id="comment_score_53839135" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839135); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~stooo">stooo</a>  <span class="uid"><a href="//slashdot.org/~stooo">( 2202012 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839135"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839135"><p><a href="http://www.commitstrip.com/en/2017/01/02/unreal-skills/?setLocale=1" title="commitstrip.com">http://www.commitstrip.com/en/...</a> [commitstrip.com]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839135">

</div>
</div>

<div id="replyto_53839135"></div>

<ul id="group_53839135">
	<li id="hiddens_53839135" class="hide"></li>
</ul>

</li><li id="tree_53839141" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839141" class="commentstatus"></div>
<div id="comment_53839141" class="cw">
	<div id="comment_top_53839141" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839141" name="comment_link_53839141" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839141" onclick="return D2.setFocusComment(53839141)" >Re:</a>


		 	<span id="comment_score_53839141" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839141); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mwvdlee">mwvdlee</a>  <span class="uid"><a href="//slashdot.org/~mwvdlee">( 775178 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839141"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839141"><p>So basically I should work on as little code as possible, since fixing bugs in any code I ever touched makes me a bad coder?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839141">

</div>
</div>

<div id="replyto_53839141"></div>

<ul id="group_53839141">
	<li id="hiddens_53839141" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53838691" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838691" class="commentstatus"></div>
<div id="comment_53838691" class="cw">
</div>

<div id="replyto_53838691"></div>

<ul id="group_53838691">
	<li id="hiddens_53838691" class="hide"></li>
</ul>

</li><li id="tree_53838703" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838703" class="commentstatus"></div>
<div id="comment_53838703" class="cw">
</div>

<div id="replyto_53838703"></div>

<ul id="group_53838703">
	<li id="hiddens_53838703" class="hide"></li>
</ul>

</li><li id="tree_53838719" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838719" class="commentstatus"></div>
<div id="comment_53838719" class="cw">
	<div id="comment_top_53838719" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838719" name="comment_link_53838719" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838719" onclick="return D2.setFocusComment(53838719)" >Deadlines</a>


		 	<span id="comment_score_53838719" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838719); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Quakeulf">Quakeulf</a>  <span class="uid"><a href="//slashdot.org/~Quakeulf">( 2650167 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838719"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838719">When he can keep deadlines within reason and deliver something that runs pretty well based on the specifications. Anything else is fluff.</div>
	</div>

	<div class="commentSub" id="comment_sub_53838719">

</div>
</div>

<div id="replyto_53838719"></div>

<ul id="group_53838719">
	<li id="hiddens_53838719" class="hide"></li>
</ul>

<ul id="commtree_53838719"><li id="tree_53838863" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838863" class="commentstatus"></div>
<div id="comment_53838863" class="cw">
</div>

<div id="replyto_53838863"></div>

<ul id="group_53838863">
	<li id="hiddens_53838863" class="hide"></li>
</ul>

</li><li id="tree_53838891" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838891" class="commentstatus"></div>
<div id="comment_53838891" class="cw">
</div>

<div id="replyto_53838891"></div>

<ul id="group_53838891">
	<li id="hiddens_53838891" class="hide"></li>
</ul>

</li><li id="tree_53839137" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53839137" class="commentstatus"></div>
<div id="comment_53839137" class="cw">
</div>

<div id="replyto_53839137"></div>

<ul id="group_53839137">
	<li id="hiddens_53839137" class="hide"></li>
</ul>

</li><li id="hidestring_53838719"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838719">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838723" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838723" class="commentstatus"></div>
<div id="comment_53838723" class="cw">
	<div id="comment_top_53838723" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838723" name="comment_link_53838723" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838723" onclick="return D2.setFocusComment(53838723)" >TPS reports!</a>


		 	<span id="comment_score_53838723" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838723); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Joe_Dragon">Joe_Dragon</a>  <span class="uid"><a href="//slashdot.org/~Joe_Dragon">( 2206452 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838723"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838723"><p>We have this on guy who we wanted to dump as he just did not file them the right way But he just got pushed up to management. And they one of older guys who got layed off burned the office down.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838723">

</div>
</div>

<div id="replyto_53838723"></div>

<ul id="group_53838723">
	<li id="hiddens_53838723" class="hide"></li>
</ul>

</li><li id="tree_53838741" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838741" class="commentstatus"></div>
<div id="comment_53838741" class="cw">
	<div id="comment_top_53838741" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838741" name="comment_link_53838741" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838741" onclick="return D2.setFocusComment(53838741)" >easy....</a>


		 	<span id="comment_score_53838741" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838741); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lumpy">Lumpy</a>  <span class="uid"><a href="//slashdot.org/~Lumpy">( 12016 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838741"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838741"><p>When he hasn't murdered the management asking if he is doing a good job....</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838741">

</div>
</div>

<div id="replyto_53838741"></div>

<ul id="group_53838741">
	<li id="hiddens_53838741" class="hide"></li>
</ul>

<ul id="commtree_53838741"><li id="tree_53838873" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838873" class="commentstatus"></div>
<div id="comment_53838873" class="cw">
	<div id="comment_top_53838873" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838873" name="comment_link_53838873" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838873" onclick="return D2.setFocusComment(53838873)" >Re:</a>


		 	<span id="comment_score_53838873" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838873); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838873"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838873"><p>...he's not, because he has shown he cannot identify things that lower his productivity.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838873">

</div>
</div>

<div id="replyto_53838873"></div>

<ul id="group_53838873">
	<li id="hiddens_53838873" class="hide"></li>
</ul>

<ul id="commtree_53838873"><li id="tree_53839157" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839157" class="commentstatus"></div>
<div id="comment_53839157" class="cw">
	<div id="comment_top_53839157" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839157" name="comment_link_53839157" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839157" onclick="return D2.setFocusComment(53839157)" >Re:</a>


		 	<span id="comment_score_53839157" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839157); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mwvdlee">mwvdlee</a>  <span class="uid"><a href="//slashdot.org/~mwvdlee">( 775178 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839157"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839157"><p>But he has. He even prevented the issue from causing future loss of productivity.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839157">

</div>
</div>

<div id="replyto_53839157"></div>

<ul id="group_53839157">
	<li id="hiddens_53839157" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_53838743" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838743" class="commentstatus"></div>
<div id="comment_53838743" class="cw">
	<div id="comment_top_53838743" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838743" name="comment_link_53838743" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838743" onclick="return D2.setFocusComment(53838743)" >depends on how you set goals.</a>


		 	<span id="comment_score_53838743" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838743); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nimbius">nimbius</a>  <span class="uid"><a href="//slashdot.org/~nimbius">( 983462 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838743"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838743">There are a few ways.  SCRUM/Kanban is an effective way to inundate your programmers with meetings and conference calls asking and tracking minute status updates for every commit or stash you can find.  its perfect to ensure that changes to the codebase are governed by your personal fears and demons, not the best interests of users, because you too have to be fully invested in standing up in a conference room every morning and listening to a dozen or more different and often pedantic events transpiring in t</div>
	</div>

	<div class="commentSub" id="comment_sub_53838743">

</div>
</div>

<div id="replyto_53838743"></div>

<ul id="group_53838743">
	<li id="hiddens_53838743" class="hide"></li>
</ul>

</li><li id="tree_53838745" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838745" class="commentstatus"></div>
<div id="comment_53838745" class="cw">
	<div id="comment_top_53838745" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838745" name="comment_link_53838745" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838745" onclick="return D2.setFocusComment(53838745)" >Evaluate the code</a>


		 	<span id="comment_score_53838745" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838745); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838745"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838745"><p>Look at what the developers write, evaluate their work. An experienced developer is capable of evaluating other developers. A manager without programming experience may have a hard time though.</p><p>There is the quality of the code written. Beginner code or better stuff? Clever stuff? Handles corner cases well or not? Passes reviews/testing better than others? Good documentation or just some mandatory template documentation?</p><p>How did they handle the unexpected, such as a key library not working as advertised?  Fixe<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838745">

</div>
</div>

<div id="replyto_53838745"></div>

<ul id="group_53838745">
	<li id="hiddens_53838745" class="hide"></li>
</ul>

</li><li id="tree_53838763" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838763" class="commentstatus"></div>
<div id="comment_53838763" class="cw">
</div>

<div id="replyto_53838763"></div>

<ul id="group_53838763">
	<li id="hiddens_53838763" class="hide"></li>
</ul>

</li><li id="tree_53838775" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53838775" class="commentstatus"></div>
<div id="comment_53838775" class="cw">
	<div id="comment_top_53838775" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838775" name="comment_link_53838775" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838775" onclick="return D2.setFocusComment(53838775)" >Simple</a>


		 	<span id="comment_score_53838775" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838775); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bickerdyke">bickerdyke</a>  <span class="uid"><a href="//slashdot.org/~bickerdyke">( 670000 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838775">		
		on Friday February 10, 2017 @09:16AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838775">#53838775</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838775"><p>The ones doing a good job are NOT wasting their time on slashdot.</p><p>And now back to work!</p><p>P.S. I'm probably closer to the weekend than most of you<nobr> <wbr></nobr>:-)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838775">
<span class="ind"></span><a id="reply_link_53838775" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838775" onclick="D2.replyTo(53838775); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Simple by bickerdyke @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838775" data-title="Simple">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Simple by bickerdyke" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838775" data-title="Simple">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Simple by bickerdyke" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838775" data-title="Simple">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10230439%26cid=53838775" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53838775" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838775" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53838775"></div>

<ul id="group_53838775">
	<li id="hiddens_53838775" class="hide"></li>
</ul>

<ul id="commtree_53838775"><li id="tree_53838889" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838889" class="commentstatus"></div>
<div id="comment_53838889" class="cw">
</div>

<div id="replyto_53838889"></div>

<ul id="group_53838889">
	<li id="hiddens_53838889" class="hide"></li>
</ul>

</li><li id="hidestring_53838775"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838775">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838793" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838793" class="commentstatus"></div>
<div id="comment_53838793" class="cw">
	<div id="comment_top_53838793" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838793" name="comment_link_53838793" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838793" onclick="return D2.setFocusComment(53838793)" >Wait, what?</a>


		 	<span id="comment_score_53838793" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838793); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bigdavex">bigdavex</a>  <span class="uid"><a href="//slashdot.org/~bigdavex">( 155746 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838793"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838793"><blockquote><div><p>One of the easiest ways to evaluate a developer is keeping a tab on the amount of value they provide to a business.</p></div></blockquote><p>That's easy?  OK, problem solved.</p><blockquote><div><p> But the problem with this approach is that the nature of software development does not make it easy to measure the value a single developer brings</p></div></blockquote><p>Wait, it's not easy?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838793">

</div>
</div>

<div id="replyto_53838793"></div>

<ul id="group_53838793">
	<li id="hiddens_53838793" class="hide"></li>
</ul>

</li><li id="tree_53838797" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838797" class="commentstatus"></div>
<div id="comment_53838797" class="cw">
</div>

<div id="replyto_53838797"></div>

<ul id="group_53838797">
	<li id="hiddens_53838797" class="hide"></li>
</ul>

</li><li id="tree_53838801" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838801" class="commentstatus"></div>
<div id="comment_53838801" class="cw">
</div>

<div id="replyto_53838801"></div>

<ul id="group_53838801">
	<li id="hiddens_53838801" class="hide"></li>
</ul>

</li><li id="tree_53838837" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838837" class="commentstatus"></div>
<div id="comment_53838837" class="cw">
	<div id="comment_top_53838837" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838837" name="comment_link_53838837" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838837" onclick="return D2.setFocusComment(53838837)" >Not Possible to Grade on Metrics</a>


		 	<span id="comment_score_53838837" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838837); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838837"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838837"><p>I don't think it is possible to grade on any metric.</p><p>Project I am managing now there was a "superstar" programmer - or so it was thought.  The project would not have been successful without his work for sure but<nobr> <wbr></nobr>...   Every line of code he wrote is terrible.  It serves the purpose intended but its unreadable and cannot be extended at all.  I have yet to find anything he wrote that could be extended to a useful degree and I am not alone.  If he had not been a programmer at the time the project would have fail<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838837">

</div>
</div>

<div id="replyto_53838837"></div>

<ul id="group_53838837">
	<li id="hiddens_53838837" class="hide"></li>
</ul>

<ul id="commtree_53838837"><li id="tree_53839201" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839201" class="commentstatus"></div>
<div id="comment_53839201" class="cw">
	<div id="comment_top_53839201" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839201" name="comment_link_53839201" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839201" onclick="return D2.setFocusComment(53839201)" >Re:</a>


		 	<span id="comment_score_53839201" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839201); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iamgnat">iamgnat</a>  <span class="uid"><a href="//slashdot.org/~iamgnat">( 1015755 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839201"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839201"><p><div class="quote"><p>Project I am managing now there was a "superstar" programmer - or so it was thought.  The project would not have been successful without his work for sure but<nobr> <wbr></nobr>...   Every line of code he wrote is terrible.  It serves the purpose intended but its unreadable and cannot be extended at all.  I have yet to find anything he wrote that could be extended to a useful degree and I am not alone.  If he had not been a programmer at the time the project would have failed completely yet his work has a super high ongoing cost.  Should he be rewarded for pulling a miracle at the time or castigated as a failure now?</p></div><p>Are you working on the same code as I am? Sure sounds like it...</p><p>The problem with all these metrics is that there are tons of inherited code bases like the one described and now the poor shmucks that have to pick up the pieces are to be held accountable to these metrics when much of it is out of their control (because how often does management bite the bullet and allow for a complete rewrite?). If the code does not allow for extension and the new developer is tasked with extending it, it's going to be slow a<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839201">

</div>
</div>

<div id="replyto_53839201"></div>

<ul id="group_53839201">
	<li id="hiddens_53839201" class="hide"></li>
</ul>

</li></ul></li><li id="tree_53838841" class="comment full contain"><span class="ind"></span>
<div id="comment_status_53838841" class="commentstatus"></div>
<div id="comment_53838841" class="cw">
	<div id="comment_top_53838841" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838841" name="comment_link_53838841" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838841" onclick="return D2.setFocusComment(53838841)" >Management Is Hard</a>


		 	<span id="comment_score_53838841" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838841); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lazarus">lazarus</a>  <span class="uid"><a href="//slashdot.org/~lazarus">( 2879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838841">		
		on Friday February 10, 2017 @09:24AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838841">#53838841</a>)
		<small><a href="//slashdot.org/~lazarus/journal/" title="Thursday April 15, 2010 @11:19AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838841"><p>So this comes down to actually being a good manager.  It's hard, and lots of people do it wrong / pretend they are good but aren't / etc.  Ask yourself what you really want in a developer and then manage your team to that standard understanding that each member has their own strengths and weaknesses.  Something like:</p><p>- Elegant and easily understood code<br>- Good at estimating and meeting deadlines<br>- Productive and participative in scrums<br>- Thoughtful and supportive of alternative views<br>- Etc.</p><p>Coders are people.  They are a unique breed of people, sure, but if you want to gauge their worth, then you manage and treat them like people.  Not monkeys at a typewriter.  A small group of talented and creative coders can save a company millions in just a day of work.  I've seen it.  You need to appreciate their value by paying attention, not coming up with some arbitrary metric that makes your job easier.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838841">
<span class="ind"></span><a id="reply_link_53838841" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838841" onclick="D2.replyTo(53838841); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Management Is Hard by lazarus @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838841" data-title="Management Is Hard">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Management Is Hard by lazarus" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838841" data-title="Management Is Hard">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Management Is Hard by lazarus" data-url="https://ask.slashdot.org/comments.pl?sid=10230439&cid=53838841" data-title="Management Is Hard">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10230439%26cid=53838841" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_53838841" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=53838841" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_53838841"></div>

<ul id="group_53838841">
	<li id="hiddens_53838841" class="hide"></li>
</ul>

</li><li id="tree_53838845" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838845" class="commentstatus"></div>
<div id="comment_53838845" class="cw">
</div>

<div id="replyto_53838845"></div>

<ul id="group_53838845">
	<li id="hiddens_53838845" class="hide"></li>
</ul>

</li><li id="tree_53838853" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838853" class="commentstatus"></div>
<div id="comment_53838853" class="cw">
	<div id="comment_top_53838853" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838853" name="comment_link_53838853" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838853" onclick="return D2.setFocusComment(53838853)" >The Snazziest Dressed</a>


		 	<span id="comment_score_53838853" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838853); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838853"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838853"><p>If he's rockin Ivanka's clothing line and buying her stuff like a good citizen, he's clearly a good developer.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838853">

</div>
</div>

<div id="replyto_53838853"></div>

<ul id="group_53838853">
	<li id="hiddens_53838853" class="hide"></li>
</ul>

</li><li id="tree_53838859" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838859" class="commentstatus"></div>
<div id="comment_53838859" class="cw">
	<div id="comment_top_53838859" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838859" name="comment_link_53838859" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838859" onclick="return D2.setFocusComment(53838859)" >Bill Gates said</a>


		 	<span id="comment_score_53838859" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838859); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bigdavex">bigdavex</a>  <span class="uid"><a href="//slashdot.org/~bigdavex">( 155746 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838859"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838859"><blockquote><div><p>Measuring programming progress by lines of code is like measuring aircraft building progress by weight.</p></div></blockquote><p>- Bill Gates</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838859">

</div>
</div>

<div id="replyto_53838859"></div>

<ul id="group_53838859">
	<li id="hiddens_53838859" class="hide"></li>
</ul>

</li><li id="tree_53838869" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838869" class="commentstatus"></div>
<div id="comment_53838869" class="cw">
	<div id="comment_top_53838869" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838869" name="comment_link_53838869" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838869" onclick="return D2.setFocusComment(53838869)" >The moanager has to understand what developers do</a>


		 	<span id="comment_score_53838869" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838869); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838869"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838869"><p>In other words: You have to be one to know one. A developer knows who is a good, productive developer and who isn't. Be a developer, at least in part.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838869">

</div>
</div>

<div id="replyto_53838869"></div>

<ul id="group_53838869">
	<li id="hiddens_53838869" class="hide"></li>
</ul>

</li><li id="tree_53838879" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838879" class="commentstatus"></div>
<div id="comment_53838879" class="cw">
	<div id="comment_top_53838879" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838879" name="comment_link_53838879" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838879" onclick="return D2.setFocusComment(53838879)" >Some methods I use</a>


		 	<span id="comment_score_53838879" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838879); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CastrTroy">CastrTroy</a>  <span class="uid"><a href="//slashdot.org/~CastrTroy">( 595695 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838879"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838879"><p>Here are some methods I use to determine if they are doing a good job.</p><p>1. Defect rate - If they are constantly fixing bugs or you are required to have other developers go over their code and are constant finding basic problems, the developer isn't doing a good job.</p><p>2. Taking more time than expected/estimated to do a job. Obviously there's cases where requirements change or unknown issues pop up in the project. But if it's a constant issue, then there is either a problem with management/planning, or the develo<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838879">

</div>
</div>

<div id="replyto_53838879"></div>

<ul id="group_53838879">
	<li id="hiddens_53838879" class="hide"></li>
</ul>

<ul id="commtree_53838879"><li id="tree_53839085" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53839085" class="commentstatus"></div>
<div id="comment_53839085" class="cw">
</div>

<div id="replyto_53839085"></div>

<ul id="group_53839085">
	<li id="hiddens_53839085" class="hide"></li>
</ul>

</li><li id="hidestring_53838879"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838879">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838883" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838883" class="commentstatus"></div>
<div id="comment_53838883" class="cw">
	<div id="comment_top_53838883" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838883" name="comment_link_53838883" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838883" onclick="return D2.setFocusComment(53838883)" >You talk to each other. And *BOTH* listen.</a>


		 	<span id="comment_score_53838883" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838883); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Qbertino">Qbertino</a>  <span class="uid"><a href="//slashdot.org/~Qbertino">( 265505 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838883"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838883"><p>It's called social interaction.</p><p>A good programmer will be able to explain what he's doing. A good programmer will also be able to tell you that sending out that offer and requirements analysis before showing it to him or somebody else who will do the programming is a very very bad idea. And that you really should have him on board when planning the project. But you do have to listen.</p><p>If there is no social interaction (which may be formalised with Scrum or something), then you will never know what he is doing.<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838883">

</div>
</div>

<div id="replyto_53838883"></div>

<ul id="group_53838883">
	<li id="hiddens_53838883" class="hide"></li>
</ul>

<ul id="commtree_53838883"><li id="tree_53838941" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838941" class="commentstatus"></div>
<div id="comment_53838941" class="cw">
	<div id="comment_top_53838941" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838941" name="comment_link_53838941" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838941" onclick="return D2.setFocusComment(53838941)" >Re:</a>


		 	<span id="comment_score_53838941" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838941); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838941"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838941">yeah, its frightening how little people value interaction. It also exposes appallingly common delusional thinking, those who think their time is so valuable they can't meet for 15 to 30 minutes per day? It's preposterous.</div>
	</div>

	<div class="commentSub" id="comment_sub_53838941">

</div>
</div>

<div id="replyto_53838941"></div>

<ul id="group_53838941">
	<li id="hiddens_53838941" class="hide"></li>
</ul>

</li><li id="tree_53839189" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53839189" class="commentstatus"></div>
<div id="comment_53839189" class="cw">
</div>

<div id="replyto_53839189"></div>

<ul id="group_53839189">
	<li id="hiddens_53839189" class="hide"></li>
</ul>

</li><li id="hidestring_53838883"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=53838883">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_53838917" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838917" class="commentstatus"></div>
<div id="comment_53838917" class="cw">
	<div id="comment_top_53838917" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838917" name="comment_link_53838917" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838917" onclick="return D2.setFocusComment(53838917)" >You know by being good yourself</a>


		 	<span id="comment_score_53838917" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838917); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~guruevi">guruevi</a>  <span class="uid"><a href="//slashdot.org/~guruevi">( 827432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838917"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838917"><p>You have to a) know how to program yourself and b) be a good manager before you can judge whether a particular person is "good". All other 'metrics' whether it's number of bugs created/resolved, time taken, lines of code written, mean time between failures, are useless if you don't know how they relate to your existing code base and impacted the actual work being done. If your software is written in brainfuck (or one of the P's - PHP, Perl and Python) you can't blame the developer for time taken to resolve<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838917">

</div>
</div>

<div id="replyto_53838917"></div>

<ul id="group_53838917">
	<li id="hiddens_53838917" class="hide"></li>
</ul>

</li><li id="tree_53838931" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838931" class="commentstatus"></div>
<div id="comment_53838931" class="cw">
	<div id="comment_top_53838931" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838931" name="comment_link_53838931" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838931" onclick="return D2.setFocusComment(53838931)" >Successfully Executed Requests</a>


		 	<span id="comment_score_53838931" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838931); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Malggi">Malggi</a>  <span class="uid"><a href="//slashdot.org/~Malggi">( 791997 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838931"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838931"><p>
I don't know about where other people work. But for me the process is, customer requests something, I build the request, customer is satisfied with the result, boss is happy with me. Wash, rinse, repeat.
</p><p>
Does it really need to be more complicated than that?
</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838931">

</div>
</div>

<div id="replyto_53838931"></div>

<ul id="group_53838931">
	<li id="hiddens_53838931" class="hide"></li>
</ul>

</li><li id="tree_53838949" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838949" class="commentstatus"></div>
<div id="comment_53838949" class="cw">
	<div id="comment_top_53838949" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838949" name="comment_link_53838949" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838949" onclick="return D2.setFocusComment(53838949)" >Metrics cannot replace understanding</a>


		 	<span id="comment_score_53838949" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838949); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838949"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838949"><p>This fact has been known for a long, long time:</p><p>
&nbsp; &nbsp; &nbsp; &nbsp; A good decision is based on knowledge and not on numbers. -- Plato</p><p>Yet these morons are _still_ looking for the "magic" numbers that can replace understanding, millennia later. The only thing that works is a "Chief Coder" or "Chief Engineer", who must be very competent, both technologically and with regards to social skills. That person will know. Of course, such people are rare, but nothing else works.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838949">

</div>
</div>

<div id="replyto_53838949"></div>

<ul id="group_53838949">
	<li id="hiddens_53838949" class="hide"></li>
</ul>

</li><li id="tree_53838965" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838965" class="commentstatus"></div>
<div id="comment_53838965" class="cw">
	<div id="comment_top_53838965" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838965" name="comment_link_53838965" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838965" onclick="return D2.setFocusComment(53838965)" >Translation</a>


		 	<span id="comment_score_53838965" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838965); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~GrumpySteen">GrumpySteen</a>  <span class="uid"><a href="//slashdot.org/~GrumpySteen">( 1250194 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838965"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838965"><p>"I am a pointy haired boss who wants to treat my employees like I treat my fantasy baseball team.  Please give me a stat system so that I can rank them and start abusing/eliminating the ones who end up ranked lowest."</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838965">

</div>
</div>

<div id="replyto_53838965"></div>

<ul id="group_53838965">
	<li id="hiddens_53838965" class="hide"></li>
</ul>

</li><li id="tree_53838969" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838969" class="commentstatus"></div>
<div id="comment_53838969" class="cw">
</div>

<div id="replyto_53838969"></div>

<ul id="group_53838969">
	<li id="hiddens_53838969" class="hide"></li>
</ul>

</li><li id="tree_53838975" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838975" class="commentstatus"></div>
<div id="comment_53838975" class="cw">
	<div id="comment_top_53838975" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838975" name="comment_link_53838975" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838975" onclick="return D2.setFocusComment(53838975)" >If you ant to evaluate a developer...</a>


		 	<span id="comment_score_53838975" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838975); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~QuietLagoon">QuietLagoon</a>  <span class="uid"><a href="//slashdot.org/~QuietLagoon">( 813062 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838975"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838975"><p><span class="substr"> </span><div class="quote"><p>...One of the easiest ways to evaluate a developer is keeping a tab on the amount of value they provide to a business.<nobr> <wbr></nobr>...</p></div><p>... you need to look at things that are under her/his control.  If the developer is placed on low-value projects, then the value of that developer is low.  Does that mean the developer is no good?  Evaluating the value of a developer to the company may be more of an evaluation of management than the developer.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838975">

</div>
</div>

<div id="replyto_53838975"></div>

<ul id="group_53838975">
	<li id="hiddens_53838975" class="hide"></li>
</ul>

</li><li id="tree_53838977" class="comment hidden"><span class="ind"></span>
<div id="comment_status_53838977" class="commentstatus"></div>
<div id="comment_53838977" class="cw">
</div>

<div id="replyto_53838977"></div>

<ul id="group_53838977">
	<li id="hiddens_53838977" class="hide"></li>
</ul>

</li><li id="tree_53838983" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53838983" class="commentstatus"></div>
<div id="comment_53838983" class="cw">
	<div id="comment_top_53838983" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53838983" name="comment_link_53838983" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53838983" onclick="return D2.setFocusComment(53838983)" >Hard line between output and 'being one'</a>


		 	<span id="comment_score_53838983" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53838983); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~adosch">adosch</a>  <span class="uid"><a href="//slashdot.org/~adosch">( 1397357 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53838983"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53838983"><p>I think it's a really hard thing to quantify a 'good job' for a developer?  The amount of context and work scenarios would make your head explode, honestly.</p><p>What if we were talking a one to two developer shop where hackish amateurism and 5-minute produced Wordpress sites seems like 'magic' and just 'works'?  On the complete other side of the spectrum with your Google, Facebook, Amazon, Snapchat, Instagram, and Microsoft's of the world in terms of fixing an ultra complex situation in 5 minutes that's nearly b<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53838983">

</div>
</div>

<div id="replyto_53838983"></div>

<ul id="group_53838983">
	<li id="hiddens_53838983" class="hide"></li>
</ul>

</li><li id="tree_53839149" class="comment oneline"><span class="ind"></span>
<div id="comment_status_53839149" class="commentstatus"></div>
<div id="comment_53839149" class="cw">
	<div id="comment_top_53839149" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_53839149" name="comment_link_53839149" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;cid=53839149" onclick="return D2.setFocusComment(53839149)" >Big teams vs small teams</a>


		 	<span id="comment_score_53839149" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 53839149); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cloud.pt">cloud.pt</a>  <span class="uid"><a href="//slashdot.org/~cloud.pt">( 3412475 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_53839149"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_53839149"><p>On team development, it's pretty straight forward, although requires 2 agile tools: daily meetings &amp;&amp; code reviews. Even if not using full-fledged Scrum, daily meetings (or at the very least, every other day; weekly defeats the purpose) are essential both to enforcing lazy/demotivated coders to code, and to keep everyone "up to speed" on each devs, well, speed (velocity). Some will argue there are devs that can mask it out pretty well on dailies, but in the long run, it's impossible not to notice wh<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_53839149">

</div>
</div>

<div id="replyto_53839149"></div>

<ul id="group_53839149">
	<li id="hiddens_53839149" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10230439&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">10 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//ask.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 23;
		D2.currents()['full']     = 5;
		D2.currents()['oneline']  = 46;
		// D2.currents_total(74);

		D2.abbrev_comments({53838983:522,53839149:515,53838879:529,53839013:521,53839127:522,53838883:529,53838967:543,53839133:512,53838837:540,53838745:529,53839001:522,53839175:529,53838743:512,53838975:3,53838917:514,53838997:755,53839055:677,53839201:1181});
		D2.noshow_comments([53838905,53839099,53839123,53838673,53838839,53838921,53838901,53839043,53838683,53838691,53838703,53838863,53838891,53839137,53838763,53838889,53838797,53838801,53838845,53839085,53839189,53838969,53838977]);
		D2.pieces_comments([53838655,53839001,53839175,53838997,53839127,53839013,53839059,53838815,53838861,53839031,53839025,53838701,53839113,53839049,53838721,53838967,53838849,53838885,53839133,53839055,53838687,53839135,53839141,53838719,53838723,53838741,53838873,53839157,53838743,53838745,53838793,53838837,53839201,53838853,53838859,53838869,53838879,53838883,53838941,53838917,53838931,53838949,53838965,53838975,53838983,53839149]);
		D2.init_hiddens([53839001,53838789,53838701,53838721,53838679,53838719,53838775,53838879,53838883,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(322333);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1144<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/06/13/0159223/ask-slashdot-can-technology-prevent-shootings?sdsrc=popbyskidbtmprev">Ask Slashdot:  Can Technology Prevent Shootings?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>766<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/12/21/151229/slashdot-asks-why-are-browsers-so-slow?sdsrc=popbyskidbtmprev">Slashdot Asks: Why Are Browsers So Slow?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>637<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/06/06/0119217/ask-slashdot-how-do-you-create-a-highly-secure-password?sdsrc=popbyskidbtmprev">Ask Slashdot: How Do You Create A Highly-Secure Password?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>587<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/11/07/0225204/ask-slashdot-why-are-american-tech-workers-paid-so-well?sdsrc=popbyskidbtmprev">Ask Slashdot: Why Are American Tech Workers Paid So Well?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>561<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/04/24/183245/slashdot-asks-have-you-experienced-ageism?sdsrc=popbyskidbtmprev">Slashdot Asks: Have You Experienced Ageism?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//news.slashdot.org/story/17/02/10/1255245/most-of-the-web-really-sucks-if-you-have-a-slow-connection?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/chrome_64.png" width="64" height="64" alt="Chrome"></span>
	    
					<p class="grid_12"><a href="//news.slashdot.org/story/17/02/10/1255245/most-of-the-web-really-sucks-if-you-have-a-slow-connection?sdsrc=nextbtmprev">Most of the Web Really Sucks If You Have a Slow Connection</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>25<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/17/02/10/0234215/tesla-employee-calls-for-unionization-musk-says-thats-morally-outrageous?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/17/02/10/0234215/tesla-employee-calls-for-unionization-musk-says-thats-morally-outrageous?sdsrc=prevbtmprev">Tesla Employee Calls For Unionization, Musk Says That's 'Morally Outrageous'</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>173<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//ask.slashdot.org/comments.pl?sid=10230439&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">74</span> of <span class="totalcommentcnt">74</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>He who has but four and spends five has no need for a wallet.</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
if($('#div-gpt-ad-728x90_a').length > 0){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
            if($(this).hasClass('railad')) {
                cls = 'adwrap-railad-sticky';
                toggleCls = '';
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
            }
        });
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                $('#firehoselist article').eq(2).after(html);
            }
        });
        
        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?266">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?798">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->