<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '73567246630444125',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts? - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="Slashdot reader dryriver writes:
There appear to be two main ways to write code today. One is with text-based languages ranging from BASIC to Python to C++. The other is to use a flow-based or dataflow programming-based visual programming language where you connect boxes or nodes with lines. What I ...">
		<meta itemprop="name" content="Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts? - Slashdot">
		<meta itemprop="description" content="Slashdot reader dryriver writes:
There appear to be two main ways to write code today. One is with text-based languages ranging from BASIC to Python to C++. The other is to use a flow-based or dataflow programming-based visual programming language where you connect boxes or nodes with lines. What I ...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/programming_64.png">
	
	
		<link rel="canonical" href="https://ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/327045" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?eada4f27471b9c9c" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?eada4f27471b9c9c" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?eada4f27471b9c9c" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?eada4f27471b9c9c">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: developers askslashdot programming dataflow logic
  
  var backend_tpc = [[ "programming", "developers", "askslashdot", "dataflow", "logic" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?eada4f27471b9c9c"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?eada4f27471b9c9c" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//ask.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotAskSlashdot" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //ask.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Slashdot is powered by <strong><a href="//ask.slashdot.org/submission">your submissions</a></strong>, so send in your scoop
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong> Also, <strong>Slashdot's <a href="https://ifttt.com/slashdot" rel="nofollow">now on IFTTT.</a></strong> Check it out! Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 Internet speed test!</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-91514861" data-fhid="91514861" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">91514861</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-91514861">
			<a href="//ask.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-91514861" class="story-title"> <a   href="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts">Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts?</a></span>

		
		
		<!--<span class="comments commentcnt-91514861" >145</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts#comments" title="">145</a></span>
		
	</h2>
	<div class="details" id="details-91514861">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-91514861" datetime="on Sunday June 04, 2017 @12:44AM">on Sunday June 04, 2017 @12:44AM</time>
		
		
			 from the <span class="dept-text">tracking-the-code</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-91514861">
	
		
	

	
		
		<div id="text-91514861" class="p">
			
		 	
				Slashdot reader <a href="/~dryriver">dryriver</a> writes:
<i>There appear to be two main ways to write code today. One is with text-based languages ranging from BASIC to Python to C++. The other is to use a flow-based or dataflow programming-based visual programming language where you connect boxes or nodes with lines. What I have never (personally) come across is a way to program by drawing classical vertical (top to bottom) flow charts. Is there a programming environment that lets you do this...?
<br> <br>There are software tools that can turn, say, C code into a visual flow chart representation of said C code. Is there any way to do the opposite -- draw a flowchart, and have that flowchart turn into working C code?</i> <br>
Leave your best answers in the comments.
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-91514861" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts"
								  data-janrain-title="Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts?"
								  data-janrain-message="Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts? @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-91514861" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/developers" target="_blank">developers</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/askslashdot" target="_blank">askslashdot</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/programming" target="_blank">programming</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//yro.slashdot.org/story/17/06/03/0137216/bruce-perens-explains-that-gpl-is-a-contract-court-case?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//news.slashdot.org/story/17/06/04/0027201/esr-shares-a-forgotten-roots-of-open-source-moment-from-1984?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//yro.slashdot.org/story/17/06/03/0137216/bruce-perens-explains-that-gpl-is-a-contract-court-case?sdsrc=prev">Bruce Perens Explains That 'GPL Is A Contract' Court Case </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/16/08/15/236236/ask-slashdot-what-are-some-bad-programming-ideas-that-work?sdsrc=rel">Ask Slashdot: What Are Some Bad Programming Ideas That Work?</a></h3><h3><a href="//developers.slashdot.org/story/16/10/01/2249256/are-flawed-languages-creating-bad-software?sdsrc=rel">Are Flawed Languages Creating Bad Software?</a></h3><h3><a href="//developers.slashdot.org/story/16/11/11/2229233/here-be-dragons-the-seven-most-vexing-problems-in-programming?sdsrc=rel">'Here Be Dragons': The Seven Most Vexing Problems In Programming</a></h3><h3><a href="//developers.slashdot.org/story/17/02/04/1751211/developer-argues-for-forgotten-code-constructs-like-goto-and-eval?sdsrc=rel">Developer Argues For 'Forgotten Code Constructs' Like GOTO and Eval</a></h3><h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//ask.slashdot.org/submission/7079401/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flowcharts?sdsrc=rel" href="#">Submission: Ask Slashdot: Is There A Way To Write Working Code By Drawing Flowcharts?</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//news.slashdot.org/story/17/06/04/0027201/esr-shares-a-forgotten-roots-of-open-source-moment-from-1984?sdsrc=next">ESR Shares A Forgotten 'Roots Of Open Source' Moment From 1984</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts" title="Back to Article - Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts?">Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts?</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts?" href="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts">Ask Slashdot: Is There a Way To Write Working Code By Drawing Flow Charts?</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=10694299" class="btn">Search <span class="totalcommentcnt">146</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//ask.slashdot.org/comments.pl?sid=10694299">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=10694299" class="ui-icon search_comments">Search <span class="totalcommentcnt">146</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//ask.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/17/06/03/0113239/ask-slashdot-is-there-a-way-to-write-working-code-by-drawing-flow-charts/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?eada4f27471b9c9c" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_54544625" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544625" class="commentstatus"></div>
<div id="comment_54544625" class="cw">
	<div id="comment_top_54544625" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544625" name="comment_link_54544625" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544625" onclick="return D2.setFocusComment(54544625)" >Is this a joke?</a>


		 	<span id="comment_score_54544625" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544625); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544625"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544625">I probably still have my flowchart template from Introduction to Computers in 1993. Used it for that one class and never used it again. Not even when I later went back to school to learn computer programming a decade later.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544625">

</div>
</div>

<div id="replyto_54544625"></div>

<ul id="group_54544625">
	<li id="hiddens_54544625" class="hide"></li>
</ul>

<ul id="commtree_54544625"><li id="tree_54544639" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544639" class="commentstatus"></div>
<div id="comment_54544639" class="cw">
	<div id="comment_top_54544639" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544639" name="comment_link_54544639" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544639" onclick="return D2.setFocusComment(54544639)" >Does seem a bit 80's...</a>


		 	<span id="comment_score_54544639" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544639); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Giant+Electronic+Bra">Giant Electronic Bra</a>  <span class="uid"><a href="//slashdot.org/~Giant+Electronic+Bra">( 1229876 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544639">		
		on Sunday June 04, 2017 @12:54AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544639">#54544639</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544639"><p>I mean, we have had UML now for going on 15 years. You can CERTAINLY generate code and other artifacts from some types of UML diagrams. None of these is all that much like a flowchart, and frankly flowcharts are essentially dead AFAIK. They really only ever worked well, if they ever did, on fairly straightforward procedural code. Back in the bad old days before Structured Programming and then OOP it wasn't all that uncommon to see people using them, but that was mainly because even fairly straightforward linear code was hard to understand when it was written in FORTRAN or COBOL. Such charts have little relevance in modern OO/functional coding where linear control flow is really not an issue.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544639">
<span class="ind"></span><a id="reply_link_54544639" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544639" onclick="D2.replyTo(54544639); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54544625" onclick="return D2.selectParent(54544625)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Does seem a bit 80's... by Giant Electronic Bra @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544639" data-title="Does seem a bit 80's...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Does seem a bit 80's... by Giant Electronic Bra" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544639" data-title="Does seem a bit 80's...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Does seem a bit 80's... by Giant Electronic Bra" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544639" data-title="Does seem a bit 80's...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544639" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544639" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544639" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544639"></div>

<ul id="group_54544639">
	<li id="hiddens_54544639" class="hide"></li>
</ul>

<ul id="commtree_54544639"><li id="tree_54544675" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544675" class="commentstatus"></div>
<div id="comment_54544675" class="cw">
	<div id="comment_top_54544675" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544675" name="comment_link_54544675" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544675" onclick="return D2.setFocusComment(54544675)" >Re:</a>


		 	<span id="comment_score_54544675" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544675); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544675"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544675"><p>Simulink is a variation of flowchart programming, but maintainability is hard when it comes to flowchart programming. You need a football field or two to try to make sense of it and any large system will have cross-dependency graphs that are extremely hard to follow.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544675">

</div>
</div>

<div id="replyto_54544675"></div>

<ul id="group_54544675">
	<li id="hiddens_54544675" class="hide"></li>
</ul>

<ul id="commtree_54544675"><li id="tree_54544705" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544705" class="commentstatus"></div>
<div id="comment_54544705" class="cw">
</div>

<div id="replyto_54544705"></div>

<ul id="group_54544705">
	<li id="hiddens_54544705" class="hide"></li>
</ul>

<ul id="commtree_54544705"><li id="tree_54544895" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544895" class="commentstatus"></div>
<div id="comment_54544895" class="cw">
</div>

<div id="replyto_54544895"></div>

<ul id="group_54544895">
	<li id="hiddens_54544895" class="hide"></li>
</ul>

</li><li id="hidestring_54544705"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54544705">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_54544675"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54544675">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54545401" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545401" class="commentstatus"></div>
<div id="comment_54545401" class="cw">
	<div id="comment_top_54545401" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545401" name="comment_link_54545401" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545401" onclick="return D2.setFocusComment(54545401)" >Re:</a>


		 	<span id="comment_score_54545401" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545401); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545401"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545401"><p>UML and other Flowcharting method are better on paper.  But rarely can scale to a full application.<br>1. They are based on the idea that the business owners know what they want.  UML and flowchart are based on the idea if you have enough meetings and talk to the right people that you will get all the info needed.  This isn't true. What they say they want vs what they need are actually very different.<br>2. Like objects often will evolve into two different species.  UML wants to make a Person class that can be inhe<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545401">

</div>
</div>

<div id="replyto_54545401"></div>

<ul id="group_54545401">
	<li id="hiddens_54545401" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544663" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544663" class="commentstatus"></div>
<div id="comment_54544663" class="cw">
	<div id="comment_top_54544663" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544663" name="comment_link_54544663" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544663" onclick="return D2.setFocusComment(54544663)" >Re:</a>


		 	<span id="comment_score_54544663" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544663); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Nutria">Nutria</a>  <span class="uid"><a href="//slashdot.org/~Nutria">( 679911 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544663"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544663"><p><div class="quote"><p>I probably still have my flowchart template from Introduction to Computers in 1993</p></div><p>They had me do it in 1983, and I know that flowcharts were around in 1963...</p><p>I also remember 4GL flow chart code generators in the mid-1980s, and their promise of "programs without paying programmers".  What a joke that was.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544663">

</div>
</div>

<div id="replyto_54544663"></div>

<ul id="group_54544663">
	<li id="hiddens_54544663" class="hide"></li>
</ul>

</li><li id="tree_54544695" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544695" class="commentstatus"></div>
<div id="comment_54544695" class="cw">
</div>

<div id="replyto_54544695"></div>

<ul id="group_54544695">
	<li id="hiddens_54544695" class="hide"></li>
</ul>

</li><li id="tree_54544843" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544843" class="commentstatus"></div>
<div id="comment_54544843" class="cw">
	<div id="comment_top_54544843" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544843" name="comment_link_54544843" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544843" onclick="return D2.setFocusComment(54544843)" >LEGO Mindstorms/LabVIEW</a>


		 	<span id="comment_score_54544843" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544843); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Roger+W+Moore">Roger W Moore</a>  <span class="uid"><a href="//slashdot.org/~Roger+W+Moore">( 538166 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544843">		
		on Sunday June 04, 2017 @02:10AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544843">#54544843</a>)
		<small><a href="//slashdot.org/~Roger+W+Moore/journal/" title="Monday April 13, 2009 @07:10PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544843">It's no joke. LEGO Mindstorms comes with a graphical flowchart-like language using LabVIEW to write programs. Of course, the system is hideously slow and inefficient compared to text and with EV3 the brick runs Linux so you can easily dump it for Python, C++ or whatever you like.
<br> <br>
LabVIEW itself is also used for instrumental programming in some labs although I expect it is rather slow so its applications will be somewhat limited. I've never used it myself in particle physics but I believe some of my condensed matter colleagues use it as a slow control system for commercial instruments.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544843">
<span class="ind"></span><a id="reply_link_54544843" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544843" onclick="D2.replyTo(54544843); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54544625" onclick="return D2.selectParent(54544625)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="LEGO Mindstorms/LabVIEW by Roger W Moore @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544843" data-title="LEGO Mindstorms/LabVIEW">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="LEGO Mindstorms/LabVIEW by Roger W Moore" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544843" data-title="LEGO Mindstorms/LabVIEW">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="LEGO Mindstorms/LabVIEW by Roger W Moore" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544843" data-title="LEGO Mindstorms/LabVIEW">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544843" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544843" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544843" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544843"></div>

<ul id="group_54544843">
	<li id="hiddens_54544843" class="hide"></li>
</ul>

<ul id="commtree_54544843"><li id="tree_54544959" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544959" class="commentstatus"></div>
<div id="comment_54544959" class="cw">
	<div id="comment_top_54544959" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544959" name="comment_link_54544959" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544959" onclick="return D2.setFocusComment(54544959)" >Re:</a>


		 	<span id="comment_score_54544959" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544959); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sjames">sjames</a>  <span class="uid"><a href="//slashdot.org/~sjames">( 1099 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544959"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544959"><p>It's not a joke but it is EXTREMELY limited. So much so that I'm not convinced it can ever be used for anything but programs just slightly more complex than hello world.</p><p>Sometimes, that may be good enough for example, LabVIEW for handling tabletop experiments.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544959">

</div>
</div>

<div id="replyto_54544959"></div>

<ul id="group_54544959">
	<li id="hiddens_54544959" class="hide"></li>
</ul>

<ul id="commtree_54544959"><li id="tree_54545215" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545215" class="commentstatus"></div>
<div id="comment_54545215" class="cw">
	<div id="comment_top_54545215" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545215" name="comment_link_54545215" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545215" onclick="return D2.setFocusComment(54545215)" >Re:</a>


		 	<span id="comment_score_54545215" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545215); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545215"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545215"><p>With limited power comes limited opportunity to screw things up. "programming" by bolting together functional blocks with lines are the preferred ways of programming safety systems for this reason, and the IEC standards put very different requirements on programs written this way compared to those written in freeform code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545215">

</div>
</div>

<div id="replyto_54545215"></div>

<ul id="group_54545215">
	<li id="hiddens_54545215" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544963" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544963" class="commentstatus"></div>
<div id="comment_54544963" class="cw">
	<div id="comment_top_54544963" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544963" name="comment_link_54544963" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544963" onclick="return D2.setFocusComment(54544963)" >Re:</a>


		 	<span id="comment_score_54544963" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544963); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dbIII">dbIII</a>  <span class="uid"><a href="//slashdot.org/~dbIII">( 701233 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544963"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544963">Yes, but it doesn't scale.<br>In LabVIEW you get stuff crossing over and under all over the place unless you decide to have the complete opposite of a modular approach and end up with a time consuming verbose thing.<br>The choice for anything other than an utterly trivial project is too complex for another to understand easily or too much code for them to bother looking at it.<br>IMHO it's a teaching tool gone wrong.  I think it's supposed to inspire people to go up to the next step and think of large modules the way t</div>
	</div>

	<div class="commentSub" id="comment_sub_54544963">

</div>
</div>

<div id="replyto_54544963"></div>

<ul id="group_54544963">
	<li id="hiddens_54544963" class="hide"></li>
</ul>

<ul id="commtree_54544963"><li id="tree_54545677" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54545677" class="commentstatus"></div>
<div id="comment_54545677" class="cw">
</div>

<div id="replyto_54545677"></div>

<ul id="group_54545677">
	<li id="hiddens_54545677" class="hide"></li>
</ul>

<ul id="commtree_54545677"><li id="tree_54545897" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545897" class="commentstatus"></div>
<div id="comment_54545897" class="cw">
	<div id="comment_top_54545897" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545897" name="comment_link_54545897" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545897" onclick="return D2.setFocusComment(54545897)" >Re:</a>


		 	<span id="comment_score_54545897" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545897); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dbIII">dbIII</a>  <span class="uid"><a href="//slashdot.org/~dbIII">( 701233 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545897"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545897"><blockquote><div><p>I have been using LabVIEW for ~15 years</p></div></blockquote><p>That's starting five years after I stopped showing it to students because it was teaching them bad habits.<br>I'm not just guessing here.<br> <br>It's a throwback to analogue computers without the careful mathematical optimisation that was usually employed before plugging in the cables.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545897">

</div>
</div>

<div id="replyto_54545897"></div>

<ul id="group_54545897">
	<li id="hiddens_54545897" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54545783" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545783" class="commentstatus"></div>
<div id="comment_54545783" class="cw">
	<div id="comment_top_54545783" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545783" name="comment_link_54545783" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545783" onclick="return D2.setFocusComment(54545783)" >Re: LEGO Mindstorms/LabVIEW</a>


		 	<span id="comment_score_54545783" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545783); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SETY">SETY</a>  <span class="uid"><a href="//slashdot.org/~SETY">( 46845 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545783"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545783"><p>Yes it is great for controlling instruments. It's not really slow per se. It really depends what you are trying to do. The biggest issue is it is very easy to write a mess with anything half complicated. But these same PhD's write FORTRAN and Matlab code with zero functions too.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545783">

</div>
</div>

<div id="replyto_54545783"></div>

<ul id="group_54545783">
	<li id="hiddens_54545783" class="hide"></li>
</ul>

</li><li id="tree_54545869" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545869" class="commentstatus"></div>
<div id="comment_54545869" class="cw">
	<div id="comment_top_54545869" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545869" name="comment_link_54545869" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545869" onclick="return D2.setFocusComment(54545869)" >Re:</a>


		 	<span id="comment_score_54545869" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545869); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Megane">Megane</a>  <span class="uid"><a href="//slashdot.org/~Megane">( 129182 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545869"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545869">The worst thing about labview is that it's basically impossible to use source code control with it. That's fine for throwaway toy programs, but not for anything that has to be maintained.</div>
	</div>

	<div class="commentSub" id="comment_sub_54545869">

</div>
</div>

<div id="replyto_54545869"></div>

<ul id="group_54545869">
	<li id="hiddens_54545869" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544903" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544903" class="commentstatus"></div>
<div id="comment_54544903" class="cw">
</div>

<div id="replyto_54544903"></div>

<ul id="group_54544903">
	<li id="hiddens_54544903" class="hide"></li>
</ul>

</li><li id="tree_54545013" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545013" class="commentstatus"></div>
<div id="comment_54545013" class="cw">
	<div id="comment_top_54545013" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545013" name="comment_link_54545013" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545013" onclick="return D2.setFocusComment(54545013)" >Re:</a>


		 	<span id="comment_score_54545013" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545013); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~EETech1">EETech1</a>  <span class="uid"><a href="//slashdot.org/~EETech1">( 1179269 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545013"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545013"><p>Someone is posting as you, with very closely spelled names, and 4980000+ uid's</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545013">

</div>
</div>

<div id="replyto_54545013"></div>

<ul id="group_54545013">
	<li id="hiddens_54545013" class="hide"></li>
</ul>

<ul id="commtree_54545013"><li id="tree_54545361" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545361" class="commentstatus"></div>
<div id="comment_54545361" class="cw">
	<div id="comment_top_54545361" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545361" name="comment_link_54545361" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545361" onclick="return D2.setFocusComment(54545361)" >Re:</a>


		 	<span id="comment_score_54545361" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545361); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545361"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545361"><p><div class="quote"><p>Someone is posting as you, with very closely spelled names, and 4980000+ uid's</p></div><p>creimer apparently has a troll that is up in the middle of the night. I get up earlier than most of Slashdot in spite of being on the left coast and I have been seeing his trolls in low-comment-volume stories in the mornings. By midday they tend to be buried in higher-value comments, because his troll is not very good.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545361">

</div>
</div>

<div id="replyto_54545361"></div>

<ul id="group_54545361">
	<li id="hiddens_54545361" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54545221" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545221" class="commentstatus"></div>
<div id="comment_54545221" class="cw">
	<div id="comment_top_54545221" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545221" name="comment_link_54545221" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545221" onclick="return D2.setFocusComment(54545221)" >Re:</a>


		 	<span id="comment_score_54545221" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545221); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dutch+Gun">Dutch Gun</a>  <span class="uid"><a href="//slashdot.org/~Dutch+Gun">( 899105 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545221"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545221"><p>Yes, you absolutely can write code using flowcharts, and I've got two practical examples from my career in videogames.  Obviously, both were in specialized sub-domains, as the bulk of our general work is in C++.</p><p>First example: I worked at a place that allowed artists to wire up nodes in Maya using a circuit-like logic system.  For input, they'd use timers, triggers, environmental sources (time of day), etc.  Then they'd connect those inputs to various logic gate nodes (AND, OR, math, branching, delays, etc),<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545221">

</div>
</div>

<div id="replyto_54545221"></div>

<ul id="group_54545221">
	<li id="hiddens_54545221" class="hide"></li>
</ul>

<ul id="commtree_54545221"><li id="tree_54545359" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545359" class="commentstatus"></div>
<div id="comment_54545359" class="cw">
	<div id="comment_top_54545359" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545359" name="comment_link_54545359" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545359" onclick="return D2.setFocusComment(54545359)" >Re:</a>


		 	<span id="comment_score_54545359" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545359); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545359"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545359"><p><div class="quote"><p>It was telling, though, that we eventually added a "Lua Script" node, because sometimes complex logic is really hard to do with circuit-type wiring.</p></div><p>There's a nice quote by Alan Perlis: "A picture is worth 10K words - but only those to describe the picture. Hardly any sets of 10K words can be adequately described with pictures."</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545359">

</div>
</div>

<div id="replyto_54545359"></div>

<ul id="group_54545359">
	<li id="hiddens_54545359" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54545329" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545329" class="commentstatus"></div>
<div id="comment_54545329" class="cw">
	<div id="comment_top_54545329" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545329" name="comment_link_54545329" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545329" onclick="return D2.setFocusComment(54545329)" >Re:</a>


		 	<span id="comment_score_54545329" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545329); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~portwojc">portwojc</a>  <span class="uid"><a href="//slashdot.org/~portwojc">( 201398 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545329"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545329"><p>Perhaps...  From the hacker test... http://www.mit.edu/people/mjbauer/Purity/hackpure.html</p><p>00B4 Do you have a flowchart template?<br>00B5<nobr> <wbr></nobr>... Is it unused?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545329">

</div>
</div>

<div id="replyto_54545329"></div>

<ul id="group_54545329">
	<li id="hiddens_54545329" class="hide"></li>
</ul>

</li><li id="tree_54545715" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545715" class="commentstatus"></div>
<div id="comment_54545715" class="cw">
	<div id="comment_top_54545715" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545715" name="comment_link_54545715" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545715" onclick="return D2.setFocusComment(54545715)" >Re: Is this a joke?</a>


		 	<span id="comment_score_54545715" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545715); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dnaumov">dnaumov</a>  <span class="uid"><a href="//slashdot.org/~dnaumov">( 453672 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545715"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545715"><p>Why would that be a joke? We live in an age where AI software is coding AI software. Why would a less-automated system be outlandish?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545715">

</div>
</div>

<div id="replyto_54545715"></div>

<ul id="group_54545715">
	<li id="hiddens_54545715" class="hide"></li>
</ul>

<ul id="commtree_54545715"><li id="tree_54545945" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545945" class="commentstatus"></div>
<div id="comment_54545945" class="cw">
	<div id="comment_top_54545945" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545945" name="comment_link_54545945" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545945" onclick="return D2.setFocusComment(54545945)" >Re:</a>


		 	<span id="comment_score_54545945" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545945); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545945"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545945"><p><div class="quote"><p>Why would a less-automated system be outlandish?</p></div><p>Because every decade we get something that promises to remove the programmer from creating the program, allowing corporations to save a ton of money or the layman to create programs at the press of a button. Those efforts never finds widespread appeal.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545945">

</div>
</div>

<div id="replyto_54545945"></div>

<ul id="group_54545945">
	<li id="hiddens_54545945" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54545781" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545781" class="commentstatus"></div>
<div id="comment_54545781" class="cw">
	<div id="comment_top_54545781" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545781" name="comment_link_54545781" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545781" onclick="return D2.setFocusComment(54545781)" >Re:Is this a joke? Yes but on who?</a>


		 	<span id="comment_score_54545781" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545781); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fygment">fygment</a>  <span class="uid"><a href="//slashdot.org/~fygment">( 444210 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545781"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545781"><p>Must be.  Why i've not seen anyone use a flowchart since they were forced to in school.  No sir, the _best_ way to code is just sit down with an idea and start banging out code.  'cause that's just the best way and everyone can do it.  Yup, bang away run the code look at the errors correct them bang away run look<nobr> <wbr></nobr>... repeat until you get something that works as hoped once.  Thinking about your code before coding?  For absolute ninnies, not even noobs.  And if you doubt the quality of the product well my fri<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545781">

</div>
</div>

<div id="replyto_54545781"></div>

<ul id="group_54545781">
	<li id="hiddens_54545781" class="hide"></li>
</ul>

<ul id="commtree_54545781"><li id="tree_54545921" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545921" class="commentstatus"></div>
<div id="comment_54545921" class="cw">
	<div id="comment_top_54545921" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545921" name="comment_link_54545921" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545921" onclick="return D2.setFocusComment(54545921)" >Re:</a>


		 	<span id="comment_score_54545921" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545921); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545921"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545921"><p><div class="quote"><p>Besides you're hinting at something like turning documentation into code and that's just frickin' heresy.</p></div><p>Python <a href="https://docs.python.org/3/library/doctest.html" title="python.org">doctest</a> [python.org] allows you to write example code in the documentation and then execute the example code as test cases. Useful for simple functions but a bit hairy for complex functions and classes.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545921">

</div>
</div>

<div id="replyto_54545921"></div>

<ul id="group_54545921">
	<li id="hiddens_54545921" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_54544625"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54544625">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54544633" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544633" class="commentstatus"></div>
<div id="comment_54544633" class="cw">
	<div id="comment_top_54544633" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544633" name="comment_link_54544633" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544633" onclick="return D2.setFocusComment(54544633)" >Congratulations, you just invented...</a>


		 	<span id="comment_score_54544633" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544633); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544633"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544633"><p>...you just invented pseudocode!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544633">

</div>
</div>

<div id="replyto_54544633"></div>

<ul id="group_54544633">
	<li id="hiddens_54544633" class="hide"></li>
</ul>

<ul id="commtree_54544633"><li id="tree_54544681" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544681" class="commentstatus"></div>
<div id="comment_54544681" class="cw">
	<div id="comment_top_54544681" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544681" name="comment_link_54544681" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544681" onclick="return D2.setFocusComment(54544681)" >Re:</a>


		 	<span id="comment_score_54544681" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544681); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544681"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544681"><p>Congratulations, you just invented Simulink.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544681">

</div>
</div>

<div id="replyto_54544681"></div>

<ul id="group_54544681">
	<li id="hiddens_54544681" class="hide"></li>
</ul>

<ul id="commtree_54544681"><li id="tree_54545181" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54545181" class="commentstatus"></div>
<div id="comment_54545181" class="cw">
	<div id="comment_top_54545181" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545181" name="comment_link_54545181" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545181" onclick="return D2.setFocusComment(54545181)" >Re:Congratulations, you just invented...</a>


		 	<span id="comment_score_54545181" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545181); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545181">		
		on Sunday June 04, 2017 @05:49AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545181">#54545181</a>)
		<small><a href="//slashdot.org/~TheRaven64/journal/" title="Saturday February 22, 2014 @06:49AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545181">He seems to want to take a dataflow programming language and generate C from it.  This is trivial and there have been a bunch of tools that do it.  The problem is, it's entirely pointless.  If your code is better represented as a flow chart, then use a dataflow programming language and <i>don't bother with C as an intermediate representation</i>.  The only reason to turn it into C is if some parts of it are easier to edit as C code (typically, bits with complex flow control, because even nested loops in graphical dataflow languages are pretty hideous).  Then the problem that you actually want to solve is turning a flow chart into C, editing it, and then <i>turning it back again while preserving the original structure</i>.  This is much harder, but typically dataflow languages let you call out to C for complex operations and that's generally a better solution.</div>
	</div>

	<div class="commentSub" id="comment_sub_54545181">
<span class="ind"></span><a id="reply_link_54545181" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54545181" onclick="D2.replyTo(54545181); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54544681" onclick="return D2.selectParent(54544681)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Congratulations, you just invented... by TheRaven64 @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54545181" data-title="Re:Congratulations, you just invented...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Congratulations, you just invented... by TheRaven64" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54545181" data-title="Re:Congratulations, you just invented...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Congratulations, you just invented... by TheRaven64" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54545181" data-title="Re:Congratulations, you just invented...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54545181" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54545181" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54545181" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54545181"></div>

<ul id="group_54545181">
	<li id="hiddens_54545181" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54544635" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544635" class="commentstatus"></div>
<div id="comment_54544635" class="cw">
	<div id="comment_top_54544635" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544635" name="comment_link_54544635" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544635" onclick="return D2.setFocusComment(54544635)" >IBM Rational Rhapsody</a>


		 	<span id="comment_score_54544635" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544635); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544635"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544635"><p>Rhapsody can do this, and has been around for about two decades. It was previously owned by I-Logix, and then Telelogic.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544635">

</div>
</div>

<div id="replyto_54544635"></div>

<ul id="group_54544635">
	<li id="hiddens_54544635" class="hide"></li>
</ul>

<ul id="commtree_54544635"><li id="tree_54545311" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545311" class="commentstatus"></div>
<div id="comment_54545311" class="cw">
	<div id="comment_top_54545311" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545311" name="comment_link_54545311" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545311" onclick="return D2.setFocusComment(54545311)" >Re:</a>


		 	<span id="comment_score_54545311" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545311); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PolygamousRanchKid+">PolygamousRanchKid </a>  <span class="uid"><a href="//slashdot.org/~PolygamousRanchKid+">( 1290638 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545311"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545311"><p>Speaking of IBM . . . take a look at Node-RED ( <a href="https://nodered.org/" title="nodered.org">https://nodered.org/</a> [nodered.org] )<nobr> <wbr></nobr>:</p><p><div class="quote"><p>Node-RED is a programming tool for wiring together hardware devices, APIs and online services in new and interesting ways.

It provides a browser-based editor that makes it easy to wire together flows using the wide range of nodes in the palette that can be deployed to its runtime in a single-click.</p></div><p>Think of it as creating node.js code from flows you define with a graphical editor.
</p><p>DISCLAIMER:  I use it a lot, and had the pleasure of meeting one of its creators, Nick O'Leary, who works for IBM.  He is a bit of a geek's geek . . . a technical genius, but very humble about it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545311">

</div>
</div>

<div id="replyto_54545311"></div>

<ul id="group_54545311">
	<li id="hiddens_54545311" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544649" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544649" class="commentstatus"></div>
<div id="comment_54544649" class="cw">
</div>

<div id="replyto_54544649"></div>

<ul id="group_54544649">
	<li id="hiddens_54544649" class="hide"></li>
</ul>

</li><li id="tree_54544651" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544651" class="commentstatus"></div>
<div id="comment_54544651" class="cw">
	<div id="comment_top_54544651" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544651" name="comment_link_54544651" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544651" onclick="return D2.setFocusComment(54544651)" >You just described Simulink.</a>


		 	<span id="comment_score_54544651" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544651); return false"><span class=opt>Score:</span>3</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544651">		
		on Sunday June 04, 2017 @12:57AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544651">#54544651</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544651"><p>Plus Simulink coder.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544651">
<span class="ind"></span><a id="reply_link_54544651" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544651" onclick="D2.replyTo(54544651); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="You just described Simulink. by Anonymous Coward @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544651" data-title="You just described Simulink.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="You just described Simulink. by Anonymous Coward" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544651" data-title="You just described Simulink.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="You just described Simulink. by Anonymous Coward" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544651" data-title="You just described Simulink.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544651" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544651" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544651" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544651"></div>

<ul id="group_54544651">
	<li id="hiddens_54544651" class="hide"></li>
</ul>

<ul id="commtree_54544651"><li id="tree_54545417" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545417" class="commentstatus"></div>
<div id="comment_54545417" class="cw">
	<div id="comment_top_54545417" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545417" name="comment_link_54545417" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545417" onclick="return D2.setFocusComment(54545417)" >Re:</a>


		 	<span id="comment_score_54545417" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545417); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~giampy">giampy</a>  <span class="uid"><a href="//slashdot.org/~giampy">( 592646 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545417"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545417"><p>You can also go the other way around:</p><p><a href="http://www.ensoftcorp.com/modelify/" title="ensoftcorp.com">http://www.ensoftcorp.com/mode...</a> [ensoftcorp.com]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545417">

</div>
</div>

<div id="replyto_54545417"></div>

<ul id="group_54545417">
	<li id="hiddens_54545417" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544655" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544655" class="commentstatus"></div>
<div id="comment_54544655" class="cw">
	<div id="comment_top_54544655" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544655" name="comment_link_54544655" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544655" onclick="return D2.setFocusComment(54544655)" >Kind of</a>


		 	<span id="comment_score_54544655" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544655); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~atari2600a">atari2600a</a>  <span class="uid"><a href="//slashdot.org/~atari2600a">( 1892574 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544655"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544655">Google Scratch.  2.0 makes it turing-complete but it's not exactly API compatible</div>
	</div>

	<div class="commentSub" id="comment_sub_54544655">

</div>
</div>

<div id="replyto_54544655"></div>

<ul id="group_54544655">
	<li id="hiddens_54544655" class="hide"></li>
</ul>

</li><li id="tree_54544657" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544657" class="commentstatus"></div>
<div id="comment_54544657" class="cw">
</div>

<div id="replyto_54544657"></div>

<ul id="group_54544657">
	<li id="hiddens_54544657" class="hide"></li>
</ul>

</li><li id="tree_54544659" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544659" class="commentstatus"></div>
<div id="comment_54544659" class="cw">
	<div id="comment_top_54544659" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544659" name="comment_link_54544659" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544659" onclick="return D2.setFocusComment(54544659)" >Scratch</a>


		 	<span id="comment_score_54544659" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544659); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~roskakori">roskakori</a>  <span class="uid"><a href="//slashdot.org/~roskakori">( 447739 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544659"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544659"><a href="https://scratch.mit.edu/" title="mit.edu">Scratch</a> [mit.edu] uses an approach similar to flow charts. If you're not to picky about the notation, it might be what you are looking for.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544659">

</div>
</div>

<div id="replyto_54544659"></div>

<ul id="group_54544659">
	<li id="hiddens_54544659" class="hide"></li>
</ul>

</li><li id="tree_54544669" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544669" class="commentstatus"></div>
<div id="comment_54544669" class="cw">
	<div id="comment_top_54544669" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544669" name="comment_link_54544669" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544669" onclick="return D2.setFocusComment(54544669)" >Why?</a>


		 	<span id="comment_score_54544669" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544669); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tablizer">Tablizer</a>  <span class="uid"><a href="//slashdot.org/~Tablizer">( 95088 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544669"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544669"><p>Why? Even if it could technically be done, it's <b>probably not good code</b> from a human-readability standpoint and will have to be heavily reworked, such as variable re-naming, splitting into functions/modules, etc.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544669">

</div>
</div>

<div id="replyto_54544669"></div>

<ul id="group_54544669">
	<li id="hiddens_54544669" class="hide"></li>
</ul>

<ul id="commtree_54544669"><li id="tree_54544947" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544947" class="commentstatus"></div>
<div id="comment_54544947" class="cw">
	<div id="comment_top_54544947" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544947" name="comment_link_54544947" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544947" onclick="return D2.setFocusComment(54544947)" >Re:</a>


		 	<span id="comment_score_54544947" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544947); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TuringTest">TuringTest</a>  <span class="uid"><a href="//slashdot.org/~TuringTest">( 533084 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544947"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544947"><p>That depends on the flow chart language you use. The <a href="https://en.wikipedia.org/wiki/DRAKON" title="wikipedia.org">DRAKON</a> [wikipedia.org] language was designed to create extremely easy-to-read and highly modular flow charts.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544947">

</div>
</div>

<div id="replyto_54544947"></div>

<ul id="group_54544947">
	<li id="hiddens_54544947" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544671" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544671" class="commentstatus"></div>
<div id="comment_54544671" class="cw">
	<div id="comment_top_54544671" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544671" name="comment_link_54544671" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544671" onclick="return D2.setFocusComment(54544671)" >Educational kits</a>


		 	<span id="comment_score_54544671" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544671); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544671"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544671">Look at the US educational products that let users do things with a gui and even a robot kit.<br>
They often have a very simple gui system of getting input and presenting an output.<br>
I am not sure how much of the US educational product would allow for options other than following a set course structure.<br>
Often used so the whole class in a US educational setting can feel they are been educated about computers.<br>
A slow pace of education, not much maths, all about the gui and getting something done in a short time.<br>
O</div>
	</div>

	<div class="commentSub" id="comment_sub_54544671">

</div>
</div>

<div id="replyto_54544671"></div>

<ul id="group_54544671">
	<li id="hiddens_54544671" class="hide"></li>
</ul>

</li><li id="tree_54544677" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544677" class="commentstatus"></div>
<div id="comment_54544677" class="cw">
</div>

<div id="replyto_54544677"></div>

<ul id="group_54544677">
	<li id="hiddens_54544677" class="hide"></li>
</ul>

</li><li id="tree_54544679" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544679" class="commentstatus"></div>
<div id="comment_54544679" class="cw">
</div>

<div id="replyto_54544679"></div>

<ul id="group_54544679">
	<li id="hiddens_54544679" class="hide"></li>
</ul>

<ul id="commtree_54544679"><li id="tree_54545411" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545411" class="commentstatus"></div>
<div id="comment_54545411" class="cw">
	<div id="comment_top_54545411" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545411" name="comment_link_54545411" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545411" onclick="return D2.setFocusComment(54545411)" >Re:</a>


		 	<span id="comment_score_54545411" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545411); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545411"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545411"><p>Technology Pega is a Business Process Management system.<br>Good for the scope that it is in.  But would get cumbersome when things get too complex where you need to edit the Java code for the stuff that is out of its bounds.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545411">

</div>
</div>

<div id="replyto_54545411"></div>

<ul id="group_54545411">
	<li id="hiddens_54545411" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544687" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544687" class="commentstatus"></div>
<div id="comment_54544687" class="cw">
	<div id="comment_top_54544687" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544687" name="comment_link_54544687" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544687" onclick="return D2.setFocusComment(54544687)" >AmigaVISION? Labview?</a>


		 	<span id="comment_score_54544687" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544687); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~50000BTU_barbecue">50000BTU_barbecue</a>  <span class="uid"><a href="//slashdot.org/~50000BTU_barbecue">( 588132 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544687"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544687"><p>There's a reason people don't<nobr> <wbr></nobr>.... It's terrible. LabView is a mess, and AmigaVISION was charming<nobr> <wbr></nobr>... 25 years ago.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544687">

</div>
</div>

<div id="replyto_54544687"></div>

<ul id="group_54544687">
	<li id="hiddens_54544687" class="hide"></li>
</ul>

</li><li id="tree_54544689" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544689" class="commentstatus"></div>
<div id="comment_54544689" class="cw">
	<div id="comment_top_54544689" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544689" name="comment_link_54544689" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544689" onclick="return D2.setFocusComment(54544689)" >Automate</a>


		 	<span id="comment_score_54544689" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544689); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dialecticus">Dialecticus</a>  <span class="uid"><a href="//slashdot.org/~Dialecticus">( 1433989 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544689">		
		on Sunday June 04, 2017 @01:12AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544689">#54544689</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544689">My favorite is called <a href="http://llamalab.com/automate/" title="llamalab.com">Automate by LlamaLab.</a> [llamalab.com]</div>
	</div>

	<div class="commentSub" id="comment_sub_54544689">
<span class="ind"></span><a id="reply_link_54544689" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544689" onclick="D2.replyTo(54544689); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Automate by Dialecticus @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544689" data-title="Automate">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Automate by Dialecticus" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544689" data-title="Automate">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Automate by Dialecticus" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544689" data-title="Automate">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544689" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544689" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544689" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544689"></div>

<ul id="group_54544689">
	<li id="hiddens_54544689" class="hide"></li>
</ul>

</li><li id="tree_54544691" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544691" class="commentstatus"></div>
<div id="comment_54544691" class="cw">
	<div id="comment_top_54544691" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544691" name="comment_link_54544691" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544691" onclick="return D2.setFocusComment(54544691)" >Wikipedia has a category 'Visual programming </a>


		 	<span id="comment_score_54544691" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544691); return false"><span class=opt>Score:</span>2</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544691"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544691"><p><a href="https://en.wikipedia.org/wiki/Category:Visual_programming_languages" title="wikipedia.org" rel="nofollow">Category:Visual programming languages</a> [wikipedia.org]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544691">

</div>
</div>

<div id="replyto_54544691"></div>

<ul id="group_54544691">
	<li id="hiddens_54544691" class="hide"></li>
</ul>

<ul id="commtree_54544691"><li id="tree_54544849" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544849" class="commentstatus"></div>
<div id="comment_54544849" class="cw">
	<div id="comment_top_54544849" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544849" name="comment_link_54544849" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544849" onclick="return D2.setFocusComment(54544849)" >Re:</a>


		 	<span id="comment_score_54544849" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544849); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~michael.karl.coleman">Michael Coleman</a> <span class="socialbadge"><a class="g" href="#" title="From Google"></a></span> <span class="uid"><a href="//slashdot.org/~michael.karl.coleman">( 4288707 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544849"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544849"><p>These were noble experiments, but none are useful for practical programming, AFAIK.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544849">

</div>
</div>

<div id="replyto_54544849"></div>

<ul id="group_54544849">
	<li id="hiddens_54544849" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544701" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544701" class="commentstatus"></div>
<div id="comment_54544701" class="cw">
</div>

<div id="replyto_54544701"></div>

<ul id="group_54544701">
	<li id="hiddens_54544701" class="hide"></li>
</ul>

</li><li id="tree_54544703" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544703" class="commentstatus"></div>
<div id="comment_54544703" class="cw">
	<div id="comment_top_54544703" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544703" name="comment_link_54544703" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544703" onclick="return D2.setFocusComment(54544703)" >Absolutely, but</a>


		 	<span id="comment_score_54544703" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544703); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phrobot">phrobot</a>  <span class="uid"><a href="//slashdot.org/~phrobot">( 877647 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544703"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544703">For trivial academic problems that nobody really cares about, yes.
For hard problems in real world situations that real people care about paying money for, no.
UML and its kind are good for documenting a simplified slice of a complex system so engineers can understand the requirements and  start writing real code. But to be precise enough to generate code, well, you might as well just write code.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544703">

</div>
</div>

<div id="replyto_54544703"></div>

<ul id="group_54544703">
	<li id="hiddens_54544703" class="hide"></li>
</ul>

<ul id="commtree_54544703"><li id="tree_54544739" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544739" class="commentstatus"></div>
<div id="comment_54544739" class="cw">
	<div id="comment_top_54544739" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544739" name="comment_link_54544739" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544739" onclick="return D2.setFocusComment(54544739)" >Re:</a>


		 	<span id="comment_score_54544739" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544739); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544739"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544739"><p>UML is useful to identify which objects you are working with in the code but it's not good to describe the information flow in a system.</p><p>The worst problem with UML is that it also can tie together objects with each other - or even worse, create objects - that from a superficial glance seems to be related but when you look at the information flow you see that the only thing they have in common is that they are related from a very specific perspective, much like two stars that looks close to each other from th<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544739">

</div>
</div>

<div id="replyto_54544739"></div>

<ul id="group_54544739">
	<li id="hiddens_54544739" class="hide"></li>
</ul>

</li><li id="tree_54544915" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544915" class="commentstatus"></div>
<div id="comment_54544915" class="cw">
	<div id="comment_top_54544915" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544915" name="comment_link_54544915" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544915" onclick="return D2.setFocusComment(54544915)" >Re:</a>


		 	<span id="comment_score_54544915" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544915); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rudi.angela">Rudi Angela</a>  <span class="uid"><a href="//slashdot.org/~rudi.angela">( 4981837 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544915"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544915">Well, FYI, I've used Prograph to tackle real world problems exactly twenty years ago. In those days I wrote a web application framework, comparable to PHP, but with advanced features like thread pooling, database connection pooling. Unlike PHP, the modules were compiled. This was all running on MacOS and Windows. Though this was cutting edge in those days, there was nothing academic to it as it was purely driven by business needs. Though I'm still actively developing server side web applications (now in Jav</div>
	</div>

	<div class="commentSub" id="comment_sub_54544915">

</div>
</div>

<div id="replyto_54544915"></div>

<ul id="group_54544915">
	<li id="hiddens_54544915" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544713" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544713" class="commentstatus"></div>
<div id="comment_54544713" class="cw">
</div>

<div id="replyto_54544713"></div>

<ul id="group_54544713">
	<li id="hiddens_54544713" class="hide"></li>
</ul>

<ul id="commtree_54544713"><li id="tree_54544769" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544769" class="commentstatus"></div>
<div id="comment_54544769" class="cw">
	<div id="comment_top_54544769" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544769" name="comment_link_54544769" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544769" onclick="return D2.setFocusComment(54544769)" >Re:</a>


		 	<span id="comment_score_54544769" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544769); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544769"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544769"><p>Which leads to the case that people have a hard time to break down a problem into components that are easy to maintain and test.</p><p>But in many solutions there's also the problem that those that codes don't even understand or know the environment the system is going to be used in. Like the fact that there's sometimes icy roads - explain that to a person in Bangalore where the only place you see ice is in drinks.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544769">

</div>
</div>

<div id="replyto_54544769"></div>

<ul id="group_54544769">
	<li id="hiddens_54544769" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544721" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544721" class="commentstatus"></div>
<div id="comment_54544721" class="cw">
	<div id="comment_top_54544721" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544721" name="comment_link_54544721" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544721" onclick="return D2.setFocusComment(54544721)" >PureData</a>


		 	<span id="comment_score_54544721" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544721); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jblues">jblues</a>  <span class="uid"><a href="//slashdot.org/~jblues">( 1703158 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544721"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544721">They're not flow-charts, but the <a href="https://puredata.info/" title="puredata.info">PureData</a> [puredata.info] programming language is provides executable diagrams. Pure Data (or just 'Pd') is an open source visual programming language for multimedia. Its main distribution (aka 'Pd Vanilla') is developed by Miller Puckette. Pd-L2ork/Purr-Data is an alternative distribution (originally based on the now unmaintained Pd-Extended project), with a revamped GUI and many included external libraries.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544721">

</div>
</div>

<div id="replyto_54544721"></div>

<ul id="group_54544721">
	<li id="hiddens_54544721" class="hide"></li>
</ul>

<ul id="commtree_54544721"><li id="tree_54544779" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544779" class="commentstatus"></div>
<div id="comment_54544779" class="cw">
	<div id="comment_top_54544779" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544779" name="comment_link_54544779" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544779" onclick="return D2.setFocusComment(54544779)" >Re:</a>


		 	<span id="comment_score_54544779" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544779); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mkendall">mkendall</a>  <span class="uid"><a href="//slashdot.org/~mkendall">( 69179 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544779"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544779"><p>I think pd, like LabVIEW, primarily shows the flow of data, not execution. They are data-flow diagrams, not flow charts in the traditional sense.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544779">

</div>
</div>

<div id="replyto_54544779"></div>

<ul id="group_54544779">
	<li id="hiddens_54544779" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544723" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544723" class="commentstatus"></div>
<div id="comment_54544723" class="cw">
</div>

<div id="replyto_54544723"></div>

<ul id="group_54544723">
	<li id="hiddens_54544723" class="hide"></li>
</ul>

<ul id="commtree_54544723"><li id="tree_54544737" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544737" class="commentstatus"></div>
<div id="comment_54544737" class="cw">
</div>

<div id="replyto_54544737"></div>

<ul id="group_54544737">
	<li id="hiddens_54544737" class="hide"></li>
</ul>

<ul id="commtree_54544737"><li id="tree_54544805" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544805" class="commentstatus"></div>
<div id="comment_54544805" class="cw">
	<div id="comment_top_54544805" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544805" name="comment_link_54544805" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544805" onclick="return D2.setFocusComment(54544805)" >Re:</a>


		 	<span id="comment_score_54544805" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544805); return false"><span class=opt>Score:</span>2</a>, Troll)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucm">lucm</a>  <span class="uid"><a href="//slashdot.org/~lucm">( 889690 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544805"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544805"><p>If you think conservatives are the best at selling out, you probably need to learn more about Bill and Hillary Clinton.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544805">

</div>
</div>

<div id="replyto_54544805"></div>

<ul id="group_54544805">
	<li id="hiddens_54544805" class="hide"></li>
</ul>

<ul id="commtree_54544805"><li id="tree_54544973" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544973" class="commentstatus"></div>
<div id="comment_54544973" class="cw">
	<div id="comment_top_54544973" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544973" name="comment_link_54544973" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544973" onclick="return D2.setFocusComment(54544973)" >Re:</a>


		 	<span id="comment_score_54544973" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544973); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dbIII">dbIII</a>  <span class="uid"><a href="//slashdot.org/~dbIII">( 701233 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544973"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544973">If you think they were not conservatives then you have a lot to learn about politics.<br>What Christopher Hitchens wrote about Bill Clinton is a good start.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544973">

</div>
</div>

<div id="replyto_54544973"></div>

<ul id="group_54544973">
	<li id="hiddens_54544973" class="hide"></li>
</ul>

<ul id="commtree_54544973"><li id="tree_54545291" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54545291" class="commentstatus"></div>
<div id="comment_54545291" class="cw">
</div>

<div id="replyto_54545291"></div>

<ul id="group_54545291">
	<li id="hiddens_54545291" class="hide"></li>
</ul>

<ul id="commtree_54545291"><li id="tree_54545875" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545875" class="commentstatus"></div>
<div id="comment_54545875" class="cw">
	<div id="comment_top_54545875" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545875" name="comment_link_54545875" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545875" onclick="return D2.setFocusComment(54545875)" >Re:</a>


		 	<span id="comment_score_54545875" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545875); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dbIII">dbIII</a>  <span class="uid"><a href="//slashdot.org/~dbIII">( 701233 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545875"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545875"><blockquote><div><p>But that's equivocation: You are not using "conservative" in the same sense that the earlier commenter did.</p></div></blockquote><p>Incorrect.  Spectacularly so.  There is hardly anything less conservative than a family that has made politics it's profession of choice for more than a century.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545875">

</div>
</div>

<div id="replyto_54545875"></div>

<ul id="group_54545875">
	<li id="hiddens_54545875" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="hidestring_54544723"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54544723">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54544741" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544741" class="commentstatus"></div>
<div id="comment_54544741" class="cw">
	<div id="comment_top_54544741" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544741" name="comment_link_54544741" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544741" onclick="return D2.setFocusComment(54544741)" >Time marches on</a>


		 	<span id="comment_score_54544741" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544741); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Waffle+Iron">Waffle Iron</a>  <span class="uid"><a href="//slashdot.org/~Waffle+Iron">( 339739 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544741">		
		on Sunday June 04, 2017 @01:33AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544741">#54544741</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544741"><p>When I was first taught to code in FORTRAN, we were told that we really needed to create a flow chart detailing every statement before writing any code. We also needed to start every line in column 8, and variable types were determined by the first letter of their name.</p><p>Those days are long gone, and we now have languages with features that allow us to directly transcribe our ideas without intermediate formats (yes, LISP always allowed that from day 1, yada yada).</p><p>I find that flow charts  still have some usefulness on occasion, but only as a high-level planning tool. I will sometimes write up a flow chart with a dozen boxes to define the rough flow of a complex algorithm, but it might take a thousand lines of code to actually complete the final implementation. A flow chart that had enough detail to mechanically translate to code would look like an incomprehensible pile of spaghetti; not very useful compared to well-formated code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544741">
<span class="ind"></span><a id="reply_link_54544741" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544741" onclick="D2.replyTo(54544741); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Time marches on by Waffle Iron @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544741" data-title="Time marches on">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Time marches on by Waffle Iron" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544741" data-title="Time marches on">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Time marches on by Waffle Iron" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544741" data-title="Time marches on">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544741" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544741" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544741" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544741"></div>

<ul id="group_54544741">
	<li id="hiddens_54544741" class="hide"></li>
</ul>

<ul id="commtree_54544741"><li id="tree_54544761" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544761" class="commentstatus"></div>
<div id="comment_54544761" class="cw">
	<div id="comment_top_54544761" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544761" name="comment_link_54544761" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544761" onclick="return D2.setFocusComment(54544761)" >Re:</a>


		 	<span id="comment_score_54544761" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544761); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~93+Escort+Wagon">93 Escort Wagon</a>  <span class="uid"><a href="//slashdot.org/~93+Escort+Wagon">( 326346 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544761"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544761"><p><div class="quote"><p>When I was first taught to code in FORTRAN, we were told that we really needed to create a flow chart detailing every statement before writing any code. We also needed to start every line in column 8, and variable types were determined by the first letter of their name.</p></div><p>1) They <i>said</i> that, but no one I knew actually did it.</p><p>2) Column 7, not 8.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544761">

</div>
</div>

<div id="replyto_54544761"></div>

<ul id="group_54544761">
	<li id="hiddens_54544761" class="hide"></li>
</ul>

<ul id="commtree_54544761"><li id="tree_54544809" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544809" class="commentstatus"></div>
<div id="comment_54544809" class="cw">
	<div id="comment_top_54544809" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544809" name="comment_link_54544809" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544809" onclick="return D2.setFocusComment(54544809)" >Re:</a>


		 	<span id="comment_score_54544809" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544809); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Waffle+Iron">Waffle Iron</a>  <span class="uid"><a href="//slashdot.org/~Waffle+Iron">( 339739 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544809"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544809"><p>Well, it seems that decades of controversy over 4 vs 8 spaces for indents has completely overridden my memory on that point.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544809">

</div>
</div>

<div id="replyto_54544809"></div>

<ul id="group_54544809">
	<li id="hiddens_54544809" class="hide"></li>
</ul>

<ul id="commtree_54544809"><li id="tree_54545025" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545025" class="commentstatus"></div>
<div id="comment_54545025" class="cw">
	<div id="comment_top_54545025" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545025" name="comment_link_54545025" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545025" onclick="return D2.setFocusComment(54545025)" >Re:</a>


		 	<span id="comment_score_54545025" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545025); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~93+Escort+Wagon">93 Escort Wagon</a>  <span class="uid"><a href="//slashdot.org/~93+Escort+Wagon">( 326346 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545025"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545025"><p>It's possible I was just a bad coder, but it was not particularly uncommon for at least one line in my Fortran programs to need more than 65 characters. So I got really familiar with columns 6 and 7.</p><p>For those who aren't old - column 6 was used as a continuation flag. If there was something in column six, what followed was a continuation of the previous line. I *think* the convention was to use numbers in there which basically indicated how many lines that particular statement used.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545025">

</div>
</div>

<div id="replyto_54545025"></div>

<ul id="group_54545025">
	<li id="hiddens_54545025" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544943" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544943" class="commentstatus"></div>
<div id="comment_54544943" class="cw">
	<div id="comment_top_54544943" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544943" name="comment_link_54544943" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544943" onclick="return D2.setFocusComment(54544943)" >Flow charts and Fortran coding forms ...</a>


		 	<span id="comment_score_54544943" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544943); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~perpenso">perpenso</a>  <span class="uid"><a href="//slashdot.org/~perpenso">( 1613749 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544943"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544943"><p><div class="quote"><p><div class="quote"><p>When I was first taught to code in FORTRAN, we were told that we really needed to create a flow chart detailing every statement before writing any code. We also needed to start every line in column 8, and variable types were determined by the first letter of their name.</p></div><p>1) They <i>said</i> that, but no one I knew actually did it.</p></div><p>Well there was that first programming assignment in CS 101 Introduction to Computer Science where one did a flow chart (neatly using a plastic template), then wrote (as in pencil on paper) code on a Fortran Coding Form (graph paper like showing the important columns), and then after manually stepping through the code (simulating it) to debug it one typed the code on the punch card machine, submitted the punched card deck, and waited for a printout to be delivered to see if it compiled and ran and generated<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544943">

</div>
</div>

<div id="replyto_54544943"></div>

<ul id="group_54544943">
	<li id="hiddens_54544943" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544979" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544979" class="commentstatus"></div>
<div id="comment_54544979" class="cw">
	<div id="comment_top_54544979" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544979" name="comment_link_54544979" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544979" onclick="return D2.setFocusComment(54544979)" >Re:</a>


		 	<span id="comment_score_54544979" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544979); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dbIII">dbIII</a>  <span class="uid"><a href="//slashdot.org/~dbIII">( 701233 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544979"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544979">Yes, it's a teaching tool.<br>You only use those methods when they kount<nobr> <wbr></nobr>:)</div>
	</div>

	<div class="commentSub" id="comment_sub_54544979">

</div>
</div>

<div id="replyto_54544979"></div>

<ul id="group_54544979">
	<li id="hiddens_54544979" class="hide"></li>
</ul>

</li><li id="tree_54545057" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545057" class="commentstatus"></div>
<div id="comment_54545057" class="cw">
	<div id="comment_top_54545057" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545057" name="comment_link_54545057" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545057" onclick="return D2.setFocusComment(54545057)" >Re:</a>


		 	<span id="comment_score_54545057" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545057); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Nutria">Nutria</a>  <span class="uid"><a href="//slashdot.org/~Nutria">( 679911 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545057"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545057"><p><div class="quote"><p>When I was first taught to code in FORTRAN, we were told that we really needed to create a flow chart detailing every statement before writing any code.</p></div><p>Well, flowcharts <b>are</b> useful -- damned useful, in fact -- <b>when you have to type punch cards!</b> </p><p><div class="quote"><p>Those days are long gone, and we now have languages with features that allow us to directly transcribe our ideas without intermediate formats</p></div><p>Because of languages which developed at the same time that VDTs became common.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545057">

</div>
</div>

<div id="replyto_54545057"></div>

<ul id="group_54545057">
	<li id="hiddens_54545057" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544745" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544745" class="commentstatus"></div>
<div id="comment_54544745" class="cw">
	<div id="comment_top_54544745" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544745" name="comment_link_54544745" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544745" onclick="return D2.setFocusComment(54544745)" >Also</a>


		 	<span id="comment_score_54544745" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544745); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Reverend+Green">Reverend Green</a>  <span class="uid"><a href="//slashdot.org/~Reverend+Green">( 4973045 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544745"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544745"><p>Does anyone know of a tool that will allow me to write a novel by scribbling with crayons in a coloring book?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544745">

</div>
</div>

<div id="replyto_54544745"></div>

<ul id="group_54544745">
	<li id="hiddens_54544745" class="hide"></li>
</ul>

<ul id="commtree_54544745"><li id="tree_54544789" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544789" class="commentstatus"></div>
<div id="comment_54544789" class="cw">
</div>

<div id="replyto_54544789"></div>

<ul id="group_54544789">
	<li id="hiddens_54544789" class="hide"></li>
</ul>

</li><li id="hidestring_54544745"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54544745">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54544751" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544751" class="commentstatus"></div>
<div id="comment_54544751" class="cw">
</div>

<div id="replyto_54544751"></div>

<ul id="group_54544751">
	<li id="hiddens_54544751" class="hide"></li>
</ul>

</li><li id="tree_54544757" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544757" class="commentstatus"></div>
<div id="comment_54544757" class="cw">
	<div id="comment_top_54544757" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544757" name="comment_link_54544757" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544757" onclick="return D2.setFocusComment(54544757)" >Somewhat</a>


		 	<span id="comment_score_54544757" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544757); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~udachny">udachny</a>  <span class="uid"><a href="//slashdot.org/~udachny">( 2454394 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544757"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544757"><p>Don't ask me how I know about this, but <a href="https://docs.oracle.com/cd/E13214_01/wli/docs81/overview/1intro.html" title="oracle.com" rel="nofollow"> weblogic (now oracle) process integration ide</a> [oracle.com] allows some code to be generated from flowcharts.   It is horrendous code and the usefulness of what it can do is very low, but it can do some of it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544757">

</div>
</div>

<div id="replyto_54544757"></div>

<ul id="group_54544757">
	<li id="hiddens_54544757" class="hide"></li>
</ul>

</li><li id="tree_54544767" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544767" class="commentstatus"></div>
<div id="comment_54544767" class="cw">
	<div id="comment_top_54544767" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544767" name="comment_link_54544767" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544767" onclick="return D2.setFocusComment(54544767)" >Isn't that circuits?</a>


		 	<span id="comment_score_54544767" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544767); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RyanFenton">RyanFenton</a>  <span class="uid"><a href="//slashdot.org/~RyanFenton">( 230700 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544767"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544767"><p>All higher level logic ends up having side effects, just in order to be convenient, and relevant the way we use analogies/language.</p><p>You'd end up with even bigger problems with flow charts, because the labels you'd add would end up confounding your expectations as you build more and more.</p><p>The only way to avoid that is using very simple concepts in your flow chart.  At that points, you're just creating circuits, which are not just below regular code, but below even assembly code in terms of the layers of abstra<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544767">

</div>
</div>

<div id="replyto_54544767"></div>

<ul id="group_54544767">
	<li id="hiddens_54544767" class="hide"></li>
</ul>

<ul id="commtree_54544767"><li id="tree_54545287" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545287" class="commentstatus"></div>
<div id="comment_54545287" class="cw">
	<div id="comment_top_54545287" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545287" name="comment_link_54545287" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545287" onclick="return D2.setFocusComment(54545287)" >Re:</a>


		 	<span id="comment_score_54545287" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545287); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gtall">gtall</a>  <span class="uid"><a href="//slashdot.org/~gtall">( 79522 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545287"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545287"><p>To some extent, what you say might be true. But I am not convinced that it is theoretically impossible to have a decent graphical language that does have higher order logical concepts. I don't believe functional programmers care or have the necessary subtlety in their thinking to accept diagrams for their stuff. That also one of the hurdles they have in pushing their religion. In a somewhat heretical book, Graham Hutton's Programming in Haskell does resort to diagrams to get his points across.</p><p>Marten (used t<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545287">

</div>
</div>

<div id="replyto_54545287"></div>

<ul id="group_54545287">
	<li id="hiddens_54545287" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544777" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544777" class="commentstatus"></div>
<div id="comment_54544777" class="cw">
</div>

<div id="replyto_54544777"></div>

<ul id="group_54544777">
	<li id="hiddens_54544777" class="hide"></li>
</ul>

</li><li id="tree_54544815" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544815" class="commentstatus"></div>
<div id="comment_54544815" class="cw">
	<div id="comment_top_54544815" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544815" name="comment_link_54544815" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544815" onclick="return D2.setFocusComment(54544815)" >That's not what you want</a>


		 	<span id="comment_score_54544815" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544815); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kohath">Kohath</a>  <span class="uid"><a href="//slashdot.org/~Kohath">( 38547 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544815"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544815"><p>Flow charts are no more expensive than code.  They just layer a visual syntax on top of the underlying forms instead of a textual syntax.</p><p>You should be asking for tools to command the underlying forms that don't require you to input all the syntax; tools where you can describe how you want something to work in broader terms and let the software write the syntax, handle the scheduling optimization, prevent the bugs and security holes, and make sure all the corner cases and failure modes are covered.</p><p>Where's th<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544815">

</div>
</div>

<div id="replyto_54544815"></div>

<ul id="group_54544815">
	<li id="hiddens_54544815" class="hide"></li>
</ul>

<ul id="commtree_54544815"><li id="tree_54544831" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544831" class="commentstatus"></div>
<div id="comment_54544831" class="cw">
	<div id="comment_top_54544831" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544831" name="comment_link_54544831" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544831" onclick="return D2.setFocusComment(54544831)" >Re:</a>


		 	<span id="comment_score_54544831" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544831); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kohath">Kohath</a>  <span class="uid"><a href="//slashdot.org/~Kohath">( 38547 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544831"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544831"><p>Also needed: an autocorrect that won't change "expressive" into "expensive".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544831">

</div>
</div>

<div id="replyto_54544831"></div>

<ul id="group_54544831">
	<li id="hiddens_54544831" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54544825" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544825" class="commentstatus"></div>
<div id="comment_54544825" class="cw">
	<div id="comment_top_54544825" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544825" name="comment_link_54544825" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544825" onclick="return D2.setFocusComment(54544825)" >EasyFlow from HavenTree</a>


		 	<span id="comment_score_54544825" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544825); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mnemotronic">mnemotronic</a>  <span class="uid"><a href="//slashdot.org/~mnemotronic">( 586021 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544825">		 &lt;<a href="mailto:mnemotronic.netscape%40net">mnemotronic.netscape@net</a>&gt;
		on Sunday June 04, 2017 @02:03AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544825">#54544825</a>)
		<small><a href="http://localhost:901/" title="http://localhost:901/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~mnemotronic/journal/" title="Thursday January 22, 2004 @08:13PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544825">I'm a visually oriented person.  For big-picture I can digest flowcharts and data diagrams easier than textual representations.  I routinely use Visio.  In the MSDOS days I used <a href="https://en.wikipedia.org/wiki/Interactive_EasyFlow" title="wikipedia.org">Interactive EasyFlow from HavenTree of Canada</a> [wikipedia.org].  The copyright notice / license agreement was worth the price of admission.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544825">
<span class="ind"></span><a id="reply_link_54544825" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544825" onclick="D2.replyTo(54544825); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="EasyFlow from HavenTree by mnemotronic @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544825" data-title="EasyFlow from HavenTree">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="EasyFlow from HavenTree by mnemotronic" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544825" data-title="EasyFlow from HavenTree">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="EasyFlow from HavenTree by mnemotronic" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544825" data-title="EasyFlow from HavenTree">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544825" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544825" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544825" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544825"></div>

<ul id="group_54544825">
	<li id="hiddens_54544825" class="hide"></li>
</ul>

</li><li id="tree_54544837" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544837" class="commentstatus"></div>
<div id="comment_54544837" class="cw">
</div>

<div id="replyto_54544837"></div>

<ul id="group_54544837">
	<li id="hiddens_54544837" class="hide"></li>
</ul>

</li><li id="tree_54544845" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544845" class="commentstatus"></div>
<div id="comment_54544845" class="cw">
	<div id="comment_top_54544845" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544845" name="comment_link_54544845" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544845" onclick="return D2.setFocusComment(54544845)" >Prograph by TGS Systems </a>


		 	<span id="comment_score_54544845" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544845); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rthille">rthille</a>  <span class="uid"><a href="//slashdot.org/~rthille">( 8526 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544845"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544845"><p><a href="https://en.m.wikipedia.org/wiki/Prograph" title="wikipedia.org">https://en.m.wikipedia.org/wik...</a> [wikipedia.org]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544845">

</div>
</div>

<div id="replyto_54544845"></div>

<ul id="group_54544845">
	<li id="hiddens_54544845" class="hide"></li>
</ul>

</li><li id="tree_54544871" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544871" class="commentstatus"></div>
<div id="comment_54544871" class="cw">
</div>

<div id="replyto_54544871"></div>

<ul id="group_54544871">
	<li id="hiddens_54544871" class="hide"></li>
</ul>

</li><li id="tree_54544885" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544885" class="commentstatus"></div>
<div id="comment_54544885" class="cw">
	<div id="comment_top_54544885" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544885" name="comment_link_54544885" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544885" onclick="return D2.setFocusComment(54544885)" >Diff</a>


		 	<span id="comment_score_54544885" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544885); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~romiz">romiz</a>  <span class="uid"><a href="//slashdot.org/~romiz">( 757548 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544885"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544885">A critical requirement when programming is the ability to compare different versions of the same code. This is quite easy to do with text. With diagrams, it becomes much harder to do.</div>
	</div>

	<div class="commentSub" id="comment_sub_54544885">

</div>
</div>

<div id="replyto_54544885"></div>

<ul id="group_54544885">
	<li id="hiddens_54544885" class="hide"></li>
</ul>

</li><li id="tree_54544889" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544889" class="commentstatus"></div>
<div id="comment_54544889" class="cw">
</div>

<div id="replyto_54544889"></div>

<ul id="group_54544889">
	<li id="hiddens_54544889" class="hide"></li>
</ul>

</li><li id="tree_54544919" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544919" class="commentstatus"></div>
<div id="comment_54544919" class="cw">
</div>

<div id="replyto_54544919"></div>

<ul id="group_54544919">
	<li id="hiddens_54544919" class="hide"></li>
</ul>

</li><li id="tree_54544941" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54544941" class="commentstatus"></div>
<div id="comment_54544941" class="cw">
	<div id="comment_top_54544941" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544941" name="comment_link_54544941" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544941" onclick="return D2.setFocusComment(54544941)" >DRAKON Editor is exactly what you asked</a>


		 	<span id="comment_score_54544941" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544941); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TuringTest">TuringTest</a>  <span class="uid"><a href="//slashdot.org/~TuringTest">( 533084 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544941">		
		on Sunday June 04, 2017 @03:01AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544941">#54544941</a>)
		<small><a href="//slashdot.org/~TuringTest/journal/" title="Sunday November 13, 2011 @05:21AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544941"><p>The open source <a href="http://drakon-editor.sourceforge.net/" title="sourceforge.net">DRAKON Editor</a> [sourceforge.net] allows you to draw classic flow charts and generate template code in various target languages that follow the defined flow.</p><p>It comes with the additional advantage of having been engineered around ergonomic practices, which makes it avoid the classic pitfalls of using flow charts. A flow diagram typically becomes a tangled mess, but DRAKON layout guidelines provide a structure to build diagrams in any scale.</p><p>The <a href="https://en.wikipedia.org/wiki/DRAKON" title="wikipedia.org">DRAKON</a> [wikipedia.org] language was created by people in the Russian space program as a way to avoid errors in defined procedures, and it was crafted and refined following the Russian school of Human-computer interaction. The flow diagrams built following their easy-to-learn layout guidelines are the most easy to read that I've ever seen.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544941">
<span class="ind"></span><a id="reply_link_54544941" class="btn link" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544941" onclick="D2.replyTo(54544941); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="DRAKON Editor is exactly what you asked by TuringTest @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544941" data-title="DRAKON Editor is exactly what you asked">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="DRAKON Editor is exactly what you asked by TuringTest" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544941" data-title="DRAKON Editor is exactly what you asked">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="DRAKON Editor is exactly what you asked by TuringTest" data-url="https://ask.slashdot.org/comments.pl?sid=10694299&cid=54544941" data-title="DRAKON Editor is exactly what you asked">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=10694299%26cid=54544941" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54544941" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54544941" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54544941"></div>

<ul id="group_54544941">
	<li id="hiddens_54544941" class="hide"></li>
</ul>

</li><li id="tree_54544989" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54544989" class="commentstatus"></div>
<div id="comment_54544989" class="cw">
	<div id="comment_top_54544989" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54544989" name="comment_link_54544989" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54544989" onclick="return D2.setFocusComment(54544989)" >There are such solutions for PLC programming</a>


		 	<span id="comment_score_54544989" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54544989); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54544989"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54544989"><p>IEC 61131-3 defines several graphical programming languages for PLC.</p><p><a href="https://en.wikipedia.org/wiki/IEC_61131-3" title="wikipedia.org" rel="nofollow">https://en.wikipedia.org/wiki/...</a> [wikipedia.org]</p><p>General purpose graphical programming language would be a major PITA. I cannot imagine anybody using it to write complex software.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54544989">

</div>
</div>

<div id="replyto_54544989"></div>

<ul id="group_54544989">
	<li id="hiddens_54544989" class="hide"></li>
</ul>

</li><li id="tree_54545055" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545055" class="commentstatus"></div>
<div id="comment_54545055" class="cw">
	<div id="comment_top_54545055" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545055" name="comment_link_54545055" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545055" onclick="return D2.setFocusComment(54545055)" >BluePrint and BPMN</a>


		 	<span id="comment_score_54545055" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545055); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SendBot">SendBot</a>  <span class="uid"><a href="//slashdot.org/~SendBot">( 29932 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545055"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545055"><p>First of all, Unreal Engine's blueprint system is quite excellent, but is also specific to its domain of being a game engine. But you can make your own blueprint modules in C++, so no reason you couldn't make boring business software with it.</p><p>But there's already a great tool for boring business workflow, and that's BPMN. I've recently discovered it and it's so much better than endless meetings where no one knows or can agree about what is fully going on. I only have experience using it to model software at a<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545055">

</div>
</div>

<div id="replyto_54545055"></div>

<ul id="group_54545055">
	<li id="hiddens_54545055" class="hide"></li>
</ul>

</li><li id="tree_54545059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545059" class="commentstatus"></div>
<div id="comment_54545059" class="cw">
	<div id="comment_top_54545059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545059" name="comment_link_54545059" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545059" onclick="return D2.setFocusComment(54545059)" >Flowcode for Microcontrollers</a>


		 	<span id="comment_score_54545059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545059); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Vapula">Vapula</a>  <span class="uid"><a href="//slashdot.org/~Vapula">( 14703 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545059"><p>There is a Developper engine called "Flowcode" which allows to do programs for microcontrollers (PIC,  AVR, ARM) using flowcharts. It's quite expensive (given that PIC/AVR dev tools are free).</p><p>Basically, you've some "macro" blocks for  more high level functions (like displaying on an LCD screen),  rest is flowcharts.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545059">

</div>
</div>

<div id="replyto_54545059"></div>

<ul id="group_54545059">
	<li id="hiddens_54545059" class="hide"></li>
</ul>

</li><li id="tree_54545179" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545179" class="commentstatus"></div>
<div id="comment_54545179" class="cw">
	<div id="comment_top_54545179" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545179" name="comment_link_54545179" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545179" onclick="return D2.setFocusComment(54545179)" >Authorware was like this</a>


		 	<span id="comment_score_54545179" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545179); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Camembert">Camembert</a>  <span class="uid"><a href="//slashdot.org/~Camembert">( 2891457 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545179"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545179">Early in my career, 1992 onwards, I made multimedia (when that was still a cool new thing!) training and presentations in Macromedia Authorware which largely followed a flowchart metaphor - the idea being that it would help non-programmer content specialists to make multimedia training. There was some bigger power under the hood since you could add pascal like scripts to the icons. Very unfortunately the scripting language didn't support functions and procedures, you had to go to the icons flow for that.<br>Sti</div>
	</div>

	<div class="commentSub" id="comment_sub_54545179">

</div>
</div>

<div id="replyto_54545179"></div>

<ul id="group_54545179">
	<li id="hiddens_54545179" class="hide"></li>
</ul>

</li><li id="tree_54545225" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545225" class="commentstatus"></div>
<div id="comment_54545225" class="cw">
	<div id="comment_top_54545225" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545225" name="comment_link_54545225" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545225" onclick="return D2.setFocusComment(54545225)" >Yes. But regular code is often easyer.</a>


		 	<span id="comment_score_54545225" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545225); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Qbertino">Qbertino</a>  <span class="uid"><a href="//slashdot.org/~Qbertino">( 265505 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545225"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545225"><p>Yes there is. It's called CASE* and/or BPM* and/or DMI*. (Computer Aided System Engineering / Business Process Modelling / Direct Manipulation Interface).</p><p>The Problem with many of these Systems is that writing code often is quicker and easyer. There are special scenarios where the tool mentioned above can be used and are extremely effective (well-built cleanroom ERP setups, cleanroom UI toolkits (end-to-end Visual Basic (guess why it's called visual), Glade, QTCreator, JBoss BPM, Flash IDE, Squeak, etc.). Sy<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545225">

</div>
</div>

<div id="replyto_54545225"></div>

<ul id="group_54545225">
	<li id="hiddens_54545225" class="hide"></li>
</ul>

</li><li id="tree_54545245" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545245" class="commentstatus"></div>
<div id="comment_54545245" class="cw">
	<div id="comment_top_54545245" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545245" name="comment_link_54545245" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545245" onclick="return D2.setFocusComment(54545245)" >Why?</a>


		 	<span id="comment_score_54545245" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545245); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~allo">allo</a>  <span class="uid"><a href="//slashdot.org/~allo">( 1728082 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545245"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545245"><p>When you finally have the language, you will realize that the hard part is not the syntax, but the logic. And that dragging boxes is way slower than writing keywords.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545245">

</div>
</div>

<div id="replyto_54545245"></div>

<ul id="group_54545245">
	<li id="hiddens_54545245" class="hide"></li>
</ul>

</li><li id="tree_54545261" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545261" class="commentstatus"></div>
<div id="comment_54545261" class="cw">
	<div id="comment_top_54545261" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545261" name="comment_link_54545261" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545261" onclick="return D2.setFocusComment(54545261)" >Submitter is clearly 12 years old</a>


		 	<span id="comment_score_54545261" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545261); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hognoxious">Hognoxious</a>  <span class="uid"><a href="//slashdot.org/~Hognoxious">( 631665 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545261"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545261"><p>This stuff has been around since the 1990s if not before.  I didn't use it but around that time some of the guys in my office used <i>Excelerator</i>.  They didn't like it much.</p><p>Clarification: are you asking if something does it, or if something does it better than a monkey could code it longhand?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545261">

</div>
</div>

<div id="replyto_54545261"></div>

<ul id="group_54545261">
	<li id="hiddens_54545261" class="hide"></li>
</ul>

</li><li id="tree_54545345" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545345" class="commentstatus"></div>
<div id="comment_54545345" class="cw">
	<div id="comment_top_54545345" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545345" name="comment_link_54545345" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545345" onclick="return D2.setFocusComment(54545345)" >There is a reason it did not catch on</a>


		 	<span id="comment_score_54545345" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545345); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Gabest">Gabest</a>  <span class="uid"><a href="//slashdot.org/~Gabest">( 852807 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545345"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545345">I don't know the reason, but there is one, and it must be a pretty good one. That is enough proof for me.</div>
	</div>

	<div class="commentSub" id="comment_sub_54545345">

</div>
</div>

<div id="replyto_54545345"></div>

<ul id="group_54545345">
	<li id="hiddens_54545345" class="hide"></li>
</ul>

</li><li id="tree_54545421" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545421" class="commentstatus"></div>
<div id="comment_54545421" class="cw">
	<div id="comment_top_54545421" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545421" name="comment_link_54545421" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545421" onclick="return D2.setFocusComment(54545421)" >Huh?</a>


		 	<span id="comment_score_54545421" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545421); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Brett+Buck">Brett Buck</a>  <span class="uid"><a href="//slashdot.org/~Brett+Buck">( 811747 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545421"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545421"><p>Only for the last 30 years. And far more complex items than simple logic, fiendishly complex systems can be quickly generated from controls block diagrams using packages like SIMULINK, Many times, its too fiendishly complex to use in an end-item but certainly for simuations it can be very effective, It also has endless frustrating bugs, but that's not inherent in the concept.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545421">

</div>
</div>

<div id="replyto_54545421"></div>

<ul id="group_54545421">
	<li id="hiddens_54545421" class="hide"></li>
</ul>

</li><li id="tree_54545431" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545431" class="commentstatus"></div>
<div id="comment_54545431" class="cw">
	<div id="comment_top_54545431" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545431" name="comment_link_54545431" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545431" onclick="return D2.setFocusComment(54545431)" >Yes. MacOS Automator, Xcode, and most game engines</a>


		 	<span id="comment_score_54545431" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545431); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheOuterLinux">TheOuterLinux</a>  <span class="uid"><a href="//slashdot.org/~TheOuterLinux">( 4778741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545431"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545431">It's a drag and drop environment with lots of options and the more software installed, the more options. So, that technically means you can't make an "automation" without hoping that the other person has the same applications. But, as long as you use what comes with a Mac by default, you'd be alright. Xcode developed software can be all drag and drop. There are some other "drag and drop" related software that are game engine related like Game Maker (Game Editor for open source clone), Unity3D, and Unreal En</div>
	</div>

	<div class="commentSub" id="comment_sub_54545431">

</div>
</div>

<div id="replyto_54545431"></div>

<ul id="group_54545431">
	<li id="hiddens_54545431" class="hide"></li>
</ul>

<ul id="commtree_54545431"><li id="tree_54545685" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545685" class="commentstatus"></div>
<div id="comment_54545685" class="cw">
	<div id="comment_top_54545685" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545685" name="comment_link_54545685" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545685" onclick="return D2.setFocusComment(54545685)" >Re:</a>


		 	<span id="comment_score_54545685" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545685); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheOuterLinux">TheOuterLinux</a>  <span class="uid"><a href="//slashdot.org/~TheOuterLinux">( 4778741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545685"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545685">Scratch from MIT might be what you're looking for too. <a href="https://scratch.mit.edu/" title="mit.edu">https://scratch.mit.edu/</a> [mit.edu]</div>
	</div>

	<div class="commentSub" id="comment_sub_54545685">

</div>
</div>

<div id="replyto_54545685"></div>

<ul id="group_54545685">
	<li id="hiddens_54545685" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54545481" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545481" class="commentstatus"></div>
<div id="comment_54545481" class="cw">
	<div id="comment_top_54545481" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545481" name="comment_link_54545481" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545481" onclick="return D2.setFocusComment(54545481)" >Agilent VEE</a>


		 	<span id="comment_score_54545481" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545481); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AndyKron">AndyKron</a>  <span class="uid"><a href="//slashdot.org/~AndyKron">( 937105 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545481"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545481">Agilent VEE is pretty close to top-down flow charts. I've used it for years. Mainly used for test and measurement like Labview</div>
	</div>

	<div class="commentSub" id="comment_sub_54545481">

</div>
</div>

<div id="replyto_54545481"></div>

<ul id="group_54545481">
	<li id="hiddens_54545481" class="hide"></li>
</ul>

</li><li id="tree_54545635" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545635" class="commentstatus"></div>
<div id="comment_54545635" class="cw">
	<div id="comment_top_54545635" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545635" name="comment_link_54545635" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545635" onclick="return D2.setFocusComment(54545635)" >for kids: SCRATCH, on the grey suit world: SAP</a>


		 	<span id="comment_score_54545635" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545635); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aod7br7932">Andre Dias</a> <span class="socialbadge"><a class="g" href="#" title="From Google"></a></span> <span class="uid"><a href="//slashdot.org/~aod7br7932">( 3819801 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545635"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545635">scratch: <a href="https://scratch.mit.edu/" title="mit.edu" rel="nofollow">https://scratch.mit.edu/</a> [mit.edu]

I once saw a person designing a SAP (https://www.sap.com/index.html) system connecting modules with graphical arrows, you only needed to write code if specific details were needed.</div>
	</div>

	<div class="commentSub" id="comment_sub_54545635">

</div>
</div>

<div id="replyto_54545635"></div>

<ul id="group_54545635">
	<li id="hiddens_54545635" class="hide"></li>
</ul>

</li><li id="tree_54545643" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545643" class="commentstatus"></div>
<div id="comment_54545643" class="cw">
	<div id="comment_top_54545643" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545643" name="comment_link_54545643" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545643" onclick="return D2.setFocusComment(54545643)" >JBoss Tools Integration Stack</a>


		 	<span id="comment_score_54545643" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545643); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NetFusion">NetFusion</a>  <span class="uid"><a href="//slashdot.org/~NetFusion">( 86828 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545643"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545643"><p>There are quite a few JBoss based tools that will let you do this and then auto deploy the app on tomcat etc</p><p><span class="substr"> </span> <a href="https://tools.jboss.org/features/apachecamel.html" title="jboss.org">https://tools.jboss.org/featur...</a> [jboss.org] <br> <a href="https://tools.jboss.org/features/bpel.html" title="jboss.org">https://tools.jboss.org/featur...</a> [jboss.org] <br> <a href="https://tools.jboss.org/features/bpmn2.html" title="jboss.org">https://tools.jboss.org/featur...</a> [jboss.org] <br> <a href="https://tools.jboss.org/features/drools.html" title="jboss.org">https://tools.jboss.org/featur...</a> [jboss.org] <br> <a href="https://tools.jboss.org/features/jbpm.html" title="jboss.org">https://tools.jboss.org/featur...</a> [jboss.org] <br>etc</p><p>I use JBoss rules visual flowcharts editors for tweaking and testing a prek-12 vaccine compliance engine.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545643">

</div>
</div>

<div id="replyto_54545643"></div>

<ul id="group_54545643">
	<li id="hiddens_54545643" class="hide"></li>
</ul>

</li><li id="tree_54545645" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545645" class="commentstatus"></div>
<div id="comment_54545645" class="cw">
	<div id="comment_top_54545645" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545645" name="comment_link_54545645" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545645" onclick="return D2.setFocusComment(54545645)" >Scratch?</a>


		 	<span id="comment_score_54545645" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545645); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MMC+Monster">MMC Monster</a>  <span class="uid"><a href="//slashdot.org/~MMC+Monster">( 602931 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545645"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545645"><p>I think scratch is a flow chart-y language.  Certainly is colorful.</p><p>Of course, I wouldn't do anything serious in it.  It's just a nice way to introduce a pre-teen to flow control and language basics.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54545645">

</div>
</div>

<div id="replyto_54545645"></div>

<ul id="group_54545645">
	<li id="hiddens_54545645" class="hide"></li>
</ul>

</li><li id="tree_54545933" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545933" class="commentstatus"></div>
<div id="comment_54545933" class="cw">
	<div id="comment_top_54545933" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545933" name="comment_link_54545933" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545933" onclick="return D2.setFocusComment(54545933)" >BPEL environments</a>


		 	<span id="comment_score_54545933" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545933); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~laughingskeptic">laughingskeptic</a>  <span class="uid"><a href="//slashdot.org/~laughingskeptic">( 1004414 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545933"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545933">There are many flow chart based Business Process Execution Language (BPEL) coding environments, including multiple open source options:  <a href="http://orchestra.ow2.org/xwiki/bin/view/Main/WebHome" title="ow2.org">http://orchestra.ow2.org/xwiki...</a> [ow2.org] , <a href="https://eclipse.org/bpel/" title="eclipse.org">https://eclipse.org/bpel/</a> [eclipse.org] .</div>
	</div>

	<div class="commentSub" id="comment_sub_54545933">

</div>
</div>

<div id="replyto_54545933"></div>

<ul id="group_54545933">
	<li id="hiddens_54545933" class="hide"></li>
</ul>

</li><li id="tree_54544957" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54544957" class="commentstatus"></div>
<div id="comment_54544957" class="cw">
</div>

<div id="replyto_54544957"></div>

<ul id="group_54544957">
	<li id="hiddens_54544957" class="hide"></li>
</ul>

<ul id="commtree_54544957"><li id="tree_54545355" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54545355" class="commentstatus"></div>
<div id="comment_54545355" class="cw">
	<div id="comment_top_54545355" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54545355" name="comment_link_54545355" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;cid=54545355" onclick="return D2.setFocusComment(54545355)" >Re:</a>


		 	<span id="comment_score_54545355" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54545355); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54545355"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54545355">Not quite. Scratch is basically a structured editor with visual representation of its data isomorphic to a certain language's syntax. It's not what any sane person would describe as a flowchart, seeing how informal flowcharts were and how strict structured editors are.</div>
	</div>

	<div class="commentSub" id="comment_sub_54545355">

</div>
</div>

<div id="replyto_54545355"></div>

<ul id="group_54545355">
	<li id="hiddens_54545355" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=10694299&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">13 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//ask.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 19;
		D2.currents()['full']     = 8;
		D2.currents()['oneline']  = 73;
		// D2.currents_total(100);

		D2.abbrev_comments({54545179:516,54545225:522,54544767:529,54544943:914,54544815:529,54544671:532,54545055:522,54545643:118,54544963:524,54544915:512,54545781:533,54544739:522,54545431:512,54545401:523,54545287:522,54545221:522});
		D2.noshow_comments([54544705,54544895,54544695,54545677,54544903,54544649,54544657,54544677,54544679,54544701,54544713,54544723,54544737,54545291,54544789,54544751,54544777,54544837,54544871,54544889,54544919,54544957]);
		D2.pieces_comments([54544625,54544675,54545401,54544663,54544959,54545215,54544963,54545897,54545783,54545869,54545013,54545361,54545221,54545359,54545329,54545715,54545945,54545781,54545921,54544633,54544681,54544635,54545311,54545417,54544655,54544659,54544669,54544947,54544671,54545411,54544687,54544691,54544849,54544703,54544739,54544915,54544769,54544721,54544779,54544805,54544973,54545875,54544761,54544809,54545025,54544943,54544979,54545057,54544745,54544757,54544767,54545287,54544815,54544831,54544845,54544885,54544989,54545055,54545059,54545179,54545225,54545245,54545261,54545345,54545421,54545431,54545685,54545481,54545635,54545643,54545645,54545933,54545355]);
		D2.init_hiddens([54544705,54544675,54544625,54544723,54544745,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(327045);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1144<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/06/13/0159223/ask-slashdot-can-technology-prevent-shootings?sdsrc=popbyskidbtmprev">Ask Slashdot:  Can Technology Prevent Shootings?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>857<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/17/04/15/0546240/ask-slashdot-what-was-your-first-home-computer?sdsrc=popbyskidbtmprev">Ask Slashdot: What Was Your First Home Computer?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>766<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/12/21/151229/slashdot-asks-why-are-browsers-so-slow?sdsrc=popbyskidbtmprev">Slashdot Asks: Why Are Browsers So Slow?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>637<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/16/06/06/0119217/ask-slashdot-how-do-you-create-a-highly-secure-password?sdsrc=popbyskidbtmprev">Ask Slashdot: How Do You Create A Highly-Secure Password?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>615<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/17/02/13/0723209/ask-slashdot-what-are-some-things-that-every-hacker-once-knew?sdsrc=popbyskidbtmprev">Ask Slashdot:  What Are Some Things That Every Hacker Once Knew?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//news.slashdot.org/story/17/06/04/0027201/esr-shares-a-forgotten-roots-of-open-source-moment-from-1984?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/att_64.png" width="64" height="64" alt="AT&T"></span>
	    
					<p class="grid_12"><a href="//news.slashdot.org/story/17/06/04/0027201/esr-shares-a-forgotten-roots-of-open-source-moment-from-1984?sdsrc=nextbtmprev">ESR Shares A Forgotten 'Roots Of Open Source' Moment From 1984</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>48<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//yro.slashdot.org/story/17/06/03/0137216/bruce-perens-explains-that-gpl-is-a-contract-court-case?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/court_64.png" width="64" height="64" alt="The Courts"></span>
	    
					<p class="grid_12"><a href="//yro.slashdot.org/story/17/06/03/0137216/bruce-perens-explains-that-gpl-is-a-contract-court-case?sdsrc=prevbtmprev">Bruce Perens Explains That 'GPL Is A Contract' Court Case</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>119<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//ask.slashdot.org/comments.pl?sid=10694299&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">137</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>To do nothing is to be nothing.</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?633">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?745">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->