<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '87721948493095846',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Ask Slashdot: Is the World Better Or Worse Because of Security Tech? - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="Slashdot reader krisdickie is a developer for embedded devices (and many other systems), and spends a lot of time being proactive about security.
This is obviously important, and I don't necessarily see it as a distraction, but rather a complex problem that has some added thrill to being solved.  I ...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="ask.slashdot.org">
		<meta property="og:url" content="https://ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech">
	    
		<meta property="og:title" content="Ask Slashdot: Is the World Better Or Worse Because of Security Tech? - Slashdot">
		<meta property="og:description" content="Slashdot reader krisdickie is a developer for embedded devices (and many other systems), and spends a lot of time being proactive about security.
This is obviously important, and I don't necessarily see it as a distraction, but rather a complex problem that has some added thrill to being solved.  I ...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/security_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/340570" >
	

		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?b248eef0f70d53e9" ><![endif]-->
		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?b248eef0f70d53e9" >
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?b248eef0f70d53e9" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?b248eef0f70d53e9">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?b248eef0f70d53e9"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?b248eef0f70d53e9" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//ask.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotAskSlashdot" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //ask.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Slashdot is powered by <strong><a href="//ask.slashdot.org/submission">your submissions</a></strong>, so send in your scoop
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
  <div id="announcementText" style="display: none;"> Have you <strong><a href="https://slashdot.org/firehose.pl?op=metamod">META-MODERATED</a></strong> today? <a href="https://slashdot.org/newsletter" rel="nofollow">Sign up for the Slashdot Daily Newsletter!</a> <strong><a href="http://hshd.io/nuLx" rel="nofollow">DEAL: For $25 - Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong></div>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 1 });
}
</script>
				<article id="firehose-100087128" data-fhid="100087128" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">100087128</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-100087128">
			<a href="//ask.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-100087128" class="story-title"> <a   href="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech">Ask Slashdot: Is the World Better Or Worse Because of Security Tech?</a></span>

		
		
		<!--<span class="comments commentcnt-100087128" >105</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech#comments" title="">105</a></span>
		
	</h2>
	<div class="details" id="details-100087128">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-100087128" datetime="on Sunday May 06, 2018 @12:34AM">on Sunday May 06, 2018 @12:34AM</time>
		
		
			 from the <span class="dept-text">alternate-universes</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-100087128">
	
		
	

	
		
		<div id="text-100087128" class="p">
			
		 	
				Slashdot reader <a href="/~krisdickie">krisdickie</a> is a developer for embedded devices (and many other systems), and spends a lot of time being proactive about security.
<i>This is obviously important, and I don't necessarily see it as a distraction, but rather a complex problem that has some added thrill to being solved.  I can't help but wonder though if I (and my team) would have been X times more productive or have come up with some amazing new concept or feature, if we didn't have to deal with implementing security measures. <br> <br>

In a utopian world, where there are no bad actors, we would have likely forfeited many of the systems and ideas that have been put into place to prevent bad things from happening. So my question is -- are we more technically advanced because of the thoughtfulness that has gone into creating these systems? <br> <br>

Or are we just losing precious resources and time dealing with the necessity of protecting ourselves from the perilous few?</i> <br>
Share your own thoughts in the comments.  Is the world better or worse off because of our ongoing development of security tech?
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-100087128" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech"
								  data-janrain-title="Ask Slashdot: Is the World Better Or Worse Because of Security Tech?"
								  data-janrain-message="Ask Slashdot: Is the World Better Or Worse Because of Security Tech? @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-100087128" class="tag-bar none">
			<a  class="popular topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/security" target="_blank">security</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/askslashdot" target="_blank">askslashdot</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//tech.slashdot.org/story/18/05/05/1925251/new-hyperloop-cargo-company-promises-deliveries-at-600-mph?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//tech.slashdot.org/story/18/05/05/0437244/facebook-exec-admits-no-real-understanding-for-the-scope-of-fake-news?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//tech.slashdot.org/story/18/05/05/1925251/new-hyperloop-cargo-company-promises-deliveries-at-600-mph?sdsrc=prev">New Hyperloop Cargo Company Promises Deliveries at 600 MPH </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//ask.slashdot.org/story/17/10/04/1513229/ask-slashdot-share-your-security-review-tales?sdsrc=rel">Ask Slashdot: Share Your Security Review Tales</a></h3><h3><a href="//ask.slashdot.org/story/17/10/16/2056207/ask-slashdot-what-are-some-hard-truths-it-must-learn-to-accept?sdsrc=rel">Ask Slashdot: What Are Some Hard Truths IT Must Learn To Accept?</a></h3><h3><a href="//ask.slashdot.org/story/17/10/18/212252/ask-slashdot-what-are-ways-to-get-companies-to-actually-focus-on-security?sdsrc=rel">Ask Slashdot: What Are Ways To Get Companies To Actually Focus On Security?</a></h3><h3><a href="//ask.slashdot.org/story/17/11/21/2312215/ask-slashdot-how-are-so-many-security-vulnerabilities-possible?sdsrc=rel">Ask Slashdot: How Are So Many Security Vulnerabilities Possible?</a></h3><h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//ask.slashdot.org/submission/8162672/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech?sdsrc=rel" href="#">Submission: Ask Slashdot: Is the World Better or Worse Because of Security Tech?</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//tech.slashdot.org/story/18/05/05/0437244/facebook-exec-admits-no-real-understanding-for-the-scope-of-fake-news?sdsrc=next">Facebook Exec Admits 'No Real Understanding' for the Scope of Fake News</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech" title="Back to Article - Ask Slashdot: Is the World Better Or Worse Because of Security Tech?">Ask Slashdot: Is the World Better Or Worse Because of Security Tech?</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Ask Slashdot: Is the World Better Or Worse Because of Security Tech?" href="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech">Ask Slashdot: Is the World Better Or Worse Because of Security Tech?</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=12071956" class="btn">Search <span class="totalcommentcnt">106</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//ask.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//ask.slashdot.org/comments.pl?sid=12071956">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//ask.slashdot.org/search.pl?op=comments&amp;sid=12071956" class="ui-icon search_comments">Search <span class="totalcommentcnt">106</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//ask.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//ask.slashdot.org/story/18/05/05/1835234/ask-slashdot-is-the-world-better-or-worse-because-of-security-tech/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?b248eef0f70d53e9" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_56561876" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56561876" class="commentstatus"></div>
<div id="comment_56561876" class="cw">
	<div id="comment_top_56561876" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561876" name="comment_link_56561876" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561876" onclick="return D2.setFocusComment(56561876)" >Seriously?</a>


		 	<span id="comment_score_56561876" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561876); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RobbieCrash">RobbieCrash</a>  <span class="uid"><a href="//slashdot.org/~RobbieCrash">( 834439 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561876"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561876"><p>What an asinine question. </p><p>Of course we're worse off because there are bad people in the world. If everyone was a magical completely altruistic person who did nothing but make the world a better place, the world would be a better place.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561876">

</div>
</div>

<div id="replyto_56561876"></div>

<ul id="group_56561876">
	<li id="hiddens_56561876" class="hide"></li>
</ul>

<ul id="commtree_56561876"><li id="tree_56561922" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56561922" class="commentstatus"></div>
<div id="comment_56561922" class="cw">
	<div id="comment_top_56561922" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561922" name="comment_link_56561922" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561922" onclick="return D2.setFocusComment(56561922)" >Re:</a>


		 	<span id="comment_score_56561922" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561922); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Jeremiah+Cornelius">Jeremiah Cornelius</a>  <span class="uid"><a href="//slashdot.org/~Jeremiah+Cornelius">( 137 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561922"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561922"><p>This article touches on many of the overall issues, implicit in the "question", as it is.</p><p>"It&rsquo;s time to kill the web"<br><a href="https://blog.plan99.net/its-time-to-kill-the-web-974a9fe80c89" title="plan99.net">https://blog.plan99.net/its-ti...</a> [plan99.net]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561922">

</div>
</div>

<div id="replyto_56561922"></div>

<ul id="group_56561922">
	<li id="hiddens_56561922" class="hide"></li>
</ul>

<ul id="commtree_56561922"><li id="tree_56561966" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561966" class="commentstatus"></div>
<div id="comment_56561966" class="cw">
</div>

<div id="replyto_56561966"></div>

<ul id="group_56561966">
	<li id="hiddens_56561966" class="hide"></li>
</ul>

</li><li id="tree_56561992" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561992" class="commentstatus"></div>
<div id="comment_56561992" class="cw">
</div>

<div id="replyto_56561992"></div>

<ul id="group_56561992">
	<li id="hiddens_56561992" class="hide"></li>
</ul>

<ul id="commtree_56561992"><li id="tree_56562956" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562956" class="commentstatus"></div>
<div id="comment_56562956" class="cw">
</div>

<div id="replyto_56562956"></div>

<ul id="group_56562956">
	<li id="hiddens_56562956" class="hide"></li>
</ul>

</li><li id="hidestring_56561992"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56561992">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56561922"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56561922">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562046" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562046" class="commentstatus"></div>
<div id="comment_56562046" class="cw">
</div>

<div id="replyto_56562046"></div>

<ul id="group_56562046">
	<li id="hiddens_56562046" class="hide"></li>
</ul>

</li><li id="tree_56562408" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562408" class="commentstatus"></div>
<div id="comment_56562408" class="cw">
</div>

<div id="replyto_56562408"></div>

<ul id="group_56562408">
	<li id="hiddens_56562408" class="hide"></li>
</ul>

<ul id="commtree_56562408"><li id="tree_56562864" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562864" class="commentstatus"></div>
<div id="comment_56562864" class="cw">
</div>

<div id="replyto_56562864"></div>

<ul id="group_56562864">
	<li id="hiddens_56562864" class="hide"></li>
</ul>

<ul id="commtree_56562864"><li id="tree_56563110" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563110" class="commentstatus"></div>
<div id="comment_56563110" class="cw">
</div>

<div id="replyto_56563110"></div>

<ul id="group_56563110">
	<li id="hiddens_56563110" class="hide"></li>
</ul>

<ul id="commtree_56563110"><li id="tree_56563190" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563190" class="commentstatus"></div>
<div id="comment_56563190" class="cw">
	<div id="comment_top_56563190" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563190" name="comment_link_56563190" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563190" onclick="return D2.setFocusComment(56563190)" >Re:</a>


		 	<span id="comment_score_56563190" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563190); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Immerman">Immerman</a>  <span class="uid"><a href="//slashdot.org/~Immerman">( 2627577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563190"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563190"><p>Oh, sure, I can imagine such a place - but that awasn't the proposition: a world full of truly selfish people would care for ONLY themselves.  Meanwhile pretty much every social animal on the planet demonstrates compassion and altruism - without them we would probably never even manage to develop modern civilization in the first place.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563190">

</div>
</div>

<div id="replyto_56563190"></div>

<ul id="group_56563190">
	<li id="hiddens_56563190" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56563464" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563464" class="commentstatus"></div>
<div id="comment_56563464" class="cw">
</div>

<div id="replyto_56563464"></div>

<ul id="group_56563464">
	<li id="hiddens_56563464" class="hide"></li>
</ul>

</li><li id="hidestring_56562864"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562864">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56562408"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562408">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562908" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562908" class="commentstatus"></div>
<div id="comment_56562908" class="cw">
	<div id="comment_top_56562908" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562908" name="comment_link_56562908" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562908" onclick="return D2.setFocusComment(56562908)" >Re:</a>


		 	<span id="comment_score_56562908" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562908); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562908"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562908"><p>Security and Convince have always been at odds.<br>Now new security tech does help make some things a bit more convent while keeping a reasonable (not superior) degree of security.<br>Such as biometrics  like finger print reading and face recognition allow you to keep devices secure enough against the casual bad actor ( the majority of them ). As well with the advancements in encryption allows a lot of extra security to go on without much user interaction.  But still it isn't faster and easier to use these system w<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562908">

</div>
</div>

<div id="replyto_56562908"></div>

<ul id="group_56562908">
	<li id="hiddens_56562908" class="hide"></li>
</ul>

<ul id="commtree_56562908"><li id="tree_56563688" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563688" class="commentstatus"></div>
<div id="comment_56563688" class="cw">
</div>

<div id="replyto_56563688"></div>

<ul id="group_56563688">
	<li id="hiddens_56563688" class="hide"></li>
</ul>

</li><li id="hidestring_56562908"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562908">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562978" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562978" class="commentstatus"></div>
<div id="comment_56562978" class="cw">
	<div id="comment_top_56562978" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562978" name="comment_link_56562978" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562978" onclick="return D2.setFocusComment(56562978)" >Re:</a>


		 	<span id="comment_score_56562978" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562978); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Sique">Sique</a>  <span class="uid"><a href="//slashdot.org/~Sique">( 173459 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562978"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562978">This mostly misses the point. Security is much more than protection against bad people. This might be a very visible and easily explained effect of having security, but security also protects against misshappenings, mistakes, accidents, errors, all the little nuisances which disrupt the intended way of running things. Even if all people were saints, we still would need security.</div>
	</div>

	<div class="commentSub" id="comment_sub_56562978">

</div>
</div>

<div id="replyto_56562978"></div>

<ul id="group_56562978">
	<li id="hiddens_56562978" class="hide"></li>
</ul>

<ul id="commtree_56562978"><li id="tree_56563582" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563582" class="commentstatus"></div>
<div id="comment_56563582" class="cw">
</div>

<div id="replyto_56563582"></div>

<ul id="group_56563582">
	<li id="hiddens_56563582" class="hide"></li>
</ul>

</li><li id="hidestring_56562978"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562978">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56563466" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563466" class="commentstatus"></div>
<div id="comment_56563466" class="cw">
</div>

<div id="replyto_56563466"></div>

<ul id="group_56563466">
	<li id="hiddens_56563466" class="hide"></li>
</ul>

<ul id="commtree_56563466"><li id="tree_56563510" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563510" class="commentstatus"></div>
<div id="comment_56563510" class="cw">
</div>

<div id="replyto_56563510"></div>

<ul id="group_56563510">
	<li id="hiddens_56563510" class="hide"></li>
</ul>

</li><li id="hidestring_56563466"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56563466">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56561876"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56561876">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56561878" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561878" class="commentstatus"></div>
<div id="comment_56561878" class="cw">
</div>

<div id="replyto_56561878"></div>

<ul id="group_56561878">
	<li id="hiddens_56561878" class="hide"></li>
</ul>

</li><li id="tree_56561880" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56561880" class="commentstatus"></div>
<div id="comment_56561880" class="cw">
	<div id="comment_top_56561880" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561880" name="comment_link_56561880" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561880" onclick="return D2.setFocusComment(56561880)" >Better or worse?</a>


		 	<span id="comment_score_56561880" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561880); return false"><span class=opt>Score:</span>2</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561880"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561880"><blockquote><div><p>Is the World Better Or Worse Because of Security Tech?</p></div></blockquote><p>Yes.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561880">

</div>
</div>

<div id="replyto_56561880"></div>

<ul id="group_56561880">
	<li id="hiddens_56561880" class="hide"></li>
</ul>

</li><li id="tree_56561888" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56561888" class="commentstatus"></div>
<div id="comment_56561888" class="cw">
	<div id="comment_top_56561888" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561888" name="comment_link_56561888" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561888" onclick="return D2.setFocusComment(56561888)" >Sure, just ignore security, YOU IDIOT</a>


		 	<span id="comment_score_56561888" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561888); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561888"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561888"><p>admin/admin passwords, not rolling out patches, leaving anonymous FTP open...  what can go wrong?  this article was written by a dumbass</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561888">

</div>
</div>

<div id="replyto_56561888"></div>

<ul id="group_56561888">
	<li id="hiddens_56561888" class="hide"></li>
</ul>

</li><li id="tree_56561896" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56561896" class="commentstatus"></div>
<div id="comment_56561896" class="cw">
	<div id="comment_top_56561896" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561896" name="comment_link_56561896" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561896" onclick="return D2.setFocusComment(56561896)" >It depends</a>


		 	<span id="comment_score_56561896" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561896); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~walshy007">walshy007</a>  <span class="uid"><a href="//slashdot.org/~walshy007">( 906710 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561896">		
		on Sunday May 06, 2018 @12:57AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561896">#56561896</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561896"><p>This is not a one-case-fits-all item.</p><p>What kinds of measures specifically are being spoken of? Does it help or hinder end users doing what they wish? Are end users even a consideration or is this solely to keep a stranglehold on the device from a manufacturers perspective?</p><p>As with many things there will never be a single answer, what is presented is a set of varying trade-offs whose value will change depending on the desired goals and whose perspective it is desired from.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561896">
<span class="ind"></span><a id="reply_link_56561896" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56561896" onclick="D2.replyTo(56561896); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="It depends by walshy007 @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561896" data-title="It depends">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="It depends by walshy007" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561896" data-title="It depends">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="It depends by walshy007" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561896" data-title="It depends">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56561896" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56561896" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56561896" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56561896"></div>

<ul id="group_56561896">
	<li id="hiddens_56561896" class="hide"></li>
</ul>

</li><li id="tree_56561898" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56561898" class="commentstatus"></div>
<div id="comment_56561898" class="cw">
	<div id="comment_top_56561898" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561898" name="comment_link_56561898" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561898" onclick="return D2.setFocusComment(56561898)" >Necessity is the mother of invention</a>


		 	<span id="comment_score_56561898" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561898); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kobun">Kobun</a>  <span class="uid"><a href="//slashdot.org/~Kobun">( 668169 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561898">		
		on Sunday May 06, 2018 @12:58AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561898">#56561898</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561898">Human 'bad actors' are only one source of adverse conditions for computing.  Many security features double as stability and error-checking features.  I think that the author's question is ultimately a silly one because of Hanlon's Razor - "Never attribute to malice that which is adequately explained by stupidity".  I think most people have seen terrifically destructive users who had no malicious intent behind their actions.  Even in a utopia, humans are still human.</div>
	</div>

	<div class="commentSub" id="comment_sub_56561898">
<span class="ind"></span><a id="reply_link_56561898" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56561898" onclick="D2.replyTo(56561898); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Necessity is the mother of invention by Kobun @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561898" data-title="Necessity is the mother of invention">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Necessity is the mother of invention by Kobun" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561898" data-title="Necessity is the mother of invention">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Necessity is the mother of invention by Kobun" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561898" data-title="Necessity is the mother of invention">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56561898" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56561898" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56561898" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56561898"></div>

<ul id="group_56561898">
	<li id="hiddens_56561898" class="hide"></li>
</ul>

<ul id="commtree_56561898"><li id="tree_56561998" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561998" class="commentstatus"></div>
<div id="comment_56561998" class="cw">
</div>

<div id="replyto_56561998"></div>

<ul id="group_56561998">
	<li id="hiddens_56561998" class="hide"></li>
</ul>

</li><li id="tree_56562056" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562056" class="commentstatus"></div>
<div id="comment_56562056" class="cw">
	<div id="comment_top_56562056" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562056" name="comment_link_56562056" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562056" onclick="return D2.setFocusComment(56562056)" >Re:</a>


		 	<span id="comment_score_56562056" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562056); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Calydor">Calydor</a>  <span class="uid"><a href="//slashdot.org/~Calydor">( 739835 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562056"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562056"><p>A good example would be the Melissa virus which, IIRC, started out as a proof-of-concept that accidentally got loose.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562056">

</div>
</div>

<div id="replyto_56562056"></div>

<ul id="group_56562056">
	<li id="hiddens_56562056" class="hide"></li>
</ul>

</li><li id="hidestring_56561898"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56561898">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56561902" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561902" class="commentstatus"></div>
<div id="comment_56561902" class="cw">
</div>

<div id="replyto_56561902"></div>

<ul id="group_56561902">
	<li id="hiddens_56561902" class="hide"></li>
</ul>

</li><li id="tree_56561908" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56561908" class="commentstatus"></div>
<div id="comment_56561908" class="cw">
	<div id="comment_top_56561908" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561908" name="comment_link_56561908" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561908" onclick="return D2.setFocusComment(56561908)" >Missing Option</a>


		 	<span id="comment_score_56561908" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561908); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dohzer">dohzer</a>  <span class="uid"><a href="//slashdot.org/~dohzer">( 867770 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561908"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561908"><p>Not better or worse, but as it should be.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561908">

</div>
</div>

<div id="replyto_56561908"></div>

<ul id="group_56561908">
	<li id="hiddens_56561908" class="hide"></li>
</ul>

</li><li id="tree_56561938" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56561938" class="commentstatus"></div>
<div id="comment_56561938" class="cw">
	<div id="comment_top_56561938" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561938" name="comment_link_56561938" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561938" onclick="return D2.setFocusComment(56561938)" >I'd - sadly - say better.</a>


		 	<span id="comment_score_56561938" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561938); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~GerryGilmore">GerryGilmore</a>  <span class="uid"><a href="//slashdot.org/~GerryGilmore">( 663905 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561938"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561938">Sadly, because we, somehow, have allowed this great infrastructure we call "the internet" to be as filled with (security) holes as a collander. <br> <br> At this point, we re just imitating the Dutch boy quickly plugging holes in the dike while at the same time realizing that we'll run out of fingers long before all of the holes are plugged.</div>
	</div>

	<div class="commentSub" id="comment_sub_56561938">

</div>
</div>

<div id="replyto_56561938"></div>

<ul id="group_56561938">
	<li id="hiddens_56561938" class="hide"></li>
</ul>

<ul id="commtree_56561938"><li id="tree_56562098" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56562098" class="commentstatus"></div>
<div id="comment_56562098" class="cw">
	<div id="comment_top_56562098" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562098" name="comment_link_56562098" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562098" onclick="return D2.setFocusComment(56562098)" >Re:I'd - sadly - say better.</a>


		 	<span id="comment_score_56562098" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562098); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dgatwood">dgatwood</a>  <span class="uid"><a href="//slashdot.org/~dgatwood">( 11270 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562098">		
		on Sunday May 06, 2018 @02:16AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562098">#56562098</a>)
		<small><a href="http://www.shellscriptgames.com/" title="http://www.shellscriptgames.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~dgatwood/journal/" title="Friday July 17, 2009 @01:37AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562098">
<p>It's not even that.  The answer to the question of whether security makes things better or not in general is straightforward: It depends on whether the cost of the security is enough of a nuisance to exceed the projected lifetime benefit.  And that largely depends on context.  I'll explain by analogy.</p><p>I grew up in a small town in West Tennessee.  Lots of folks around town routinely left their houses unlocked.  It was that kind of town.  There were a few thousand people, and everybody knew everybody, or if they didn't know somebody, they knew someone who did.  In that context, it didn't take much security to keep things safe, because most people are good people, and if somebody from outside the community was wandering around, everybody knew that the person was an outsider if nobody out of a group of three or more people recognized the person.  Thus, a bad person from elsewhere would arouse enough suspicion to be noticed, and would probably be thwarted in whatever nefarious deeds he or she was planning, unless it was just minor mischief like TPing the house of somebody that nobody really liked much anyway.</p><p>Now, I live in the Silicon Valley.  I know two of my neighbors.  Thanks to work and church, I know people from various parts of the area, but they don't live nearby  I'm reasonably confident in leaving things lying around at work for precisely the same reason that I was reasonably confident back home&mdash;because everybody knows each other.  But if you were to ask me if I could leave valuables lying around anywhere else, the answer would be "heck no," because nobody knows anybody, statistically speaking, and so everybody is indistinguishable from a potential insider or outsider.  Even though most people are still good people, the odds of a bad person getting noticed are much lower.  And with so many more people, the number of bad people is much higher even if the percentage is the same, which only compounds the problem.</p><p>The same problem exists with technology.  Prior to the Internet, when computers were basically devices that you interacted with locally, security didn't matter that much, because most people are good people.  When computers became more connected, that became a problem, because even if most people are good people, the bad people can get to your systems from anywhere in the world, so it only takes a few bad people to ruin everything.  And because the pool of people potentially accessing your system is so much larger, the ability to distinguish good people from bad people is diminished.</p><p>So to make a long story short, computer security is a necessary response to the realities of a more interconnected world.  Would things be worse without all that added security?  Yes.  Does the security actually make the world better?  No.  It just keeps things from unraveling in the presence of interconnectedness that <b>does</b> make the world better.  The real question is whether that distinction matters.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562098">
<span class="ind"></span><a id="reply_link_56562098" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562098" onclick="D2.replyTo(56562098); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=56561938" onclick="return D2.selectParent(56561938)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:I'd - sadly - say better. by dgatwood @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562098" data-title="Re:I'd - sadly - say better.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:I'd - sadly - say better. by dgatwood" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562098" data-title="Re:I'd - sadly - say better.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:I'd - sadly - say better. by dgatwood" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562098" data-title="Re:I'd - sadly - say better.">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56562098" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56562098" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562098" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56562098"></div>

<ul id="group_56562098">
	<li id="hiddens_56562098" class="hide"></li>
</ul>

<ul id="commtree_56562098"><li id="tree_56563766" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563766" class="commentstatus"></div>
<div id="comment_56563766" class="cw">
	<div id="comment_top_56563766" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563766" name="comment_link_56563766" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563766" onclick="return D2.setFocusComment(56563766)" >Scarcity thinking and ironies of abundance</a>


		 	<span id="comment_score_56563766" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563766); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Paul+Fernhout">Paul Fernhout</a>  <span class="uid"><a href="//slashdot.org/~Paul+Fernhout">( 109597 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563766"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563766"><p>I agree with your point "computer security is a necessary response to the realities of a more interconnected world." That said, in many cases, I feel the deeper issue is, as in my sig, the irony of technologies of abundance in the hands of those still thinking in terms of scarcity.</p><p>I write about those ironies in regards to militarism here: <a href="http://pdfernhout.net/recognizing-irony-is-a-key-to-transcending-militarism.html" title="pdfernhout.net">http://pdfernhout.net/recogniz...<span class="substr"> </span></a> [pdfernhout.net] <br>"Likewise, even United States three-letter agencies like the NSA and the CIA, as well as their foreign counterparts, are becoming ironic i</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563766">

</div>
</div>

<div id="replyto_56563766"></div>

<ul id="group_56563766">
	<li id="hiddens_56563766" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_56561940" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561940" class="commentstatus"></div>
<div id="comment_56561940" class="cw">
</div>

<div id="replyto_56561940"></div>

<ul id="group_56561940">
	<li id="hiddens_56561940" class="hide"></li>
</ul>

</li><li id="tree_56561970" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56561970" class="commentstatus"></div>
<div id="comment_56561970" class="cw">
	<div id="comment_top_56561970" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56561970" name="comment_link_56561970" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561970" onclick="return D2.setFocusComment(56561970)" >Technology is a gift</a>


		 	<span id="comment_score_56561970" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56561970); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MrKaos">MrKaos</a>  <span class="uid"><a href="//slashdot.org/~MrKaos">( 858439 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56561970">		
		on Sunday May 06, 2018 @01:22AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56561970">#56561970</a>)
		<small><a href="//slashdot.org/~MrKaos/journal/" title="Monday July 23, 2007 @09:49AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56561970"><p>The choice people have to make is if it frees us or enslaves us.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56561970">
<span class="ind"></span><a id="reply_link_56561970" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56561970" onclick="D2.replyTo(56561970); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Technology is a gift by MrKaos @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561970" data-title="Technology is a gift">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Technology is a gift by MrKaos" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561970" data-title="Technology is a gift">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Technology is a gift by MrKaos" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56561970" data-title="Technology is a gift">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56561970" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56561970" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56561970" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56561970"></div>

<ul id="group_56561970">
	<li id="hiddens_56561970" class="hide"></li>
</ul>

</li><li id="tree_56562020" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56562020" class="commentstatus"></div>
<div id="comment_56562020" class="cw">
	<div id="comment_top_56562020" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562020" name="comment_link_56562020" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562020" onclick="return D2.setFocusComment(56562020)" >We had our decision point in the 80s and 90s</a>


		 	<span id="comment_score_56562020" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562020); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ctilsie242">ctilsie242</a>  <span class="uid"><a href="//slashdot.org/~ctilsie242">( 4841247 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562020">		
		on Sunday May 06, 2018 @01:49AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562020">#56562020</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562020"><p>In the 1980s and 1990s, there was a turning point where security was considered something that should be baked into an OS and product, be it an operating system (thus the C2/C3/B1/etc. levels), MAC/DAC controls, security as part of the kernel, and part of a module, and so on.</p><p>However, what happened is that companies took the easy route.  Windows had no innate security so the whole firewall/castle model of company security was formed, where security was done by the network fabric, and not the endpoints.  This worked for a while, until malvertising and Trojans allowed malware to attack anywhere.</p><p>These days, security is pathetic in general.  I have heard "security has no ROI", "the hackers will always win, so why waste money?" and other claptrap for over a decade.  In fact, because there is no real criminal penalty, an egregious security breach makes the top levels of a company a lot of money because they can short their stock before making the announcement public, especially if they can keep the breach under wraps for six months.</p><p>IoT devices come to mind as a specific example.  Why even bother with meaningful security when customers are forced to buy your version 1.1 of a doodad because version 1.0 will get their stuff hacked, and cannot be upgraded?  Especially because the money with IoT is the analytics coming in, not the actual purchase of the device.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562020">
<span class="ind"></span><a id="reply_link_56562020" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562020" onclick="D2.replyTo(56562020); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="We had our decision point in the 80s and 90s by ctilsie242 @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562020" data-title="We had our decision point in the 80s and 90s">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="We had our decision point in the 80s and 90s by ctilsie242" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562020" data-title="We had our decision point in the 80s and 90s">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="We had our decision point in the 80s and 90s by ctilsie242" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562020" data-title="We had our decision point in the 80s and 90s">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56562020" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56562020" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562020" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56562020"></div>

<ul id="group_56562020">
	<li id="hiddens_56562020" class="hide"></li>
</ul>

<ul id="commtree_56562020"><li id="tree_56562054" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562054" class="commentstatus"></div>
<div id="comment_56562054" class="cw">
	<div id="comment_top_56562054" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562054" name="comment_link_56562054" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562054" onclick="return D2.setFocusComment(56562054)" >Re:</a>


		 	<span id="comment_score_56562054" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562054); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Alypius">Alypius</a>  <span class="uid"><a href="//slashdot.org/~Alypius">( 3606369 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562054"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562054">It's stuff like this that makes me cry, but only because it's true. It actually makes me second-guess my second career; do I take my risk analysis and other skills to a company that will ignore it because "the hackers will always win," or do I go for a NSA gig where I can actually be on the offensive for once?</div>
	</div>

	<div class="commentSub" id="comment_sub_56562054">

</div>
</div>

<div id="replyto_56562054"></div>

<ul id="group_56562054">
	<li id="hiddens_56562054" class="hide"></li>
</ul>

<ul id="commtree_56562054"><li id="tree_56562102" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562102" class="commentstatus"></div>
<div id="comment_56562102" class="cw">
</div>

<div id="replyto_56562102"></div>

<ul id="group_56562102">
	<li id="hiddens_56562102" class="hide"></li>
</ul>

<ul id="commtree_56562102"><li id="tree_56562126" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562126" class="commentstatus"></div>
<div id="comment_56562126" class="cw">
</div>

<div id="replyto_56562126"></div>

<ul id="group_56562126">
	<li id="hiddens_56562126" class="hide"></li>
</ul>

<ul id="commtree_56562126"><li id="tree_56562284" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562284" class="commentstatus"></div>
<div id="comment_56562284" class="cw">
</div>

<div id="replyto_56562284"></div>

<ul id="group_56562284">
	<li id="hiddens_56562284" class="hide"></li>
</ul>

<ul id="commtree_56562284"><li id="tree_56563044" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563044" class="commentstatus"></div>
<div id="comment_56563044" class="cw">
</div>

<div id="replyto_56563044"></div>

<ul id="group_56563044">
	<li id="hiddens_56563044" class="hide"></li>
</ul>

</li><li id="tree_56563196" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563196" class="commentstatus"></div>
<div id="comment_56563196" class="cw">
	<div id="comment_top_56563196" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563196" name="comment_link_56563196" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563196" onclick="return D2.setFocusComment(56563196)" >Re:</a>


		 	<span id="comment_score_56563196" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563196); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bert64">Bert64</a>  <span class="uid"><a href="//slashdot.org/~Bert64">( 520050 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563196"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563196"><p>No it doesn't.<br>There are thousands of compromised boxes in china, and malware infections are a routine problem in chinese companies.<br>A lot of the spam and hack attempts that come from chinese addresses aren't launched by the chinese, they are boxes that have been hacked.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563196">

</div>
</div>

<div id="replyto_56563196"></div>

<ul id="group_56563196">
	<li id="hiddens_56563196" class="hide"></li>
</ul>

</li><li id="hidestring_56562284"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562284">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56562126"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562126">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56562102"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562102">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56562054"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562054">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562120" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562120" class="commentstatus"></div>
<div id="comment_56562120" class="cw">
	<div id="comment_top_56562120" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562120" name="comment_link_56562120" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562120" onclick="return D2.setFocusComment(56562120)" >Re:</a>


		 	<span id="comment_score_56562120" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562120); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562120"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562120"><p><div class="quote"><p>In the 1980s and 1990s, there was a turning point where security was considered something that should be baked into an OS and product, be it an operating system (thus the C2/C3/B1/etc. levels), MAC/DAC controls, security as part of the kernel, and part of a module, and so on.</p><p>However, what happened is that companies took the easy route.</p></div><p>Amen!  However, also along the way is that the entire tech community decided that real security wasn't possible, it somehow became unobtainable.  The problems were SOLVED in the 1970s in response to the data processing problems encountered with multi-level data security for Viet Nam, but we failed to heed the lessons, and eventually they fell into obscurity.</p><p>Capability based security offers a way to have general purpose computing that humans can manage and secure. The core concept is to never, ever, trust an<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562120">

</div>
</div>

<div id="replyto_56562120"></div>

<ul id="group_56562120">
	<li id="hiddens_56562120" class="hide"></li>
</ul>

<ul id="commtree_56562120"><li id="tree_56562306" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562306" class="commentstatus"></div>
<div id="comment_56562306" class="cw">
	<div id="comment_top_56562306" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562306" name="comment_link_56562306" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562306" onclick="return D2.setFocusComment(56562306)" >Re:</a>


		 	<span id="comment_score_56562306" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562306); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dnaumov">dnaumov</a>  <span class="uid"><a href="//slashdot.org/~dnaumov">( 453672 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562306"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562306"><p>People can't deal with trivial UAC prompts because they don't understand what's being asked of them and you are suggesting THIS?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562306">

</div>
</div>

<div id="replyto_56562306"></div>

<ul id="group_56562306">
	<li id="hiddens_56562306" class="hide"></li>
</ul>

<ul id="commtree_56562306"><li id="tree_56562382" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562382" class="commentstatus"></div>
<div id="comment_56562382" class="cw">
	<div id="comment_top_56562382" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562382" name="comment_link_56562382" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562382" onclick="return D2.setFocusComment(56562382)" >Re:</a>


		 	<span id="comment_score_56562382" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562382); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562382"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562382"><p>UAC suck, quite frankly.  It's a "this might be bad, do you want to do it anyway" type of question, conveying no useful information other than horrid boolean choice  (Yes - your machine might get PWND along with everything on it,   No - Your machine won't do what you want because of "Security")</p><p>Replacing dialog boxes with "power boxes" makes almost no difference in terms of ease of use, but it shifts permissions away from the application code and puts it back where it belongs.</p><p>Insisting that users can't manag<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562382">

</div>
</div>

<div id="replyto_56562382"></div>

<ul id="group_56562382">
	<li id="hiddens_56562382" class="hide"></li>
</ul>

<ul id="commtree_56562382"><li id="tree_56563206" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563206" class="commentstatus"></div>
<div id="comment_56563206" class="cw">
	<div id="comment_top_56563206" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563206" name="comment_link_56563206" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563206" onclick="return D2.setFocusComment(56563206)" >Re:</a>


		 	<span id="comment_score_56563206" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563206); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bert64">Bert64</a>  <span class="uid"><a href="//slashdot.org/~Bert64">( 520050 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563206"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563206"><p><div class="quote"><p>the current OS design would have you hand your wallet (and a non-revocable power of attorney) to the clerk, and just hope that they take the right amount out of your account before handing it back.</p></div><p>Which is exactly how credit/debit cards work...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563206">

</div>
</div>

<div id="replyto_56563206"></div>

<ul id="group_56563206">
	<li id="hiddens_56563206" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_56562422" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562422" class="commentstatus"></div>
<div id="comment_56562422" class="cw">
	<div id="comment_top_56562422" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562422" name="comment_link_56562422" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562422" onclick="return D2.setFocusComment(56562422)" >Re:</a>


		 	<span id="comment_score_56562422" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562422); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562422"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562422"><p>The OS file dialogue is exactly how OS X handles sandbox applications for opening a file.<br>It goes further, that it gives a file handle back that is signed by the OS, so it can store the user-given-permission in a preference file, so that the next time the application is opened it will still have access to that file.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562422">

</div>
</div>

<div id="replyto_56562422"></div>

<ul id="group_56562422">
	<li id="hiddens_56562422" class="hide"></li>
</ul>

</li><li id="tree_56562644" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562644" class="commentstatus"></div>
<div id="comment_56562644" class="cw">
	<div id="comment_top_56562644" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562644" name="comment_link_56562644" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562644" onclick="return D2.setFocusComment(56562644)" >Re:</a>


		 	<span id="comment_score_56562644" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562644); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~110010001000">110010001000</a>  <span class="uid"><a href="//slashdot.org/~110010001000">( 697113 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562644"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562644">Ridiculous. A computer program can "touch" many files and also may need to run without user intervention. No one is going to answer "yes this problem needs to access djfhgkl.dll" prompts. General computers can never be secure because malware are just programs too.</div>
	</div>

	<div class="commentSub" id="comment_sub_56562644">

</div>
</div>

<div id="replyto_56562644"></div>

<ul id="group_56562644">
	<li id="hiddens_56562644" class="hide"></li>
</ul>

<ul id="commtree_56562644"><li id="tree_56563170" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563170" class="commentstatus"></div>
<div id="comment_56563170" class="cw">
	<div id="comment_top_56563170" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563170" name="comment_link_56563170" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563170" onclick="return D2.setFocusComment(56563170)" >Re:</a>


		 	<span id="comment_score_56563170" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563170); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563170"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563170"><p>Why should a program even know about the existence of "djfhgkl.dll"?  It shouldn't see any of the file system, except when handed a capability for a file or folder.</p><p>Every gas station clerk I hand $20 to as a form of payment doesn't have the ability to take out a mortgage in my name... they only have the $20. There are zero clerks asking to touch each note in my wallet by serial number, etc.</p><p>Malware are just programs that are written to do evil,  everything else does evil by mistake.  Capabilities just prevent<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563170">

</div>
</div>

<div id="replyto_56563170"></div>

<ul id="group_56563170">
	<li id="hiddens_56563170" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_56562742" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562742" class="commentstatus"></div>
<div id="comment_56562742" class="cw">
	<div id="comment_top_56562742" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562742" name="comment_link_56562742" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562742" onclick="return D2.setFocusComment(56562742)" >Re: We had our decision point in the 80s and 90s</a>


		 	<span id="comment_score_56562742" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562742); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Arnold+Reinhold">Arnold Reinhold</a>  <span class="uid"><a href="//slashdot.org/~Arnold+Reinhold">( 539934 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562742"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562742">A big factor was U.S. export controls. An operating system with strong security would require individual licenses to be sold in other countries. Remember 40-bit encryption keys?</div>
	</div>

	<div class="commentSub" id="comment_sub_56562742">

</div>
</div>

<div id="replyto_56562742"></div>

<ul id="group_56562742">
	<li id="hiddens_56562742" class="hide"></li>
</ul>

</li><li id="tree_56563616" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563616" class="commentstatus"></div>
<div id="comment_56563616" class="cw">
	<div id="comment_top_56563616" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563616" name="comment_link_56563616" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563616" onclick="return D2.setFocusComment(56563616)" >Re:</a>


		 	<span id="comment_score_56563616" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563616); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~avandesande">avandesande</a>  <span class="uid"><a href="//slashdot.org/~avandesande">( 143899 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563616"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563616">Yeah, when an OS was the size of what is now a simple device driver.</div>
	</div>

	<div class="commentSub" id="comment_sub_56563616">

</div>
</div>

<div id="replyto_56563616"></div>

<ul id="group_56563616">
	<li id="hiddens_56563616" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562048" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562048" class="commentstatus"></div>
<div id="comment_56562048" class="cw">
	<div id="comment_top_56562048" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562048" name="comment_link_56562048" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562048" onclick="return D2.setFocusComment(56562048)" >probaby yes</a>


		 	<span id="comment_score_56562048" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562048); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~superwiz">superwiz</a>  <span class="uid"><a href="//slashdot.org/~superwiz">( 655733 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562048"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562048">It probably increases usability in the same way that car safety measures increase usability of cars.  As someone already mentioned, it forces systems to be designed in such a way that they are also proofed against users "shooting themselves in the foot" at a moment of even a tiniest incompetence.</div>
	</div>

	<div class="commentSub" id="comment_sub_56562048">

</div>
</div>

<div id="replyto_56562048"></div>

<ul id="group_56562048">
	<li id="hiddens_56562048" class="hide"></li>
</ul>

</li><li id="tree_56562062" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562062" class="commentstatus"></div>
<div id="comment_56562062" class="cw">
	<div id="comment_top_56562062" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562062" name="comment_link_56562062" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562062" onclick="return D2.setFocusComment(56562062)" >Locked Doors Are Barriers to Experimenting/Learnin</a>


		 	<span id="comment_score_56562062" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562062); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562062"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562062"><p>I know that when I first started hacking around with Linux in the mid 1990s that I had an easy time experimenting with networking compared to somebody just trying things out today.</p><p>Samba was out and all the security in it, and in Microsoft products that used SMB, were loose and easy to use.  NFS was a breeze to use, so you could boot up a machine with an NFS install floppy diskette and put a whole freenix (I like NetBSD) on a system quickly.</p><p>A lot of that has changed now.  It's even a hassle now just to get t<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562062">

</div>
</div>

<div id="replyto_56562062"></div>

<ul id="group_56562062">
	<li id="hiddens_56562062" class="hide"></li>
</ul>

<ul id="commtree_56562062"><li id="tree_56562142" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562142" class="commentstatus"></div>
<div id="comment_56562142" class="cw">
	<div id="comment_top_56562142" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562142" name="comment_link_56562142" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562142" onclick="return D2.setFocusComment(56562142)" >Re:</a>


		 	<span id="comment_score_56562142" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562142); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~zynthaxx">zynthaxx</a>  <span class="uid"><a href="//slashdot.org/~zynthaxx">( 725359 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562142"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562142">The problem is that the intruder doesn&#226;(TM)t have to come from outside, but most likely will be a naive user on your own network who clicks something they shouldn&#226;(TM)t have on a poorly secured computer.

So: The basic protocols are still around, so you can still learn the basics of how to set up network services within a lab environment; nothing has really changed there. But don&#226;(TM)t stop learning once you know the basics; that&#226;(TM)s the main lesson here. When you can reliably create a</div>
	</div>

	<div class="commentSub" id="comment_sub_56562142">

</div>
</div>

<div id="replyto_56562142"></div>

<ul id="group_56562142">
	<li id="hiddens_56562142" class="hide"></li>
</ul>

</li><li id="tree_56562550" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562550" class="commentstatus"></div>
<div id="comment_56562550" class="cw">
	<div id="comment_top_56562550" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562550" name="comment_link_56562550" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562550" onclick="return D2.setFocusComment(56562550)" >Re:</a>


		 	<span id="comment_score_56562550" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562550); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tlhIngan">tlhIngan</a>  <span class="uid"><a href="//slashdot.org/~tlhIngan">( 30335 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562550"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562550"><p>Exactly.</p><p>It's also  making stuff harder to repair, because new vulnerabilities mean you lose the ability to fix it yourself.</p><p>Think about a fingerprint reader. In days gone by, they were simply cameras and you got an image from them, then run your algorithms on them. But nowadays it's such a big deal that fingerprint data must be encrypted and if your hardware supports it, sent over a secure bus to a secure processor, using PKI encryption to ensure both endpoints haven't been compromised.</p><p>All this because a bad<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562550">

</div>
</div>

<div id="replyto_56562550"></div>

<ul id="group_56562550">
	<li id="hiddens_56562550" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562068" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562068" class="commentstatus"></div>
<div id="comment_56562068" class="cw">
</div>

<div id="replyto_56562068"></div>

<ul id="group_56562068">
	<li id="hiddens_56562068" class="hide"></li>
</ul>

</li><li id="tree_56562082" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562082" class="commentstatus"></div>
<div id="comment_56562082" class="cw">
	<div id="comment_top_56562082" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562082" name="comment_link_56562082" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562082" onclick="return D2.setFocusComment(56562082)" >Simple answer: Yes.</a>


		 	<span id="comment_score_56562082" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562082); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562082"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562082"><p>Aka "both". But by and large, worse, and this will worsen until we fix two things:</p><p>The atrocious state of our technology, IOW the "hyoooooooge" technical debt. That mountain is so big we don't know where to start looking at it. But it's still there. It's become so big it has its own abyss, staring at you. That makes it even harder to look at.</p><p>Our willingness to be oppressed by technology. It doesn't matter if it's because of some "security" threat or other ("for the childrun", "terrists", you name it), govern<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562082">

</div>
</div>

<div id="replyto_56562082"></div>

<ul id="group_56562082">
	<li id="hiddens_56562082" class="hide"></li>
</ul>

</li><li id="tree_56562094" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562094" class="commentstatus"></div>
<div id="comment_56562094" class="cw">
	<div id="comment_top_56562094" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562094" name="comment_link_56562094" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562094" onclick="return D2.setFocusComment(56562094)" >Yes.</a>


		 	<span id="comment_score_56562094" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562094); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562094"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562094"><p>The logical value of (A or (not A)) is always True.</p><p>I am simplifying somewhat here because "better" is not the opposite of "worse" (we must also consider "equal"), however the probability of the situation being exactly equal is zero, so you get the same result.</p><p>You could also ask if it is better AND worse, and the answer would still be yes. Just as you could say Slashdot is both bad and good. There are plenty annoyances, but hey - after 20+ years I am still here reading, so it can't be all bad.</p><p>Some of these p<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562094">

</div>
</div>

<div id="replyto_56562094"></div>

<ul id="group_56562094">
	<li id="hiddens_56562094" class="hide"></li>
</ul>

</li><li id="tree_56562132" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56562132" class="commentstatus"></div>
<div id="comment_56562132" class="cw">
	<div id="comment_top_56562132" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562132" name="comment_link_56562132" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562132" onclick="return D2.setFocusComment(56562132)" >Security Tech and the Orwellian society</a>


		 	<span id="comment_score_56562132" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562132); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MindPrison">MindPrison</a>  <span class="uid"><a href="//slashdot.org/~MindPrison">( 864299 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562132">		
		on Sunday May 06, 2018 @02:40AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562132">#56562132</a>)
		<small><a href="//slashdot.org/~MindPrison/journal/" title="Friday February 24, 2012 @02:44PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562132"><p>First we have to ask ourselves, what is security?</p><p>Security, as in locked doors, encrypted drives, encrypted mail and digital wallets?</p><p>Or...</p><p>Security as in personal security (the rights to roam free and pursue our own dreams), free from oppressors, freedom of speech, information freedom.<br>In a time of fake news where it's possible to manipulate another country just by doctoring the news and opinions of the masses, this is certainly not good.<br>Another bad is that if we take away our freedom of speech, we get less say - and the power handed to a privileged few, aka "your" chosen government.</p><p>Internet gave us a lot of freedom. We could exchange information faster than ever before, play games with our friends overseas, book travels and earn money no matter were you where in the world.</p><p>But it also blinded us, with information this fast, there was no time for peer reviews of the news, what source can you truly trust? "Likes" almost became the new "law". Getting likes was almost like the new religion, and nevermind the reliability of the actual sources, just as long as a bunch of likes came along, and the rest thought "meh...might as well join the crowd", and what crowd? These are just numbers. A very real but dangerous development.</p><p>Time to take a step back - and understand that we should keep this technology free, putting too many locks on it also censors our freedom of speech, but security starts with us, we need to educate ourselves and not trust everything blindly. Turn off the net, breathe - go out there, say hi to your neighbor once in a while, talk amongst yourselves.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562132">
<span class="ind"></span><a id="reply_link_56562132" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562132" onclick="D2.replyTo(56562132); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Security Tech and the Orwellian society by MindPrison @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562132" data-title="Security Tech and the Orwellian society">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Security Tech and the Orwellian society by MindPrison" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562132" data-title="Security Tech and the Orwellian society">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Security Tech and the Orwellian society by MindPrison" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562132" data-title="Security Tech and the Orwellian society">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56562132" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56562132" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562132" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56562132"></div>

<ul id="group_56562132">
	<li id="hiddens_56562132" class="hide"></li>
</ul>

<ul id="commtree_56562132"><li id="tree_56563390" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563390" class="commentstatus"></div>
<div id="comment_56563390" class="cw">
	<div id="comment_top_56563390" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563390" name="comment_link_56563390" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563390" onclick="return D2.setFocusComment(56563390)" >Re:</a>


		 	<span id="comment_score_56563390" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563390); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~UnknownSoldier">UnknownSoldier</a>  <span class="uid"><a href="//slashdot.org/~UnknownSoldier">( 67820 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563390"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563390"><p>&gt; "Likes" almost became the new "law".</p><p><span class="substr"> </span> <i>The Orville</i> even did an episode on that: <a href="http://www.denofgeek.com/us/tv/the-orville/268556/the-orville-episode-7-review-majority-rule" title="denofgeek.com">Majority Rule</a> [denofgeek.com] (aired in 2017) which was a repeat of a <i>Black Mirror</i> episode <a href="https://en.wikipedia.org/wiki/Nosedive" title="wikipedia.org">Nosedive</a> [wikipedia.org] (aired in 2016), which is similar to a <i>Community</i>, <a href="https://en.wikipedia.org/wiki/App_Development_and_Condiments" title="wikipedia.org">App Development and Condiments</a> [wikipedia.org] (aired in 2014)</p><p>It's actually worse then that.  Security (or the lack of it) -- whether it be public security (prevention of intrusion) or personal security (protecting your rights) -- can be summarized with two phrases and how they are linked:</p><p>1. <b>Follow the money</b>, a</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563390">

</div>
</div>

<div id="replyto_56563390"></div>

<ul id="group_56563390">
	<li id="hiddens_56563390" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562136" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562136" class="commentstatus"></div>
<div id="comment_56562136" class="cw">
	<div id="comment_top_56562136" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562136" name="comment_link_56562136" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562136" onclick="return D2.setFocusComment(56562136)" >Mis-allocated energies</a>


		 	<span id="comment_score_56562136" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562136); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562136"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562136"><p>Time spent protecting operating systems from possible bad behaviour of applications is time wasted.</p><p>The current state of Operating Systems is akin to having only single phase AC power, but no fuses or circuit breakers anywhere in the system.  Because applications are trusted with everything, any bug can result in the wholesale mis-direction of everything down the wrong path. Most (but not all) of our problems with security result from this misplaced trust.</p><p>It's probably going to be another decade before capab<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562136">

</div>
</div>

<div id="replyto_56562136"></div>

<ul id="group_56562136">
	<li id="hiddens_56562136" class="hide"></li>
</ul>

<ul id="commtree_56562136"><li id="tree_56563038" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563038" class="commentstatus"></div>
<div id="comment_56563038" class="cw">
	<div id="comment_top_56563038" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563038" name="comment_link_56563038" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563038" onclick="return D2.setFocusComment(56563038)" >Re: Mis-allocated energies</a>


		 	<span id="comment_score_56563038" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563038); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563038"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563038"><p>The current state of things is like having fuses designed into equipment, but then finding that somebody has shoved a 30 amp fuse into the holder. I find that from time to time now on equipment I am repairing. Sometimes it causes dramatic equipment failure.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563038">

</div>
</div>

<div id="replyto_56563038"></div>

<ul id="group_56563038">
	<li id="hiddens_56563038" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562172" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562172" class="commentstatus"></div>
<div id="comment_56562172" class="cw">
	<div id="comment_top_56562172" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562172" name="comment_link_56562172" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562172" onclick="return D2.setFocusComment(56562172)" >Security is a side effect of good code..</a>


		 	<span id="comment_score_56562172" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562172); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~zynthaxx">zynthaxx</a>  <span class="uid"><a href="//slashdot.org/~zynthaxx">( 725359 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562172"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562172">Security mainly boils down to &#226;think about the consequences before implementing something&#226;, and &#226;clean up your own mess to avoid introducing accidental consequences&#226;.
If a developer lacks these habits, they will write broken software from more perspectives than just security.</div>
	</div>

	<div class="commentSub" id="comment_sub_56562172">

</div>
</div>

<div id="replyto_56562172"></div>

<ul id="group_56562172">
	<li id="hiddens_56562172" class="hide"></li>
</ul>

<ul id="commtree_56562172"><li id="tree_56563112" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563112" class="commentstatus"></div>
<div id="comment_56563112" class="cw">
	<div id="comment_top_56563112" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563112" name="comment_link_56563112" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563112" onclick="return D2.setFocusComment(56563112)" >Re: Security is a side effect of good code..</a>


		 	<span id="comment_score_56563112" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563112); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~krisdickie">krisdickie</a>  <span class="uid"><a href="//slashdot.org/~krisdickie">( 2535126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563112"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563112">This is the type of concept I was thinking about in asking the question and the point I was trying to touch on. More thoughtfulness, better code, better technology, happier people. But the answer 'yes', is also my favourite.</div>
	</div>

	<div class="commentSub" id="comment_sub_56563112">

</div>
</div>

<div id="replyto_56563112"></div>

<ul id="group_56563112">
	<li id="hiddens_56563112" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562218" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562218" class="commentstatus"></div>
<div id="comment_56562218" class="cw">
	<div id="comment_top_56562218" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562218" name="comment_link_56562218" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562218" onclick="return D2.setFocusComment(56562218)" >Better, but narrowly</a>


		 	<span id="comment_score_56562218" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562218); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cfalcon">cfalcon</a>  <span class="uid"><a href="//slashdot.org/~cfalcon">( 779563 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562218"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562218"><p>Much of the internet is built on a model of reasonably open trust.  This proved to not be a mistake, but a particularly galling one, which has required patch after patch.</p><p>The problem, as I see it, occurred starting in about the mid 90s.  At this point, what the internet actually was, was clear to all.  Making assumptions of trustworthiness in 1985 was still quite reasonable: it was possible that all meaningful internet connections were to continue to be monitored for bad behavior manually and actioned when a<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562218">

</div>
</div>

<div id="replyto_56562218"></div>

<ul id="group_56562218">
	<li id="hiddens_56562218" class="hide"></li>
</ul>

</li><li id="tree_56562242" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562242" class="commentstatus"></div>
<div id="comment_56562242" class="cw">
	<div id="comment_top_56562242" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562242" name="comment_link_56562242" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562242" onclick="return D2.setFocusComment(56562242)" >Prevent bad things from happening</a>


		 	<span id="comment_score_56562242" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562242); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~blackhedd">blackhedd</a>  <span class="uid"><a href="//slashdot.org/~blackhedd">( 412389 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562242"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562242"><p>As a cybersec professional of many years tenure (and now an exec at one of the major firms), I have to admit I've asked this same question many many times. If we didn't need to put so much effort into security, and instead put it into features with direct customer benefits, wouldn't we all be better off?</p><p>I think the OP approaches the answer to his question when he refers to preventing bad things from happening. A basic part of engineering is system robustness, resiliency and safety. We don't question the eff<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562242">

</div>
</div>

<div id="replyto_56562242"></div>

<ul id="group_56562242">
	<li id="hiddens_56562242" class="hide"></li>
</ul>

<ul id="commtree_56562242"><li id="tree_56563074" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563074" class="commentstatus"></div>
<div id="comment_56563074" class="cw">
</div>

<div id="replyto_56563074"></div>

<ul id="group_56563074">
	<li id="hiddens_56563074" class="hide"></li>
</ul>

</li><li id="hidestring_56562242"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562242">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562292" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56562292" class="commentstatus"></div>
<div id="comment_56562292" class="cw">
	<div id="comment_top_56562292" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562292" name="comment_link_56562292" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562292" onclick="return D2.setFocusComment(56562292)" >anonymity</a>


		 	<span id="comment_score_56562292" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562292); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bigtreeman">bigtreeman</a>  <span class="uid"><a href="//slashdot.org/~bigtreeman">( 565428 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562292">		 &lt;<a href="mailto:coltree%40%40%40tpg...com...au">coltree@@@tpg...com...au</a>&gt;
		on Sunday May 06, 2018 @04:09AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562292">#56562292</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562292"><p>anonymity and security,<br>can't have both<br>if criminals know they will be identified and caught they will be less likely to offend.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562292">
<span class="ind"></span><a id="reply_link_56562292" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562292" onclick="D2.replyTo(56562292); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="anonymity by bigtreeman @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562292" data-title="anonymity">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="anonymity by bigtreeman" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562292" data-title="anonymity">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="anonymity by bigtreeman" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562292" data-title="anonymity">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56562292" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56562292" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562292" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56562292"></div>

<ul id="group_56562292">
	<li id="hiddens_56562292" class="hide"></li>
</ul>

<ul id="commtree_56562292"><li id="tree_56563108" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563108" class="commentstatus"></div>
<div id="comment_56563108" class="cw">
	<div id="comment_top_56563108" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563108" name="comment_link_56563108" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563108" onclick="return D2.setFocusComment(56563108)" >Re: anonymity</a>


		 	<span id="comment_score_56563108" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563108); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563108"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563108"><p>There is something to be said for woeking at a really small company, or on a small team secured ay somewhere. Therw is far, far less anonymnity, but things are then looser and more free.</p><p>The place I am working has a 'news' bulletin that consists of a 'txt' file in a shared network folder. Everybody is expected to open and read and update it every day or so with notepad. The less computer adept have a shortcut to the file on their taskbar. It works because their are only 8 of us in the company. It's secure be<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563108">

</div>
</div>

<div id="replyto_56563108"></div>

<ul id="group_56563108">
	<li id="hiddens_56563108" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562310" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56562310" class="commentstatus"></div>
<div id="comment_56562310" class="cw">
	<div id="comment_top_56562310" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562310" name="comment_link_56562310" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562310" onclick="return D2.setFocusComment(56562310)" >Java Anecdote </a>


		 	<span id="comment_score_56562310" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562310); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tablizer">Tablizer</a>  <span class="uid"><a href="//slashdot.org/~Tablizer">( 95088 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562310">		
		on Sunday May 06, 2018 @04:17AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562310">#56562310</a>)
		<small><a href="//slashdot.org/~Tablizer/journal/" title="Saturday March 15, 2003 @02:22PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562310"><p>It's a rather open ended question, but here's an anecdote to consider. A lot of free and open-source software is written in Java. However, our security administrator set an aggressive policy on Java because of past Java security holes. Java-based applications run about 20x slower than they would without the aggressive scanning done on it by our security software.  It <b>makes such software virtually useless</b>. We either pay more for alternatives or go without. (I personally believe the security scanning software that starts with an "M" is poorly designed, but that's another topic.)</p><p>I cannot reliably say if our org's policy is too aggressive, because not getting things done may be just as bad as being hacked in the longer run.</p><p>Another oddity is that Microsoft is also leaky, but because we need <i>some</i> software to avoid going back to paper and pencils, Microsoft gets a pass that Java doesn't. It's crazy. Sometimes it feels the 90's were more productive because we didn't have consider security stuff. (That and stupid Web "UI" (non) standards.)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562310">
<span class="ind"></span><a id="reply_link_56562310" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562310" onclick="D2.replyTo(56562310); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Java Anecdote  by Tablizer @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562310" data-title="Java Anecdote ">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Java Anecdote  by Tablizer" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562310" data-title="Java Anecdote ">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Java Anecdote  by Tablizer" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56562310" data-title="Java Anecdote ">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56562310" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56562310" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56562310" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56562310"></div>

<ul id="group_56562310">
	<li id="hiddens_56562310" class="hide"></li>
</ul>

<ul id="commtree_56562310"><li id="tree_56564458" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56564458" class="commentstatus"></div>
<div id="comment_56564458" class="cw">
	<div id="comment_top_56564458" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56564458" name="comment_link_56564458" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56564458" onclick="return D2.setFocusComment(56564458)" >Re:</a>


		 	<span id="comment_score_56564458" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56564458); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DCFusor">DCFusor</a>  <span class="uid"><a href="//slashdot.org/~DCFusor">( 1763438 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56564458"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56564458">Doing without MS doesn't mean only paper and pencil as options....rilly? [sic].  I ditched windows around 2001 when I stopped running a company that fixed windows issues and wrote drivers for oddball hardware.  There are around 20 machines here, mostly linux, a couple apple, all work great.  Kinda diminishes any authority in the rest of your comment...</div>
	</div>

	<div class="commentSub" id="comment_sub_56564458">

</div>
</div>

<div id="replyto_56564458"></div>

<ul id="group_56564458">
	<li id="hiddens_56564458" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562346" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562346" class="commentstatus"></div>
<div id="comment_56562346" class="cw">
	<div id="comment_top_56562346" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562346" name="comment_link_56562346" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562346" onclick="return D2.setFocusComment(56562346)" >Worse, IMHO</a>


		 	<span id="comment_score_56562346" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562346); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Khyber">Khyber</a>  <span class="uid"><a href="//slashdot.org/~Khyber">( 864651 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562346"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562346"><p>Everyone has failed so hard at the first three levels of OSI through shitty programming that they rely upon several more layers of OSI to cover up for even shittier programming now.</p><p>Security comes through good programming practices, thorough testing, and sticking to KISS ideas.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562346">

</div>
</div>

<div id="replyto_56562346"></div>

<ul id="group_56562346">
	<li id="hiddens_56562346" class="hide"></li>
</ul>

</li><li id="tree_56562358" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562358" class="commentstatus"></div>
<div id="comment_56562358" class="cw">
	<div id="comment_top_56562358" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562358" name="comment_link_56562358" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562358" onclick="return D2.setFocusComment(56562358)" >Security as a pretext for surveillance</a>


		 	<span id="comment_score_56562358" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562358); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SigmundFloyd">SigmundFloyd</a>  <span class="uid"><a href="//slashdot.org/~SigmundFloyd">( 994648 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562358"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562358"><p>The problem with security is that it's used as a pretext for surveillance and spying. We get backdoored CPUs so our data and devices are no longer under our control. All in the name of security.</p><p>I'll choose freedom over security any day.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562358">

</div>
</div>

<div id="replyto_56562358"></div>

<ul id="group_56562358">
	<li id="hiddens_56562358" class="hide"></li>
</ul>

</li><li id="tree_56562374" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562374" class="commentstatus"></div>
<div id="comment_56562374" class="cw">
	<div id="comment_top_56562374" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562374" name="comment_link_56562374" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562374" onclick="return D2.setFocusComment(56562374)" >What About Food?</a>


		 	<span id="comment_score_56562374" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562374); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NicknameUnavailable">NicknameUnavailable</a>  <span class="uid"><a href="//slashdot.org/~NicknameUnavailable">( 4134147 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562374"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562374"><p><div class="quote"><p>This is obviously important, and I don't necessarily see it as a distraction, but rather a complex problem that has some added thrill to being solved. I can't help but wonder though if I (and my species) would have been X times more productive or have come up with some amazing new culture or technology, if we didn't have to deal with obtaining agricultural products.</p><p>In a utopian world, where there are no metabolic processes, we would have likely forfeited many of the farms and fisheries that have been put into place to prevent starvation from happening. So my question is -- are we more technically advanced because of the thoughtfulness that has gone into creating these systems?</p><p>Or are we just losing precious resources and time dealing with the necessity of fending off starvation?</p></div><p>Point being: OP is a euphoric tard.  Security is a natural consequence of game theory, you might as well stop coding if you don't want to deal with it.  It's no different than food or water for base survival - it's a result of existence.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562374">

</div>
</div>

<div id="replyto_56562374"></div>

<ul id="group_56562374">
	<li id="hiddens_56562374" class="hide"></li>
</ul>

</li><li id="tree_56562380" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562380" class="commentstatus"></div>
<div id="comment_56562380" class="cw">
	<div id="comment_top_56562380" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562380" name="comment_link_56562380" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562380" onclick="return D2.setFocusComment(56562380)" >Better off than with guns ...</a>


		 	<span id="comment_score_56562380" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562380); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Qbertino">Qbertino</a>  <span class="uid"><a href="//slashdot.org/~Qbertino">( 265505 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562380"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562380"><p>... that's for sure.</p><p><a href="https://youtu.be/0rR9IaXH1M0" title="youtu.be">https://youtu.be/0rR9IaXH1M0</a> [youtu.be]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562380">

</div>
</div>

<div id="replyto_56562380"></div>

<ul id="group_56562380">
	<li id="hiddens_56562380" class="hide"></li>
</ul>

</li><li id="tree_56562384" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562384" class="commentstatus"></div>
<div id="comment_56562384" class="cw">
	<div id="comment_top_56562384" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562384" name="comment_link_56562384" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562384" onclick="return D2.setFocusComment(56562384)" >In other news</a>


		 	<span id="comment_score_56562384" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562384); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hognoxious">Hognoxious</a>  <span class="uid"><a href="//slashdot.org/~Hognoxious">( 631665 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562384"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562384"><p>Cares would totally be much cheaper if we could make them from cardboard or something and like do away with brakes and all that shit.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562384">

</div>
</div>

<div id="replyto_56562384"></div>

<ul id="group_56562384">
	<li id="hiddens_56562384" class="hide"></li>
</ul>

<ul id="commtree_56562384"><li id="tree_56563124" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563124" class="commentstatus"></div>
<div id="comment_56563124" class="cw">
</div>

<div id="replyto_56563124"></div>

<ul id="group_56563124">
	<li id="hiddens_56563124" class="hide"></li>
</ul>

</li><li id="hidestring_56562384"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562384">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562510" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562510" class="commentstatus"></div>
<div id="comment_56562510" class="cw">
	<div id="comment_top_56562510" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562510" name="comment_link_56562510" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562510" onclick="return D2.setFocusComment(56562510)" >Betteridge's law of headlines:</a>


		 	<span id="comment_score_56562510" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562510); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562510"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562510"><p>No. And in this case "no" means you really shouldn't be asking this kind of question. The world is not better or worse, a specific application is, a specific scenario is.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562510">

</div>
</div>

<div id="replyto_56562510"></div>

<ul id="group_56562510">
	<li id="hiddens_56562510" class="hide"></li>
</ul>

<ul id="commtree_56562510"><li id="tree_56563134" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563134" class="commentstatus"></div>
<div id="comment_56563134" class="cw">
	<div id="comment_top_56563134" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563134" name="comment_link_56563134" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563134" onclick="return D2.setFocusComment(56563134)" >Re: Betteridge's law of headlines:</a>


		 	<span id="comment_score_56563134" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563134); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~krisdickie">krisdickie</a>  <span class="uid"><a href="//slashdot.org/~krisdickie">( 2535126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563134"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563134">Hey c'mon, we're only here to discuss the big picture</div>
	</div>

	<div class="commentSub" id="comment_sub_56563134">

</div>
</div>

<div id="replyto_56563134"></div>

<ul id="group_56563134">
	<li id="hiddens_56563134" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562564" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562564" class="commentstatus"></div>
<div id="comment_56562564" class="cw">
	<div id="comment_top_56562564" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562564" name="comment_link_56562564" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562564" onclick="return D2.setFocusComment(56562564)" >Security measures and amazing new concepts or feat</a>


		 	<span id="comment_score_56562564" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562564); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~najajomo">najajomo</a>  <span class="uid"><a href="//slashdot.org/~najajomo">( 4890785 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562564"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562564">"<i>I can't help but wonder though if I (and my team) would have been X times more productive or have come up with some amazing new concept or feature, if we didn't have to deal with implementing security measures</i>."<br> <br>

No, security has to be baked in at the design stage and would have no deleterious effect on the implementation of amazing new concepts or features. It's patently obvious that in the rush to get out new features the innovators failed to come up with a design that can't tell the difference between</div>
	</div>

	<div class="commentSub" id="comment_sub_56562564">

</div>
</div>

<div id="replyto_56562564"></div>

<ul id="group_56562564">
	<li id="hiddens_56562564" class="hide"></li>
</ul>

<ul id="commtree_56562564"><li id="tree_56563210" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563210" class="commentstatus"></div>
<div id="comment_56563210" class="cw">
	<div id="comment_top_56563210" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563210" name="comment_link_56563210" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563210" onclick="return D2.setFocusComment(56563210)" >Re:</a>


		 	<span id="comment_score_56563210" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563210); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563210"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563210"><p>NOTHING can tell the difference between<br>1&gt; a program deliberately written to do something bad,<br>2&gt; a program that does something bad by mistake</p><p>To make this determination requires solving the halting problem.  You can not pre-determine the intent of a non-trivial program. This is the root cause of most computer security issues.</p><p>What you can do, is to pre-determine which side effects of running the program you are willing to allow.  Most systems place NO limits on side effects of a program, however capabili<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563210">

</div>
</div>

<div id="replyto_56563210"></div>

<ul id="group_56563210">
	<li id="hiddens_56563210" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562638" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562638" class="commentstatus"></div>
<div id="comment_56562638" class="cw">
	<div id="comment_top_56562638" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562638" name="comment_link_56562638" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562638" onclick="return D2.setFocusComment(56562638)" >Who are the perilous few?</a>


		 	<span id="comment_score_56562638" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562638); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~VikingNation">VikingNation</a>  <span class="uid"><a href="//slashdot.org/~VikingNation">( 1946892 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562638"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562638">There are plenty of non software products where designers must incorporate elements of design that  to protect users.  For example: durable goods, small appliances, bridges, stairs. Vehicles, etc.  Software should be no different.</div>
	</div>

	<div class="commentSub" id="comment_sub_56562638">

</div>
</div>

<div id="replyto_56562638"></div>

<ul id="group_56562638">
	<li id="hiddens_56562638" class="hide"></li>
</ul>

</li><li id="tree_56562724" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562724" class="commentstatus"></div>
<div id="comment_56562724" class="cw">
</div>

<div id="replyto_56562724"></div>

<ul id="group_56562724">
	<li id="hiddens_56562724" class="hide"></li>
</ul>

<ul id="commtree_56562724"><li id="tree_56563148" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563148" class="commentstatus"></div>
<div id="comment_56563148" class="cw">
	<div id="comment_top_56563148" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563148" name="comment_link_56563148" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563148" onclick="return D2.setFocusComment(56563148)" >Re: Importance of human intel</a>


		 	<span id="comment_score_56563148" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563148); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563148"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563148"><p>The places where shrill and paranoid 'high tech security' are mandatory tend to burn themselves up.</p><p>Over time, secure and well adjusted people will come along and build anew on the scortched patches of land.</p><p>Some would say that containment and provision of weapons and combustibles to the 'problem spots' is a sufficient means of correction.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563148">

</div>
</div>

<div id="replyto_56563148"></div>

<ul id="group_56563148">
	<li id="hiddens_56563148" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562774" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56562774" class="commentstatus"></div>
<div id="comment_56562774" class="cw">
	<div id="comment_top_56562774" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56562774" name="comment_link_56562774" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56562774" onclick="return D2.setFocusComment(56562774)" >Utopia means NOWHERE</a>


		 	<span id="comment_score_56562774" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56562774); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56562774"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56562774"><p>And NOWHERE is there a lack of bad actors.</p><p>What a spectacularly stupid question.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56562774">

</div>
</div>

<div id="replyto_56562774"></div>

<ul id="group_56562774">
	<li id="hiddens_56562774" class="hide"></li>
</ul>

<ul id="commtree_56562774"><li id="tree_56563144" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563144" class="commentstatus"></div>
<div id="comment_56563144" class="cw">
	<div id="comment_top_56563144" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563144" name="comment_link_56563144" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563144" onclick="return D2.setFocusComment(56563144)" >Re: Utopia means NOWHERE</a>


		 	<span id="comment_score_56563144" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563144); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~krisdickie">krisdickie</a>  <span class="uid"><a href="//slashdot.org/~krisdickie">( 2535126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563144"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563144">Rule #1 - you haven't failed to medicate</div>
	</div>

	<div class="commentSub" id="comment_sub_56563144">

</div>
</div>

<div id="replyto_56563144"></div>

<ul id="group_56563144">
	<li id="hiddens_56563144" class="hide"></li>
</ul>

</li><li id="tree_56563162" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563162" class="commentstatus"></div>
<div id="comment_56563162" class="cw">
	<div id="comment_top_56563162" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563162" name="comment_link_56563162" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563162" onclick="return D2.setFocusComment(56563162)" >Re: Utopia means NOWHERE</a>


		 	<span id="comment_score_56563162" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563162); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563162"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563162"><p>Utopia means never bothering to ask about those really old  skeletons over there. Obviously reality self-corrected itself.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563162">

</div>
</div>

<div id="replyto_56563162"></div>

<ul id="group_56563162">
	<li id="hiddens_56563162" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562880" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562880" class="commentstatus"></div>
<div id="comment_56562880" class="cw">
</div>

<div id="replyto_56562880"></div>

<ul id="group_56562880">
	<li id="hiddens_56562880" class="hide"></li>
</ul>

<ul id="commtree_56562880"><li id="tree_56563192" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563192" class="commentstatus"></div>
<div id="comment_56563192" class="cw">
	<div id="comment_top_56563192" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563192" name="comment_link_56563192" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563192" onclick="return D2.setFocusComment(56563192)" >Re: Replacement for TCP/IP</a>


		 	<span id="comment_score_56563192" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563192); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bing+Tsher+E">Bing Tsher E</a>  <span class="uid"><a href="//slashdot.org/~Bing+Tsher+E">( 943915 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563192"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563192"><p>'More complex' can be the answer, but simplification also sometimes works.</p><p>Tearing out unneeded layers can improve security.</p><p>A piece of 'scorekeeping' equipment I work on for a sporting activity transmits to large displays for spectators and a judge's stand reciever . Originally I wondered why there wasn't more security in place, it just uses vanilla zigbee radio channels. Then I noticed that the communication protocol is simplex... and only the instrument that makes the actual measurement has transmit capabi<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563192">

</div>
</div>

<div id="replyto_56563192"></div>

<ul id="group_56563192">
	<li id="hiddens_56563192" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56563054" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563054" class="commentstatus"></div>
<div id="comment_56563054" class="cw">
</div>

<div id="replyto_56563054"></div>

<ul id="group_56563054">
	<li id="hiddens_56563054" class="hide"></li>
</ul>

</li><li id="tree_56563106" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563106" class="commentstatus"></div>
<div id="comment_56563106" class="cw">
</div>

<div id="replyto_56563106"></div>

<ul id="group_56563106">
	<li id="hiddens_56563106" class="hide"></li>
</ul>

</li><li id="tree_56563204" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563204" class="commentstatus"></div>
<div id="comment_56563204" class="cw">
</div>

<div id="replyto_56563204"></div>

<ul id="group_56563204">
	<li id="hiddens_56563204" class="hide"></li>
</ul>

</li><li id="tree_56563656" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563656" class="commentstatus"></div>
<div id="comment_56563656" class="cw">
</div>

<div id="replyto_56563656"></div>

<ul id="group_56563656">
	<li id="hiddens_56563656" class="hide"></li>
</ul>

</li><li id="tree_56563732" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56563732" class="commentstatus"></div>
<div id="comment_56563732" class="cw">
</div>

<div id="replyto_56563732"></div>

<ul id="group_56563732">
	<li id="hiddens_56563732" class="hide"></li>
</ul>

</li><li id="tree_56564280" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56564280" class="commentstatus"></div>
<div id="comment_56564280" class="cw">
	<div id="comment_top_56564280" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56564280" name="comment_link_56564280" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56564280" onclick="return D2.setFocusComment(56564280)" >Technological Darwinism</a>


		 	<span id="comment_score_56564280" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56564280); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Humbubba">Humbubba</a>  <span class="uid"><a href="//slashdot.org/~Humbubba">( 2443838 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56564280"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56564280">Security tech and it's mirror image, hacking, have been highly prized since 1943, when the codebreakers at Bletchey Park used a set of computers known as "Colossus"  to gain unauthorized access to information in an encrypted system. They hacked Germany's best security technology, the Lorenz Sz 40/42 cipher machines, aka "Tunny".
<p>
Since then, technology and its security systems have evolved dramatically. But so has hacking. Tools stolen from the NSA are now in the hands of those they were fighting. One has t<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56564280">

</div>
</div>

<div id="replyto_56564280"></div>

<ul id="group_56564280">
	<li id="hiddens_56564280" class="hide"></li>
</ul>

</li><li id="tree_56561854" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56561854" class="commentstatus"></div>
<div id="comment_56561854" class="cw">
</div>

<div id="replyto_56561854"></div>

<ul id="group_56561854">
	<li id="hiddens_56561854" class="hide"></li>
</ul>

<ul id="commtree_56561854"><li id="tree_56562114" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562114" class="commentstatus"></div>
<div id="comment_56562114" class="cw">
</div>

<div id="replyto_56562114"></div>

<ul id="group_56562114">
	<li id="hiddens_56562114" class="hide"></li>
</ul>

<ul id="commtree_56562114"><li id="tree_56562410" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562410" class="commentstatus"></div>
<div id="comment_56562410" class="cw">
</div>

<div id="replyto_56562410"></div>

<ul id="group_56562410">
	<li id="hiddens_56562410" class="hide"></li>
</ul>

<ul id="commtree_56562410"><li id="tree_56563220" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56563220" class="commentstatus"></div>
<div id="comment_56563220" class="cw">
	<div id="comment_top_56563220" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563220" name="comment_link_56563220" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563220" onclick="return D2.setFocusComment(56563220)" >Re: Gaming has more investment, more of a WASTE o</a>


		 	<span id="comment_score_56563220" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563220); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Immerman">Immerman</a>  <span class="uid"><a href="//slashdot.org/~Immerman">( 2627577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563220">		
		on Sunday May 06, 2018 @10:53AM (<span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563220">#56563220</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563220"><p>Bull.  Music, art, dance, board games - these things exist in practically every culture in the the world, and have for at least several thousand years.  Poverty is no great impediment to entertainment.  Even in our hunter-gather days it's estimated that the average person only spent a few hours a day in survival-oriented activities.  Abject poverty, along with the idea that anyone should spend more than half their waking life at work, are purely modern constructs of greed-oriented society.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563220">
<span class="ind"></span><a id="reply_link_56563220" class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56563220" onclick="D2.replyTo(56563220); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=56562410" onclick="return D2.selectParent(56562410)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re: Gaming has more investment, more of a WASTE o by Immerman @slashdot" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56563220" data-title="Re: Gaming has more investment, more of a WASTE o">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re: Gaming has more investment, more of a WASTE o by Immerman" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56563220" data-title="Re: Gaming has more investment, more of a WASTE o">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re: Gaming has more investment, more of a WASTE o by Immerman" data-url="https://ask.slashdot.org/comments.pl?sid=12071956&cid=56563220" data-title="Re: Gaming has more investment, more of a WASTE o">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://ask.slashdot.org/comments.pl?sid=12071956%26cid=56563220" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56563220" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56563220" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56563220"></div>

<ul id="group_56563220">
	<li id="hiddens_56563220" class="hide"></li>
</ul>

</li><li id="tree_56563384" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563384" class="commentstatus"></div>
<div id="comment_56563384" class="cw">
	<div id="comment_top_56563384" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563384" name="comment_link_56563384" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563384" onclick="return D2.setFocusComment(56563384)" >Re:</a>


		 	<span id="comment_score_56563384" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563384); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~pete6677">pete6677</a>  <span class="uid"><a href="//slashdot.org/~pete6677">( 681676 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563384"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563384"><p>The fact that you had time to post that waste-of-space comment of yours proves that you are one of the "pampered first worlders".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563384">

</div>
</div>

<div id="replyto_56563384"></div>

<ul id="group_56563384">
	<li id="hiddens_56563384" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56562598" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562598" class="commentstatus"></div>
<div id="comment_56562598" class="cw">
</div>

<div id="replyto_56562598"></div>

<ul id="group_56562598">
	<li id="hiddens_56562598" class="hide"></li>
</ul>

<ul id="commtree_56562598"><li id="tree_56563176" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563176" class="commentstatus"></div>
<div id="comment_56563176" class="cw">
	<div id="comment_top_56563176" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563176" name="comment_link_56563176" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563176" onclick="return D2.setFocusComment(56563176)" >Re:</a>


		 	<span id="comment_score_56563176" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563176); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bert64">Bert64</a>  <span class="uid"><a href="//slashdot.org/~Bert64">( 520050 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563176"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563176"><p><div class="quote"><p>Warner Bros and Disney will keep pumping out movies while the people who work on it are slowly drained of their time and wealth by the companies they work for, and the people who buy the worst of their products will keep producing "a market" for that slop.</p></div><p>Worse than that, disney keep selling the same movies again every few years, each time targeting new kids with the same old crap rather than making any effort to create any new content.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563176">

</div>
</div>

<div id="replyto_56563176"></div>

<ul id="group_56563176">
	<li id="hiddens_56563176" class="hide"></li>
</ul>

</li><li id="tree_56563234" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563234" class="commentstatus"></div>
<div id="comment_56563234" class="cw">
	<div id="comment_top_56563234" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563234" name="comment_link_56563234" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563234" onclick="return D2.setFocusComment(56563234)" >Re:</a>


		 	<span id="comment_score_56563234" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563234); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Immerman">Immerman</a>  <span class="uid"><a href="//slashdot.org/~Immerman">( 2627577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563234"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563234"><p>Sure it's a timesink - but there's no need for constant labor, it'd be a complete waste.  We could give every person on the planet adequate food, shelter, and medical care using only a small fraction of the current global productivity. After that, pretty much everything else is about either increasing future potential or entertainment.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563234">

</div>
</div>

<div id="replyto_56563234"></div>

<ul id="group_56563234">
	<li id="hiddens_56563234" class="hide"></li>
</ul>

<ul id="commtree_56563234"><li id="tree_56563784" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56563784" class="commentstatus"></div>
<div id="comment_56563784" class="cw">
	<div id="comment_top_56563784" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56563784" name="comment_link_56563784" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56563784" onclick="return D2.setFocusComment(56563784)" >Re:  Gaming has more investment, more of a WASTE o</a>


		 	<span id="comment_score_56563784" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56563784); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56563784"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56563784"><p>If only that were true.</p><p>A very small portion of global spending goes to entertainment.</p><p>Simple objectives don't meet simple methods to obtain them. You know how much time is wasted handling paper records? Well electronic ones solve that, but require industry to support them. It's actually a net positive but it diversifies the workforce.</p><p>We no longer spend most of our time farming, but to say the extra work is unnessecary is too simple minded.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56563784">

</div>
</div>

<div id="replyto_56563784"></div>

<ul id="group_56563784">
	<li id="hiddens_56563784" class="hide"></li>
</ul>

<ul id="commtree_56563784"><li id="tree_56564020" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56564020" class="commentstatus"></div>
<div id="comment_56564020" class="cw">
	<div id="comment_top_56564020" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56564020" name="comment_link_56564020" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;cid=56564020" onclick="return D2.setFocusComment(56564020)" >Re:</a>


		 	<span id="comment_score_56564020" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56564020); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Immerman">Immerman</a>  <span class="uid"><a href="//slashdot.org/~Immerman">( 2627577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56564020"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56564020"><p>Everything beyond food, shelter and (arguably) medical care is by its nature unnecessary.  *Desirable* maybe, but not necessary - and thus I would group it into some form of entertainment - science (satisfying intellectual curiosity = entertainment), dining out (spending less time cooking, more time focused on company = entertainment),etc.  And of course, lots and lots of busywork that produces very little of value other than jobs to keep people fed, and could be eliminated without any loss so long as the P<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56564020">

</div>
</div>

<div id="replyto_56564020"></div>

<ul id="group_56564020">
	<li id="hiddens_56564020" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="hidestring_56562114"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56562114">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56562190" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56562190" class="commentstatus"></div>
<div id="comment_56562190" class="cw">
</div>

<div id="replyto_56562190"></div>

<ul id="group_56562190">
	<li id="hiddens_56562190" class="hide"></li>
</ul>

</li><li id="hidestring_56561854"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56561854">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//ask.slashdot.org/comments.pl?sid=12071956&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">11 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//ask.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 33;
		D2.currents()['full']     = 9;
		D2.currents()['oneline']  = 58;
		// D2.currents_total(100);

		D2.abbrev_comments({56563170:529,56562082:529,56563108:522,56562564:526,56563192:529,56562094:536,56563766:498,56562242:522,56562908:523,56564280:515,56562142:512,56562120:901,56562062:529,56562218:522,56563210:537,56562382:529,56562136:529,56562550:536,56563390:51,56564020:515});
		D2.noshow_comments([56561966,56561992,56562956,56562046,56562408,56562864,56563110,56563464,56563688,56563582,56563466,56563510,56561878,56561998,56561902,56561940,56562102,56562126,56562284,56563044,56562068,56563074,56563124,56562724,56562880,56563054,56563106,56563204,56563656,56563732,56561854,56562114,56562410,56562598,56562190]);
		D2.pieces_comments([56561876,56561922,56563190,56562908,56562978,56561880,56561888,56562056,56561908,56561938,56563766,56562054,56563196,56562120,56562306,56562382,56563206,56562422,56562644,56563170,56562742,56563616,56562048,56562062,56562142,56562550,56562082,56562094,56563390,56562136,56563038,56562172,56563112,56562218,56562242,56563108,56564458,56562346,56562358,56562374,56562380,56562384,56562510,56563134,56562564,56563210,56562638,56563148,56562774,56563144,56563162,56563192,56564280,56563384,56563176,56563234,56563784,56564020]);
		D2.init_hiddens([56561992,56561922,56562864,56562408,56562908,56562978,56563466,56561876,56561898,56562284,56562126,56562102,56562054,56562242,56562384,56562114,56561854,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(340570);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>808<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/17/06/12/0136253/ask-slashdot-will-python-become-the-dominant-programming-language?sdsrc=popbyskidbtmprev">Ask Slashdot: Will Python Become The Dominant Programming Language? </a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>736<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/17/09/18/1431245/ask-slashdot-what-would-happen-if-a-hyperloop-train-failed?sdsrc=popbyskidbtmprev">Ask Slashdot: What Would Happen If a Hyperloop Train Failed?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>694<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/17/08/16/1416258/ask-slashdot-female-engineers-could-you-please-share-your-thoughts-on-the-google-memo?sdsrc=popbyskidbtmprev">Ask Slashdot: Female Engineers, Could You Please Share Your Thoughts On the Google Memo</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>660<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/17/07/13/200201/ask-slashdot-why-do-so-many-of-you-think-carrying-cash-is-dangerous?sdsrc=popbyskidbtmprev">Ask Slashdot: Why Do So Many of You Think Carrying Cash Is 'Dangerous'?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>593<span class="hide"> comments</span></span></span><a href="//ask.slashdot.org/story/18/03/23/2030231/ask-slashdot-is-beaming-down-in-star-trek-a-death-sentence?sdsrc=popbyskidbtmprev">Ask Slashdot: Is Beaming Down In Star Trek a Death Sentence?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/18/05/05/0437244/facebook-exec-admits-no-real-understanding-for-the-scope-of-fake-news?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/facebook_64.png" width="64" height="64" alt="Facebook"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/18/05/05/0437244/facebook-exec-admits-no-real-understanding-for-the-scope-of-fake-news?sdsrc=nextbtmprev">Facebook Exec Admits 'No Real Understanding' for the Scope of Fake News</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>123<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/18/05/05/1925251/new-hyperloop-cargo-company-promises-deliveries-at-600-mph?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/18/05/05/1925251/new-hyperloop-cargo-company-promises-deliveries-at-600-mph?sdsrc=prevbtmprev">New Hyperloop Cargo Company Promises Deliveries at 600 MPH</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>149<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//ask.slashdot.org/comments.pl?sid=12071956&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">105</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>I put up my thumb... and it blotted out the planet Earth.
		-- Neil Armstrong</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2018 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			//$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
    //announcement NEL
    if(document.getElementById('announcementText')){
      $('#announcementText').hide();
      var hlUrl = '/ajax.pl?op=hl_nel';
      if(nelId){
        hlUrl += '&nel_id='+nelId;
      }
      $.ajax({
        url: hlUrl,
        success: function(html){
          if(html.length < 10){
            $('#announcementText').show();
            return;
          }
          $('#announcementText').html(html).show();
        },
        error: function () {
          $('#announcementText').show();
        }
      });
    }

</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?276">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?655">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->